Question about 1994 GMC Sonoma

1 Answer

I have 4 cyln 5 speed gmc .truck just started skipping or motor hesitation under acceleration,i changed plug, wires,pcv valve.old plugs r white on the heads.i know its lean.please help .has anyone had same prob with a solution?i cant afford to **** money away on a bunch of could bes.thanks for help,,,,note.skip does not occer all the time but just seems to be getting worst

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 110 Answers

I hear you!

Bad input = Bad output

Start testing the computer inputs -

1) Air Charge Sensor (Resistance measurement - OHM meter needed)

2) Coolant Temp Sensor (Resistance measurement - OHM meter needed)

3) Crankshaft Sensor (Test procedures off the ignition amplifier)

4) Detonation Knock Sensor (This can cause your symptoms if there are any rattles in the motor or exhaust pipe - like a loose heat shield or bracket causing the rattle will be picked up by the knock sensor - which in turn retards the timing causing a stumble and hesitation)

5) MAP (Manifold Absolute Pressure) Sensor (make sure the plug contacts to it AND all of your other inputs are not corroded - also check the vacuum line going to the MAP and make sure there are no leaks, cracks....)

6) O2 Sensor (Would normally show up on computer as needing replacement - not always though )

7) Throttle Position Sensor (this is a variable resistor, which can and does get wear spots on it - sending incorrect voltages to computer causing your stated symptoms too. A good analog meter would be nice to test this. engine off, key on - You can tap into the voltage side and watch the needle carefully while slowly opening throttle to wide - and back to close. If the needle on the meter moves smoothly from one side to the other without and dips or jerking motions, then the TPS is fine - of course the voltages need to be within parameters)

You can find all of the testing procedures and vehicle specific data at alldatadiy.com

Good Luck.

Posted on Oct 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 305 gmc truck hesitates good egr and pcv valves


low speeds or passing if ac hose is running rite over where all the spark plug wires go it maybe leaking water on cap. rap with foam and replace cap

Aug 08, 2013 | GMC Cars & Trucks

1 Answer

2000 GMC Sierra V8 4.8L - I recently had my fuel pump & fuel filter replaced. I just changed my spark plugs and wires. Truck starts up fine, but it idles low now. When I'm driving it now hesitates...


What shape is air filter & pcv valve in? That and run a good fuel system cleaner through it - there seems to be ALOT of questionable fuel going around these days. Am hearing it from all over.

Apr 04, 2011 | GMC Sierra Cars & Trucks

1 Answer

97 ford expedition cutting off at idle . it was skipping and hesitating under strain . had it checked by a computer and it said egr valve and number 6 cylinder misfire . i changed egr valve , plugs, wires...


pull wire off # 2 see if idle changes if not there s no spark... test coil....test all vacuum lines for leaks also. if all good then idle speed sensor.

Mar 20, 2011 | 1997 Ford Expedition

1 Answer

Hi i have 94 sonoma 2 wh drive 4 cyln.just did tune up plugs wire pcv valve.engine has a studder or skip under acceleration and some losse of power when this happens.but doesnt happen all the time.spark...


im a chevy guy but i also know a bit about gmc and the one thing i can tell you is that both have problems with the distributer having to much play in it to check it you just pull off the cap and leave the rotor on and see if you cna move the shaft to either side replace it if it has play also check to make sure you have the gap in the plugs set right if its a sencer problem your check engine light will come on.

Oct 02, 2010 | 1994 GMC Sonoma

1 Answer

Hesitates slightly when accelerating at speed. Shows misfire in cylinder one.


first and formost, hit it with new plugs and wires, alot of times a misfire and poor performace simular to yours stems from a fouled plug, make sure your also up to date on you oil changes as well as that will cause a spark plug to fail, while changing your plug you can use a compression tool to make sure the valves and piston are working the way they should on that cylinder, but with a vehical under 10 years old, a good tune up will usually cure such a minor flare up, best of luck...

Mar 21, 2010 | 2003 Mazda MPV

1 Answer

Runs rough under load. Changed wires and coil pack, could it be MAS or motor mounts? or other.


Motor mounts would be mostly from low speed to high, as you accelerate, and there is the most reverse torque on the enging. At steady high speed you won't notice bad motor mounts much.

Fuel filter or pump comes to mind first, because you need the most fuel under load.

There are also a number of valves that could be causing loss of intake vacuum as well, such as EGR, purge valve, PCV valve.

Make sure spark is good and plugs good. A smaller gap will perform better, and only hurt mileage.

You can try cleaning the MAS sensor, and take a look at the oxygen sensor. These can be checked with an ohmmeter, but I don't have the actual values. But if you get 0 or infinite resistence, there is probably a problem.

Rough running often means it is isolated to one cylinder. Try removing one plugwire at a time to see if one makes no difference. Then try switching plugs to see if problem moves with plug.

Mar 04, 2010 | 2004 Volkswagen Passat

1 Answer

It skips when u hit 48 to57 miles an hour please help ive replaced the wires to the fule filter please help Ive also replaced the egr valve and the distibuter


Sir,
When your car seems to skip at what ever speed all you have to do is to check the Plugs and Plugs wires they must be missing the current that is why your Ride is skiping. all you have to do is to start the are and accelerate it without in gear. it will give a **** if missing.then the problem will be confirmed and you would be required to change it plug wire and plugs both.

Oct 25, 2009 | 1996 GMC Sierra

Not finding what you are looking for?
1994 GMC Sonoma Logo

350 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...