Question about 1995 Mercury Villager

1 Answer

My 95 mercury villager has no power accept for the dom lights, i had the ignition and main power wire to the starter make contact blowing something in the electrical system any idea were i should look, i have already checked fuses but still have no power to the dash or ignition system please help

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i got in my 97 mercury villager to start, i turned the ignition everything went black, there is power in the batterie


There should be a master link in the wiring from the battery. These wires are like fuses and melt to prevent further damage. You have a problem somewhere if this broke.

Apr 08, 2015 | 1997 Mercury Villager

3 Answers

My son has a 6 cyl. 95 Camaro that will not turn over. He said lights and accessories seem ok. What should he start checking first? Starter? Solenoid? Terminals?


what happens if the lights are on and he attempts to start? do lights dim or is there no change? If lights dim the ignition is making contact but the starter is not engaging ! If lights do not dim then the ignition is not making contact. start at the starter and check for ignition wire contact. a small 12 - 14 gauge wire. try to cross terminals on the selonoid and see if car will turn over, ( starter engage ) if it does then one of two things, selonoid is bad , or the ign wire is bad, some have a fusable link in-line check for one. you can check the ign wire by using a test light, ground to a good ground and while a helper turns key to start position test wire for power (test light lights ) if there is power then selonoid is most likely to be the culprit.Be sure to support car on jack stands or use two floor jacks or one floor jack and one bottle jack !!!! for safety reasons, of course if only one jack is used and it fails the possibilities of death is 98%, the possibilities of serious injury 100%. also keep fingers clear of all moving object in case something does engage causing movement.

Jan 14, 2011 | 1995 Chevrolet Camaro

1 Answer

My 95 mercury villager just stopped while i was pulling out of driveway and now it will not turn over.Is there a fuse or something.


check battery cable connections, especially the 2 smaller wires on the positive post. Clean them.

Aug 16, 2010 | 1995 Mercury Villager

1 Answer

No start


It sounds like you need to clean both battery cable connections on the battery and make sure they are not spread. You may have to cut off steel clamps and replace with lead kit. Also, clean the 2 smaller wires on the poitive post of the battery.

Go here for more help. We fix all Villagers with our expertise. Nothing we can't fix. Free too!

Jul 23, 2009 | 1995 Mercury Villager

2 Answers

95 Mercury Villager will not start


check/replace the starter relay switch in the relay box under the hood. The relay box is located on the front right of the engine compartment. easy fix, inexpensive part if that is the problem.

May 02, 2009 | 1995 Mercury Villager

1 Answer

95 mercuy villager wont start


you probably have a bad cable end on you battery cables where they connect to the battery. The steel clamps ****. replace with typical lead ends, @$6

Dec 05, 2008 | 1995 Mercury Villager

1 Answer

95 MERCERY VILLAGER WONT START


check the steel battery connections at the battery. Also check the 2 smaller wires at the ositive post too.
http://autos.groups.yahoo.com/group/villagerquest/

Dec 02, 2008 | 1995 Mercury Villager

1 Answer

2002 villager


It is connector c146B, 2 pin connector. there is a geen wire that provides the igniton tach signal. The other brown wire provides voltage from the ignition switch.

Oct 19, 2008 | 2002 Mercury Villager

Not finding what you are looking for?
1995 Mercury Villager Logo

Related Topics:

260 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...