Question about 2001 Chevrolet S-10

2 Answers

My brke lights dont work on my 2001 s10 but everything else works tail lights turn signals hazard lights and even the third brake light i have replaced bulbs, checked fuses and replaced the brake switch

Posted by on

  • tucker10470 Oct 03, 2010

    yes i checked grounds thanks i think i figured it out though i double checked all of my sighnals they still worked but when i checked my hazard lights they didnt work so i wiggled the hazard button they started working so i turned them off and checked my brake lights and they worked so i believe the problem is in the multi function switch or turn sighnal switch

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 3,072 Answers

I would check sockets to make sure they are not corroded, if they are not then I would start checking the actual wiring harness.

Posted on Oct 02, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 2,122 Answers

Did you check the grounding of the curuits?

Posted on Oct 02, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Turn signal,brake lights not working


I would check for voltage at the turn signal switch. The brake lights go thru the turn signal switch, except for the high mount light.

Jul 24, 2012 | Cars & Trucks

1 Answer

95 buick lights third light works and rear brake lights dont, turn signals work,tail lights work,new b.l swicth


Check your hazard button, you may have a bad flasher and it could be on causing the break lights not to work.

May 02, 2012 | 1995 Buick Riviera

1 Answer

My tail lights, turn signals, hazards and third brake light works, but my brake lights do not.


Check your brake lite bulb socket alot of times even a newer car will go bad from heat ing every time bulb comes on,,also check for grd on that socket, also should check brake lite swich on brake peddle

Mar 11, 2011 | Ford F-250 Cars & Trucks

1 Answer

Why taillights will not work when I turn my lights on. However they work when I brake so i know it is not the light bulbs. Also my turn signals do not work even though my hazards do.


Tail lights and brake lights are two seperate things . There are different bulbs for each. When you put your lights on does the front parK lights com on ? Usually the are on the same circuit as the tail lights. Check for fuse first.

Oct 22, 2010 | 2001 Toyota Camry Solara

1 Answer

Chevy S10. When my running lights are on everything works (except turn signals), front lights, tail lights brake lights. When I turn on my headlights turn signals still dont work everything comes on fine...


Check the grounds on your wiring.
If you have a trailer harness, make sure there are no shorts, or crusty connections

Good Luck chasing the gremlins

Oct 13, 2010 | 1996 Chevrolet K1500

1 Answer

Brakes Lights dont work on a 2006 Chevy Silverado


I've worked on these the first drove me crazy. its the turn signal switch every thing runs thru these. head lights, turn signal, brakes. except the third brake light. it runs directly from the brake switch. go figuare

Jun 22, 2010 | 2003 Chevrolet Tahoe

1 Answer

2001 GMC Jimmy break lights not working but all


Check the brake light switch should be a orange wire with 12v then a white wire with 12v when the pedal is pressed.If htat cks good then ck the hazard switch by moving it up and down and wiggeling the knob with the brake pedal pressed if they start working then your multifunction switch is bad and needs to be replaced.

Feb 20, 2010 | 2001 GMC Jimmy

7 Answers

1996 Chev Silverado K3500 dually, no brake lights


Check at the light socket in the rear, where your lights don't work. You need a test light or a voltage meter, and check to see that you have a groun there, power for your parking light, and power to the brake light. You should have power for the parking lights seeing that it works, and a ground. Just verify that your power for the brakes is getting to the bulb, or not. Just a good place to start.
And you are correct that if the third brake light works (top) your brake light switch is fine.

Aug 19, 2009 | 1996 Chevrolet C3500

1 Answer

Tail lights dont work


bulb(s) burnt out, or a bad ground wire

Mar 28, 2009 | 2005 Ford F 250 Super Duty

3 Answers

No turn signals or brake lights on left and right but brake light on top


I agree. My brake light dont work. Only the third brake light does. The running lights work but when i apply the brakes the rear tails dont light up.
I currently have this issue along with the signals dont work unless I bang the top of the steering colum. The hazard switch doesnt work either. If the signals dont work it makes this very quick clicking sound on the passenger side. I checked the fuses and they are good. The bulbs still work. The brake switch works cause the third brake light goes on. And seeing as I am having a problem with signals.....GM says I have to replace the switch in the steerg colume. Its a little box about the size of a cigarette pack. If you take apart the panels off ( right behind the steering wheel, where the hazard switch is) ...that is where it is located. Its plugged into the signal lever. Hope this helpa....Good luck everyone with this issue.

Oct 17, 2008 | 2001 Chevrolet Blazer

Not finding what you are looking for?
2001 Chevrolet S-10 Logo

258 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...