Question about 1999 Mercury Cougar

1 Answer

Want ilde changed the altrnater ,but everting back in .now the car will start but ildes rough if it ildes at all .

Posted by on

  • 2 more comments 
  • wormy13 May 26, 2008

    it will run a little rough when you give it gas

  • wormy13 May 26, 2008

    battery is new ,could it be the oxyen sensor on the exust,at the maniflod

  • wormy13 May 27, 2008

    did a code check,had 4 sensor bad. the manifold air temp. sensor,idle air control valve,oxygen sensor and coil-ignition performance. THANK YOU

  • Anonymous Mar 17, 2014

    moisture problems in oil and intake

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 148 Answers

How recently has it run well? if its been a while you may need to change out the fuel filter and clean the fuel system. Try the simplest first, fuel injector cleaner, regular tune up... If you are sure it has something to do with the electrical system then the cars computer should register a problem and give you a "check engine" light, if so then it would be possible to get the codes out of it to see which sensor to replace or where to plan further troubleshooting.  Remember if the alternator was bad at some point then the battery probably went with it, check the battery under load and replace it if needed. Also check the cabling harness to the battery to ensure it has a good connection. Pick up some contact cleaner from your local parts store and go though the electrical system to see if there is a corroded connection somewhere. Good Luck.

Posted on May 26, 2008

  • Will Kibler
    Will Kibler May 26, 2008

    if you are getting a check engine light the code readout would indicate the O2 sensor as the fault. You can try replacing it anyways.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Running rough


Probally needs to be tune up.

Nov 06, 2012 | 2001 Kia Sportage

1 Answer

2000 tacoma ildes rough ever so often?


TRY CLEANING THROTTLE BODY BORE AND IDLE AIR CONTROL

Dec 09, 2010 | Toyota Tacoma Cars & Trucks

1 Answer

After cool down motor only engages after prolonged starting;proceeds with rough ilde eventually runs normal 2005 f 350 deseil


test glow plugs if 6 liter on the side of the head test for electricity geting to them during glow plug cycle then test each one for continuity carfull study the plugs they are a little ****

Jul 12, 2010 | 2005 Ford F 350 Super Duty

1 Answer

Ilde rough


Check your idle air valve, maybe your air filter needs to be changed. EGR valve may need to be checked at as well.

Jul 21, 2009 | 2001 Ford Taurus

1 Answer

High ilde


Well first off if you know how far you backed off the idle screw put it back its all computer controled. Try checking for vacuum leaks

Jan 18, 2009 | 1999 Chevrolet Tahoe

1 Answer

Rough idel


Possible fuel injector cleaning required. Could also have oxygen sensors checked.

Nov 17, 2008 | 1994 Ford Thunderbird

2 Answers

Check Engine Lite


when was the last time the oil was changed on either one off these vechs. on the one hand the cam sensor is located in the timing cover with a spring, this will not cause a no start our dying problem but will set a cel light. if the egr passages is pluged up it will cause a egr problem hard start no start rough ilde. o2 sensor can cause a rough ilde but will also set a code . what is the mech condation off these vechs. run a commpession test and a vauccmn test. if these two items show bad readings our result. these two test should be done frist

Aug 28, 2008 | 1988 Oldsmobile Delta 88

Not finding what you are looking for?
1999 Mercury Cougar Logo

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

63661 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...