Question about 2000 Ford Focus

1 Answer

I have a 2000 mondeo 1.8. when stationary the engine revs ok. when moving. hot or cold it will only do 60mph max and it takes 60 secs to do that. when it comes to a hill its max speed is 15mph when i put my foot down it just splutters, at this point the engine is not at high revs so its not the clutch slipping. Any ideas, cheers.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 90 Answers

Sounds like a fuel restriction, change fuel filter first then pump if neaded,

Posted on Sep 30, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine idles at 1000 RPMs.At 60 MPH 2000 RPM's.Is this normal?


the 4.0L engine?
is this engine cold or hot.
why is 2000 rpm wrong for 60mph., (depends on engine and axle size and what gear you were in , then)

the idle speed for hot is too high
did you scan the PCM yet?
if hot , idle is high, is the thermostat holding water temp 180f or above. ? if not that is the problem.

Aug 23, 2016 | 1996 Jeep Grand Cherokee

1 Answer

The heater on my 02 mondeo takes about 30 minutes to start working properly, if I put the blower on too soon the temperature gauge shoots down, any ideas?


It sounds like the thermostat is stuck open. The thermostat is closed until the coolant in the engine gets heated up. Once it get hot, the coolant is cycled to the radiator to be cooled by air passing thru it. The coolant that was in the radiator is cycled to the engine where it is heated - or more properly termed, is used to cool the engine to keep it from overheating and seizing. The heated coolant is used to provide heat for the cabin in cold months.

Heres a video showing the job on a 2001 Mondeo and should be pretty similar job.
Ford Mondeo 1 8 Lx 2001 Thermostat Replacement

Feb 05, 2015 | Cars & Trucks

1 Answer

Hyundai Elantra 1999 GL


run the fault codes to find the sensor that is at fault

Sep 08, 2014 | 2000 Hyundai Elantra

1 Answer

Car will not move 2000 acura 3.2


ok you crank the engine over, it starts,
it can rev. to 3000 rpm for 1 second in park ?
y/n?
you then select, all gears forward and reverse and car can not move on flat ground, all brakes off?
can you push car in neutral on flat ground, , y/n ?

if no, brakes are bad. (or something more serious , ask)
if yes, tranny is dead (but....)

the if RPM rises, on engine (right foot action) and car MPH is 0
and rpm keeps rising that is a bad tranny (called slip or flare) in "D"
if you set the brakes hard,
and do the A/T stall test. (read the FSM)
and the RPM is way low that is a bad engine. (weak engine power)

if the RPM is good, stall tested. the engine and tranny are working. ( brakes stuck or frozen in ice?)
if the RPM flares, at stall test. it's a bad tranny
do the stall test for 5 sec max. rest for 15min and repeat.
STALL, test, makes tons of ATF heat. and heats the TC big time
RTM, it's all there. See FSM and read the manual.

Nov 23, 2013 | 2000 Acura TL

1 Answer

Mercedes e 320 cdi engine revs ok but will not engage reverse or drive to move


Just bought S 320 cdi , drives very well, but when starting engin cold , it only moves on R or D when I rev up to 2000 rpm , then drives normally , but if Istop the car , pull off again it goes very softly on 800 or 900 rpm . So the problem is the first start only. Is that normal or there is something wrong..advice me guys , Thak you

Aug 07, 2013 | Cars & Trucks

1 Answer

2000 plymouth neon, heat not working. heats only when car is moving? Please help!!!!


sounds like poor circulation of engine coolant. When stationary, if you increase the engine revs, does it blow hot ? if so, then i think it may be the water pump, that needs to be replaced. Have you lost any engine coolant, low level would also cause this problem. If so, then you need to see where you are losing the water and rectify that. Hope this helps

Jan 11, 2010 | 2000 Plymouth Neon

2 Answers

Engine revving


try cleaning the petrol cap. it breaths round the key hole. i boiled mine. sometimes if there is not enough air in the tank. pure fule goes into the carb. and makes the car race. take fule cap and boil it in water. you can use steradent in cold water if you prefer. muck gets stuck in them.
liz.

Mar 07, 2009 | 2000 Renault 181

1 Answer

'93 940 no turbo engine stuck at max RPM


YOU IDLE CONTROL VALVE IS GOING BAD ON YOU. TRY TO CLEAN IT BUT BEST TO JUST REPLACE. LOCATED UNDER INTAKE MANIFOLD

Dec 23, 2008 | 1993 Volvo 940

1 Answer

Heater only blows hot (well, warm) on full speed of fan


Replace the temp control on this car, it should be electrical control not cables.

Dec 03, 2008 | 2000 Ford Escort

Not finding what you are looking for?
2000 Ford Focus Logo

152 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...