Question about 1999 Pontiac Grand Prix

4 Answers

Just installed maf sensor and when you start the engine it won't stay on unless you press the gas pedal to raise the engine so it will keep running, after awhile it will stay on an runs good. What can we do to set it back correctly so when you start the motor it will stay on without stepping on the gas pedal???

Posted by on

  • cheap repair Sep 29, 2010

    did you clean the idle air control valve? if not, remove it and clean with a can of spray carb cleaner, clean the hole it came out of and clean the throttle plate area

×

Ad

4 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Pontiac Expert
  • 328 Answers

Try pulling idle air control valve on the throttle body and clean it

Posted on Mar 21, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Pontiac Master
  • 14,585 Answers

3.4 engine, Use a tooth brush and brake clean to clean the throttle body. Clean inside it and on the back side of the throttle plate. Then start the car with the plenum unhooked. Rev the engine up and spray some brake clean in the throttle, keep it running. If you have the 3.8, remove the throttle body and clean the back side of it. Still open the plate and clean around where it sets (same with the 3.4). Put it back on, then spray inside while the engine is running. Also check your air filter. Really dirty, replace it.

Posted on Mar 21, 2015

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

  • Contributor
  • 3 Answers

Could it be that you, on cleaning the inside of the air chamber, refitted everything and .... left a cleaning cloth in there? I did (once!).
Also.. check for an air vacuum leak or a sender wire not re-connected properly or was dirt filled.

Posted on Mar 20, 2015

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Pontiac Master
  • 14,036 Answers

KEEP ENGINE RUNNING UNTIL IT GETS OPERATING TEMPERATURE.KEEP ACCELERATING IT.IT WILL STAY RUNNING THE PCM HAS TO RELEARN THE NEW PART.

Posted on Sep 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Dying, not starting after it's been warmed up. Runs beautiful on cold engine. Replaced plugs, wire, cap, rotor and crank position sensor, no luck.


Your car cold start valve puts more gas into the system keeping your engine running higher RPM. When you car warms up, the cold start valve will stop working and your car RPM will drop. What you could have is a vacuum hose disconnected which puts more air into your engine - therefore when you press on the gas pedal, your engine would shut off or you find lack of power and then shut off.

Mar 27, 2015 | Cars & Trucks

1 Answer

Engine wont start, unless I push the gas pedal and keep my foot on it.?


Could be a dirty throttle body, or a stuck idle air control valve.
Is the check engine light staying on now ?

Apr 23, 2013 | Toyota Highlander Cars & Trucks

2 Answers

My truck wont start unless i prime the carborator first, then it wont stay running unless i rev it high just before i put it in gear, or im accellerating...


To start with, you have a throttle body instead of a carburetor.
On that throttle body is a component called an air control valve.
That valve is how the computer controls the idle speed. It should open and close the air flow into the intake manifold as needed.
Is the check engine light on when you are driving ? Have you checked the fuel pressure ?

Jul 30, 2012 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

98 Expedition..5.4L 4WD..coded bank 1 bank 2....O2 sensors..LEAN....replaced both..no change..still same codes..now it won't stay running. Tried to code again..won't run long enough to get a c


all code readers will retrieve information stored while in the on position --doesnt need to be running ---when you rehook up scanner either resubmit or edit request with codes

Aug 15, 2017 | 1998 Ford Expedition

1 Answer

My van sedona 2005 after i stop it,it won't restart unless i press a few time on the gas pedal ,and also runs rough a bit what could be the cause of it.


May be the starter or fuel pump. Might not be getting gas after turning it off. the gas may be settling to fast into the fuel pump and none staying in the engine. My friends SUV does not start unless you pump the gas pedal. Not an expert but its what i know it could possibly be.

Apr 23, 2012 | 2005 Kia Sedona

1 Answer

When engine is cold and i try to start it won't completely start unless gas pedal is pushed half way, even then will not stay running, have to keep slight pressure on gas pedal to keep running. When...


Yes, your car has what is called a Cold Start Routine which is like a choke on the old cars. This is controlled by a water sensor and when the water is cold, it makes the fuel mix richer and speeds up the idle. When the water warms up, it disengages.

There are 2 water sensors, 1 for the dash gauge and a second for this control. Tell the parts guy you do not want the sensor for the gauge, but the computer sensor.

You might try to clean the MAF sensor in the Air bonnet and use Electronics cleaner. This part will adjust the fuel mix for the incoming Air temperature. Then I would check the Intake manifold for leaks.

Use either a water mist or approved choke cleaner(safe for plastic and rubber) and if you use chemicals cover painted surfaces from overspray. Spray around seams and vacuum lines while the engine is running. A change in RPM will indicate a leak is drawing in the spray. Then fix the leak.

Feb 01, 2011 | 1999 Ford Taurus

2 Answers

1997 ford expedition will start but wont stay running unless you hold your foot on the gas pedal. Replaced mass airflow sensor because that's the code that came up. Doesn't do it all the time.


if code keeps coming up re check sensor and connections and if not done replace air filter ----if good than check fuel prssure sometimes clodding fuel filter can cause same problem and set off sensor

Jan 04, 2011 | Ford Expedition Cars & Trucks

1 Answer

Car will start and engine will run but will not stay idling


fuel filter, tps sensor, maf sensor or fuel pressure regulator

Apr 21, 2009 | 1996 Jeep Grand Cherokee

1 Answer

1998 Ford Expedition wont stay running


it is probably the MAFS, the MAFS tells the computer how much air is coming in and if it is bad the ECU will not be able to work properly, it is an integral part of the system,

one way to check the MAFS is to unplug it and try to start the vehicle, if the problem is better then replace the MAFS


Edit: also try to clean the MAFS with brake cleaner, sometimes dirt and oil will cause a MAFS to act up, it may be hard to get to the sensor wires but if you take the MAFS all the way off of the vehicle and just spray the unit down well you should be able to clean any larger debris off of the sensor wire

Oct 02, 2008 | 1998 Ford Expedition

Not finding what you are looking for?
1999 Pontiac Grand Prix Logo

334 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...