Question about Chevrolet Suburban

1 Answer

Tbi unit spit gas when trying to start , backfire a little bit HELP

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 60 Answers

Sounds like you vehicle is out of time.Hope this helps
D.

Posted on Sep 28, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Missing and backfire.


Backfiring is usually associated with a lean condition. Is fuel pressure correct? Is this vehicle TBI and are both injectors working properly? If timing related it should spark rattle under load and the timing would be way out and not run/start well at idle

May 09, 2015 | 1995 GMC Sierra C1500

1 Answer

I drive a 1997 mercury sable, it's constantly backfiring almost to the point where it takes 10 minutes to start the car the sparkplug and wires were changed and yet it still backfires when trying to start...


This happens because it's not getting enough fuel into the cylinders at startup. The "squirter" in your carburetor is not squirting on the older ones, but for the '97 with EFI or TBI, the problem is that the computer is not putting it in cold start mode. Computers can only to what the sensors tell them to do. Problem here is your temperature sending unit/sensor is stuck in open,or warm position. Replace the temperature sending unit/heat sensor in the intake manifold and all will be well. Check first that the wire is even plugged on the sensor. That has happened.

Dec 01, 2014 | 1997 Mercury Sable

2 Answers

Backfire, Black smoke from exhaust, spitting and sputtering


If you have not replaced plugs start there A bad map sensor will also cause black smoke and poor running

Feb 15, 2014 | Dodge Durango Cars & Trucks

1 Answer

89 K5 Blazer 350 TBI cranks but won't start... the rad hose blew, i fixed it then the next day it bogged and backfired, ran fine cold, but when warmed up it would lose power and stall when trying


Have you checked Google I found this hopefully it's not your timing or it may be flooded but doubtful have you tried spraying starting fluid into the intake while cranking it

Jun 01, 2012 | Cars & Trucks

1 Answer

My 1990 olds calais just started running rough and backfiring a bit. it does this at idle and spits and kinda backfires when i hit the gas or when taking off til u get up to speed somewhat and then it...


NOT SURE ABOUT THE FLUID MAY BE WATER LEAKING BUT, I WOULD TRY TWO INEXPENSIVE THINGS FIRST.ONE IS CHOKE -N-THROLTLE BODY CLEANER AND A GAS TREATMENT.

Jul 19, 2011 | 1990 Oldsmobile Cutlass Calais

1 Answer

My ford was spitting and sputtering and backfiring. i changed the plugs and wires, made sure of the gap, and it ran fine for a few days . thought my problem was fixed and then it started doing it again...


Use a gas treatment with a full tank of premium gas and see if it clean out your fuel system. It could also be your MAF sensor. There are ways to clean them but you have to be careful not to damage it.

Jun 07, 2011 | 1994 Ford Ranger Supercab

1 Answer

95 gmc 5.7 spitting back and losing power after warmiing up


Have you checked fuel pressure? You said TBI so it needs to be around 11-12-13 psi

Sep 02, 2009 | 1995 Chevrolet Blazer

1 Answer

89 chevy beretta gt- surges at idle, backfires and hesitates


Hi! I had the same problem with my 88 2.8 Ltr. Had dirty fuel Injectors. Put in fuel Inj. cleaner in gas tank, after a couple of days, runs like a dream,no more problems. Give it a try. Take care,Leo B. Flushme@shaw.ca

Jan 03, 2009 | 1989 Chevrolet Beretta

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...