Question about 1994 Ford Explorer Limited

3 Answers

Runs rough when a load is put on the motor.

1994 ford explorer xlt 6cyl. Friend of mine is a mechanic and says its a wiring problem. The computer is getting no signal from the egr system. He checked everything and the computer still indicates no voltage from the egr system. Runs fine for the first few mins when cold, but once starts warming up, runs rough on acceleration, and especially once it shifts into overdrive. If I run it in 3, it runs smoother. I've tried to get a wiring diagram for the egr system, as I would replace the wiring if I know where and what. Also, the temp gauge on the dash only works every now and then, and 4x4 low range button doesent work (I dont us low range anyway) although 4x4 regular works fine. If I could get the engine running smoothly, I would be satisfied.

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

I have the same problems as your having, i put new plugs, wires, air filter, and fuel filter and its fine now, runs like a champ!! do u hear a miss sound when u get on the gas a lil??

Posted on Dec 01, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 208 Answers

The fact that it will idle well but lose power on acceleration is a symptom of a bad coil.
The low range button will only work when the car is at a complete stop, in park, and your foot on the brake. Only then will the car shift into 4WD low.

Posted on Jul 23, 2008

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 23 Answers

Chiltons or haynes manual found at any parts store

Posted on Jul 18, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Ford Explorer XLT Wants To Stall At Low Idle,, especially when at a stop light


How does it idle in park , does it run ruff or smooth? Are any lights lit on the dash , check engine etc. ? Could have a partially plugged IAC air passage .idle air control (IAC) valve ! The engine computer uses the IAC to control idle , when under a load such as when put into gear the computer raises the idle ! It does this by allowing more air to by pass the closed throttle into the engine raising the idle ! If these air passages clog they restrict the air flow an cause a idle problem ! Now if it runs ruff at idle in park you could have vacuum leak ! Rough Idle How to Fix Ford Taurus Engine Stalls at Stop Signs

Mar 19, 2015 | 2003 Ford Explorer

1 Answer

91 Explorer 6cyl XLT standard is super hard to start, the engine sounds muffled when starting and while running, quickly overheated once it was running, looses power when pressing accelerator.


Could be a clogged catalytic converter. It could also be a bad head gasket allowing some coolant to enter the cylinders. Check for milky grey oil.

Dec 18, 2011 | 1991 Ford Explorer

1 Answer

No heat after motor repair


check the vacuum line going to the heater control valve.it runs inline with the heater core hose coming from fire wall to behind the dashboard

Dec 17, 2011 | 2002 Ford Explorer

1 Answer

1997 Ford Explorer Power Seat Wiring


There are several options. It all depends on how bad you want the leather seats. You could disassemble the seats and transfer the upholstery from one seat to the other, or you could transfer the motor mechanisms from one seat to the other. The leather seats are most likely equipped with seat heater elements...there is no way you are going to get them to work without redesigning half of the vehicle, so you can either leave the heating elements out when you transfer the upholstery or just leave their respective connectors disconnected.

Nov 13, 2011 | 1997 Ford Explorer AWD

1 Answer

I have a 99 ford explorer and the power windows have stopped working fuse and relay are good. I can't locate the power window module, any suggestions would be helpful.


Same thing happened to my drivers side. I have a 1999 Ford Explorer XLT. Mechanic found a broken wire in the wiring boot that runs from the door to the body. Spliced wire back together. Fixed the problem.
Alvin

Apr 10, 2011 | 1999 Ford Explorer

1 Answer

Engine idles rough, I have new plugs, wires, air cleaner. Could it be air sensor and where would it be on 1998 Ford Explorer, 6cyl. .. Egine light stays on. I have tried to reset it, but it eventually...


what code are you getting when you check the obd2 computer usually the problem when an ford engine runs ruff check the tps sensor which is on the side of the throttle body opposite of the throttle cables tps stands for (throttle possitioning sensor)

Jul 08, 2010 | 1998 Ford Explorer

2 Answers

Firing order


that is true your firing order is wrong here is a link to a web sight that has all the 1998 explorers 6cyl just click on the one that your explorer is and it'll show you the correct firing order also make sure you have your plugs gaped right good luck.
http://autorepair.about.com/library/firing_orders/bl-ford-firing-98.htm

Mar 22, 2009 | 1998 Ford Explorer

1 Answer

Miss firing


could be a wire crossed, or it's out of time. since you used motorcraft plugs, did you set them properly to the correct gap? replacing plugs without gapping them can cause the sluggishness, out of time can cause the mis-fires and rough running.

Nov 27, 2008 | 1994 Ford F150 Styleside Supercab

Not finding what you are looking for?
1994 Ford Explorer Limited Logo

263 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...