Question about 1996 Nissan Quest

1 Answer

Van runs great until it heats up. generally about 15-20 min.

My van runs great and changes gears real smoothly until i drive it for about 15-20 min. and then it acts like it is running out of fuel. the trans. starts acting up and want down shift. i can put it in neutral and hold the accelerator to the floor and it feels like it is starving for gas. when i pull off the codes, it came up spark knock sensor, tps(which i replaced) and oxygen sensor. can you tell me what this sounds like to you. also the fuel pump does seem to be a little louder than normal.

Posted by on

  • 1 more comment 
  • Anonymous Jul 26, 2008

    Have the same problem.

  • zbprinting Jul 26, 2008

    Have the same problem in my Nissan Quest 1996.
    It runs approx. 15-20 min and then stops.
    How did you solve the problem in you van?

  • zbprinting Jul 26, 2008

    Have the same problem in my Nissan Quest 1996.
    It runs great approx. 15-20 min until it heats up and then stops.
     

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 359 Answers

I would check to see if your fuel pump is working properly maybe first try replacing the fuel filter and running a fuel treatment.

Posted on May 24, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1990 Chrysler New Yorker 5th avenue will not shift up past second gear.


Probly no one ever changed the trans fluid,now you did and its to late,But get a bottle of Lucas trans slip.cost about 12$ at walmart,put the whole bottle in the trans,it is really thick, so heat the bottle on a register for a good while so that it will pour right in in this cold wheather.Let car run for 20 min. than try driveing it.if it wont move,let it rin another 20 min. if it moves drive it around untill it starts driveing better ,might take up to 3 days to get moved through trans real good.It worked for me on 6 cars now

Feb 25, 2013 | 1990 Chrysler New Yorker

1 Answer

High RPM when changing gears


If it was me, the first step would be taking it to a transmission shop for a tranny-fluid change (unless you are a real wrench and can do it yourself). The transmission fluid can get dirty, breakdown from heat and/or general use/abuse, and the filter can become clogged.

Jan 15, 2013 | Cars & Trucks

1 Answer

I have a 04 voyager 2.8 and the auto box wont change above second- only happened since new battery , any ideas


Okay you will need to program the shift points again this is normal when battery voltage is lost, you will need to shift yourself and try to get it to shift when you want it to, what you do is remove the negitive battery terminal for 10 mins, then connect it back, start the van when you take off the shifter must be in low gear try to go slow until you have a straight away then accel and shift gears up until you hit the last drive gear make sure to shift as it use to or as close, dont rev to high before shifting as you shift up the computer stores the info and thats the way it will shift if you make a mistake unhook batttery again and try it again. i cant rememeber the exact shift points but i think you will know as its the van you drive, doesnt have to be perfect, for example start off in low and when you hit 15mph shift up a gear then ithink at 25 shift up and then 35 or 40mph shift and so on, you dont want the engine to rev to high between shifts it should be smooth but you you feel it a bit, hope this is helpful. let me know the out come, i do this all the time, dodge ,chrysler cars and vans. good day.

Sep 24, 2011 | 2004 Chrysler Voyager

1 Answer

When i start my van and put the gear on drive the van will not move until the gear is push to one or two then it will move


Hi!!
Check the transmission fluid level, here is how.
Engine running, move shifter one gear at the time until you get to one and then back to park, do this a couple of times and then check your fluid level. Also check for burnt smell on the fluid. Fluid should be of a pinkish color, if too dark, service transmission.
Good Luck!! A HELPFUL - 4 THUMBS - rating for this solution would be greatly appreciated. Thank you for using FixYa.

Nov 02, 2010 | 1991 GMC Safari

1 Answer

When putting van in gear the engine runs rough


how about putting the van in drive with one foot down hard on the brake and rev the engine, does it smooth out now? if it smooths out, i would pull the air cleaner tube to the throttle body and spray the throttle body with carb cleaner, be careful if using the red tube, I have had it blow off before into the intake, not good, open the accelerator and spray it out really good, it will to start until all the cleaner clears out.

Jun 29, 2010 | 1995 Pontiac Trans Sport

1 Answer

Van dies after 10 min drive when pulling into


Try removing the idle speed motor on side of throttle body, and spray it clean, as well as the port it came out of, with throttle body spray cleaner. Don't pull and extend shaft of idle motor, just leave it in position it's in, and make sure you don't lose small "O" ring on idle motor. Re-install and try it. If it cures it for a while, then starts to do it again, replace the idle speed motor.

Apr 03, 2010 | 1995 Plymouth Voyager

1 Answer

On my f150 5.0 it starts good cold but after i drive for awhile maybe 5 miles i shut it off and start it again it is ok.But if i wait 15 min it wont start.you can try but after it cools off it will start...


It could be a spark plug problem..I would remove a few of them to see what they look like. It may not be firing very well when it gets hot, and new spark plugs are never a real bad investment, since they're generally very cheap. Not sure on this, but it's a good place to check.

Jun 26, 2009 | 1996 Ford F150 Regular Cab

Not finding what you are looking for?
1996 Nissan Quest Logo

Related Topics:

289 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...