Question about 1995 Ford Aspire

1 Answer

Sending unit has no power

Unable to get power to the sending unit. Have checked reset button. Not the problem. Don't know if there is a fuse or a fuseable link somewhere. Any suggestions would be appreciated.

Posted by on

  • CathS Jun 10, 2008

    Similar problem. Car runs fine for 10 minutes or so at speed, then it coughs, and power fades. It idles fine, no weird noises, but won't accelerate. Fuel pump? Vacuum? Ideas?



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 625 Answers

Ok we the mechanics know the sending unit as a sensor inside the fuel tank and they do not get any power they get groun and send a regulated ground to teh fuel gage,
if this not answer your question please be more specific about what sending unit are you talking about

Posted on May 28, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

My horn & volume buttons under steering wheel stopped working on my 2007 Dodge Nitro. I checked the horn fuse & others & they all looked good. Any suggestions?

Do you have access to a horn wiring diagram for your vehicle? If so, check the applicable fuses for voltage when the horn button is actuated. Even if the fuse is good, if no voltage on the fuse circuit, the circuit is still dead. Use a test light to check voltage.
Check for applicable trouble codes. There is more than one module involved with horn operation. The instrument cluster knows when you hit the horn button then sends serial data message to integrated power module, then the power module sends voltage to horn fuse.
To troubleshoot any modules, you probably need a manufacturer specific scanner to communicate with modules.
The problem could be a hard wired circuit somewhere?

Dec 04, 2015 | Dodge Cars & Trucks

2 Answers

Hello my name is Christopher I have a 96 Chevy K 1500 5.7. my fuel pump isn't turning on. I have a new relay. good pump and wiring seems intact.I tried an experiment( carb swap) and removed the pump...

check that the earth wire is making good contact , when ignition off the relay should have power to one prong , does it ? the brighter light on one prong than the other does point to a earth problem though, i presume you have checked the fuse board , as you know some fuses feed thing's not mentioned , worth a check , keep me posted if you wish

Nov 03, 2014 | 1996 Chevrolet K1500

1 Answer

My fuel gauge is not working, have a 70 Dodge Challenger, have replaced sending unit in tank, dash unit, voltage limiter and checked continuity between wires to gauge and sending unit, and made sure dash...

Only thing I can tell, with all you've checked, is the power to the gage isn't there. If the tank sending unit ground to frame is not connected, the gage will go past the full mark. No power to the gage it will stay at empty side. Power goes from fuse to gage, gage to sending unit and back to gage. Make sure the fuse is good on both sides of it. The gage just isn't getting power from the fuse.

Jan 13, 2018 | Dodge Challenger Cars & Trucks

1 Answer

96 chevy k1500 5.7 runs good starts hard, turn it over and it wont start if i bump the starter a couple of times it will start then run good and will start no problem if it does not sit for a long period...

The problem on your vehicle is much more likely to be the oil pressure sending unit ore the fuel pump relay . The way the systems works is the fuel pump is supplyed by the fuse box fuse #9 but the cirrcuit splits and goes to the oil pressure sending unit in case the relay fails when your drivering the fuel pump will still have a power supply its stupid but its a safty thing that was mandated. If the fuel relay is NG the vehicle will still start but it takes the engine some time to build up enough oil pressure to trip the switch inside the sending unit to send volatge to the starter . Witch means slow starts long cranking times I would check the fuel filter first but realsticly if you don't know if the fuel pump has been replaced or you haven't done it your self this is vary likely the cause of the problem . If you have then try the oil pressure unit

Jul 23, 2011 | 1996 Chevrolet K1500

1 Answer

Where is the fuel pump reset button on a 2001 Lincoln Navigator SUV?

I see it's been 2 hours since you posted your question but am sending it to you anyway. See picture below for location. This should be in your owners manual if you have one. If you don't and would like a copy, you can email me at with your make, model and year and I will be happy to email you a copy. Don't worry no cost. I hope this helps and good luck. One other thing, if your not getting any fuel, have you checked your fuses as well because in the power distribution box (fancy name for a big fuse box) in the engine compartment if a fuel pump fuse and a fuel pump relay as well. I went on and gave you a picture of the layout of that fuse box and the fuse is in the number 10 position (20 amp) and the relay is in the number 301 position.


May 01, 2011 | Lincoln Navigator Cars & Trucks

1 Answer

2004 Pontiac Montana problems with my speedometer,gas,and temperature guages varied readings on the highway 120km plus the reading goes to 200km the gas meter sticks at 3/4 tank and the temp guage is...

It gets a little complicated here but I will tell you what it can be. Devective dash voltage regulator, lost ground at sending unit, break in wire going to the dash, bad sending unit. Check the fuse, may fix it. Other then that, you will have to check these parts. If you have another question, write me back. I will help the best I can. Thanks for choosing FixYa.

Feb 12, 2011 | 1999 Pontiac Montana

2 Answers

1999 nissan quest power window, seat and lock don't work can't find fuse or switch. Any one know which one it is?

My power window fuse don't work. the window goes down never came up
Any one can help me de to it please ?

Jun 25, 2010 | 1999 Nissan Quest

2 Answers

Where is power window control unit located

usually power windows have a relay that sends current to the windows due to the high current flow that the switch can not handle.
So, the switch works through a fuse and when you activate the switch it sends power to the relay. The relay then closes and sends power to the window motor. Look for a relay either in the fuse panel or in the engine compartment fuse/relay ox. check owner manual for location.

Mar 21, 2009 | 1986 Oldsmobile Ciera

Not finding what you are looking for?
1995 Ford Aspire Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts


Level 3 Expert

78010 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers


Level 3 Expert

5651 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides