Question about 2000 Alfa Romeo 156

2 Answers

Alfa 156 selespeed fault

Hi the fault only happens when the car as been driven for for 20 to 30 miles it will not change gear as it should1 and 2 are ok but will not fined 3rd or 4th going to 5th and i can then ghange back to 4th but sometimes can not fined a gear at all can you help

Posted by on

  • 2 more comments 
  • bobclock0 May 20, 2008

    hope sombody can help

  • zbimis1 May 21, 2008

    selespeed problem in alfa romeo 156...please advice...


    zbigniew


  • bobclock0 May 22, 2008

    hi ive drained the gear oil only 1 ltr came out and have put elf fully synthetic gear oil in 1.7 ltrs and seems to have solved the probblem but have only done about 70 miles on open roads ( not many gear changes ) and not in the towns but it dose seem better thanks for your time and knowledge regards bob

  • Anonymous Mar 13, 2014

    Alfa156 2ltr selespeed 2001-heater fan for passenger compartment not working, I think the switch itself is ok, any suggestions? regards, Heiko

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,102 Answers

Hi, it sounds like either your clutch needs replacing or the problem could just be that the gearbox needs oil this is best checking as the gearbox can sieze then this will be expensive to replace.
What you need to do is take it into garage and they will remove a plug on the gearbox with special tool then this tells them if the oil is low as some oil should come out of this lug if not then they will top this up for you hopefully solving your problem,
Having no oil in the gearbox could strip the gears and if its got to bad then these will need replacing but this is in the most severe of cases so hopefully your problem is just that the oil needs filling up so get this done and this will hopefully solve your problem.
If you have any problem then give me a shout or if you have any questions then give me a shout then ill be glad to assist you further.

Posted on May 20, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have Alfa romeo 156 2001 year old ND HAVE THE SAME PROBLEM APPARENTLY solved by onle of the alfa romeo authorised services but evet after the fluids were exchanged or topped up if required the selespeed control is still on indicating there seemes to be some problem.PLease advice.


zbigniew

Posted on May 21, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Only get 1, 2nd and reverse on my Alfa 156 selespeed 2000. Other gears i don't get. The selespeed light flash on the dash and gear indicator also flashing. What can cause this?


It may have a problem in the electronics that shift the transmission, have a fault code test run on the Transmission control module (TCM)

Sep 20, 2016 | 2004 Alfa Romeo 156

1 Answer

My alfa 156 selespeed wont go into third gear it just revs


Third is either striped out on the shaft or the shift arm is worn out. Either way it must come out. With that type of car, you don't want to take it to an amature who says "I always wanted to work on a transamision"

Hope you can find someone who knows what they are doing. Transmission experts are becoming rare.

Aug 20, 2009 | 2000 Alfa Romeo 156

1 Answer

Gears change without a command from the driver.


There is a vacuum controlled selector valve on the selespeed alfa's it tricky to get at and expensive to replace. Have it sent to an alfa specialist or main dealer and they ll sort it

May 05, 2009 | 2000 Alfa Romeo 156

1 Answer

Alfa Romeo Selespeed 156. How to drive uphill in traffic.


Left foot braking technique shold solve your problem!

Apr 19, 2009 | Alfa Romeo 156 Cars & Trucks

1 Answer

Alfa 156 selespeed no gears


hi have you checked your selespeed fluid ? as this can cause this regards bob

Jul 29, 2008 | 2000 Alfa Romeo 156

1 Answer

Selespeed gearbox fault


sorry mate now i get you. The fault could be with the ECU on the selespeed box this would need checking also click here
that is a forum that discusses problems with only that type of box so may be of some help to you.
Im still looking into your problem and have a few people i can talk to you so ill get back to you shortly ok.

May 28, 2008 | 2000 Alfa Romeo 156

Not finding what you are looking for?
Cars & Trucks Logo

1,561 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

yadayada
yadayada

Level 3 Expert

60667 Answers

Fabrice Wolters

Level 2 Expert

162 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...