Question about 2000 Ford Expedition

1 Answer

Accesory/Aux AC ports not working

I have a 2000 Expedition and both front and rear aux power ports are not working. I have checked the fuse and they are all good, and the cigarette lighter is also working. Can anyone offer any suggestions for a fix?

Posted by on


1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I was able to contact a local service man who works on vehicle electrical. He directed me to a fuse box on the left side of the engine compartment specifically the #1 and #4 fuses. He said the fuses will burn and that is a common problem with the aux power ports and their locations. inspecting and replacing the fuses ended up being the fix.

Posted on May 29, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Need location of rear blower relay 2001 expedtion

Here is the order of checking....

Power Distribution Box Description
Position 114 30AMP** for Climate Control Auxiliary Blower

** MaxiFuse

Passenger Compartment Fuse Panel
Position 7 5AMP for Aux A/C Blower Relay (via fuse 22)
Position 24 10AMP for EATC Module, EATC Blower Relay, Climate Control Switch Assembly (Feeds Fuse 7)

Also, additional details about fuses could find in

Hope helps.

Feb 04, 2011 | 2000 Ford Expedition

1 Answer

Where is the fruse for the left aux power connector below the radio -

The fuses for the auxilliary power outlets are located in the rear fuse panel located under the left second row seat.

The fuse for the console and two front outlets is fuse #46 (20 Amp) and is marked "AUX PWR 1"
The fuse for the rear power outlet is fuse #15 (20 Amp) and is marked "AUX PWR 2"

Dec 01, 2010 | 2003 Chevrolet TrailBlazer

1 Answer

My aux inport won't work on 2006 Land Rover LR3. Would this be something effected by a bad fuse?

No. Radio works off single fuse. Some aux ports have to be enabled by mode/source setting. Check your radio manual on how to turn on aux port.

Aug 23, 2010 | 2006 Land Rover LR3

1 Answer

Front two auxiliary power points not working on front console

Sounds like a bad fuse. Locate your Ford's fuse panel and check spots 15 and 26 (typical location for aux power points)

Good luck!

Jul 12, 2010 | 2003 Ford Expedition

2 Answers

My aux power points are not working. What is the

there are two auxillary power sockets. The console aux power socket is protected by fuse #4 in the battery junction box. The second aux socket located in the rear is protected by fuse #1 in the battery junction box. Both fuses are 20 amp fuses. The battery junction box is the fuse box located under the hood, usually on the driver side.

Feb 15, 2010 | 2001 Ford Expedition

1 Answer

2007 Chevy Uplander Rear Overhead A/C Vents Won't Work

Have you checked the Aux switch near the bottom of the center control console.
There should be a knob with: Aux, Off, 1, 2, 3. This is the switch for the rear AC blower.
If the driver wants to control the rear AC, use the 1, 2, 3 settings.
If you put it on Aux, Than the rear AC is controlled by the passenger in the back seat using the extra controls located on the Overhead DVD player. (The front AC must be on the rear to work)

Jul 09, 2009 | 2006 Chevrolet Uplander

1 Answer

"Accesory Power" outlet not working. Can't find fuse.

CIG LTR Fuse 15 amp located in the under hood fuse box. Plus AUX PWR 1 fuse 20amp also located in the underhood fuse box.

Sep 06, 2017 | 2006 GMC Sierra

1 Answer

Aux power outlets won't work

check fuses,also the socket it self could be wore out they are easy to replace,

Jan 15, 2009 | 2002 Chevrolet Tahoe

Not finding what you are looking for?
2000 Ford Expedition Logo

451 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts


Level 3 Expert

78010 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers


Level 3 Expert

5651 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides