Question about 2000 Ford Expedition

1 Answer

Accesory/Aux AC ports not working

I have a 2000 Expedition and both front and rear aux power ports are not working. I have checked the fuse and they are all good, and the cigarette lighter is also working. Can anyone offer any suggestions for a fix?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I was able to contact a local service man who works on vehicle electrical. He directed me to a fuse box on the left side of the engine compartment specifically the #1 and #4 fuses. He said the fuses will burn and that is a common problem with the aux power ports and their locations. inspecting and replacing the fuses ended up being the fix.

Posted on May 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Need location of rear blower relay 2001 expedtion


Here is the order of checking....

Power Distribution Box Description
Position 114 30AMP** for Climate Control Auxiliary Blower

** MaxiFuse


Passenger Compartment Fuse Panel
Position 7 5AMP for Aux A/C Blower Relay (via fuse 22)
Position 24 10AMP for EATC Module, EATC Blower Relay, Climate Control Switch Assembly (Feeds Fuse 7)


Also, additional details about fuses could find in ford.com/maintenance/owners_manuals

Hope helps.

Feb 04, 2011 | 2000 Ford Expedition

1 Answer

Where is the fruse for the left aux power connector below the radio -


The fuses for the auxilliary power outlets are located in the rear fuse panel located under the left second row seat.

The fuse for the console and two front outlets is fuse #46 (20 Amp) and is marked "AUX PWR 1"
The fuse for the rear power outlet is fuse #15 (20 Amp) and is marked "AUX PWR 2"

Dec 01, 2010 | 2003 Chevrolet TrailBlazer

1 Answer

My aux inport won't work on 2006 Land Rover LR3. Would this be something effected by a bad fuse?


No. Radio works off single fuse. Some aux ports have to be enabled by mode/source setting. Check your radio manual on how to turn on aux port.

Aug 23, 2010 | 2006 Land Rover LR3

1 Answer

Front two auxiliary power points not working on front console


Sounds like a bad fuse. Locate your Ford's fuse panel and check spots 15 and 26 (typical location for aux power points)

Good luck!

Jul 12, 2010 | 2003 Ford Expedition

2 Answers

My aux power points are not working. What is the


there are two auxillary power sockets. The console aux power socket is protected by fuse #4 in the battery junction box. The second aux socket located in the rear is protected by fuse #1 in the battery junction box. Both fuses are 20 amp fuses. The battery junction box is the fuse box located under the hood, usually on the driver side.

Feb 15, 2010 | 2001 Ford Expedition

1 Answer

2007 Chevy Uplander Rear Overhead A/C Vents Won't Work


Have you checked the Aux switch near the bottom of the center control console.
There should be a knob with: Aux, Off, 1, 2, 3. This is the switch for the rear AC blower.
If the driver wants to control the rear AC, use the 1, 2, 3 settings.
If you put it on Aux, Than the rear AC is controlled by the passenger in the back seat using the extra controls located on the Overhead DVD player. (The front AC must be on the rear to work)

Jul 09, 2009 | 2006 Chevrolet Uplander

1 Answer

Aux power outlets won't work


check fuses,also the socket it self could be wore out they are easy to replace,

Jan 15, 2009 | 2002 Chevrolet Tahoe

1 Answer

Aux cable snapped of inside external Audio port (AUX). an ideas on how to get the piece out? or does anyone now how to take the AUX port out of the console? 2008 crv, center console unit.


I have a 2007 CRV which had the same issue. I fixed this by:
- first removing the AUX port cover by carefully prying it up from both the rear-facing and front-facing edges. Once done, this exposes the AUX port mechanism itself.
- Using some needlenose plyers, I pulled out the AUX port component. It simply slides out.
- The trick now is to PUSH the broken piece out of the inside of the port. To do this, I first removed the "cover" that is covering the end of the port (opposite from the opening to the port). Be very careful with this step as you don't want to break the cover. It's very thin plastic.
- Once this cover is removed, I used a pin to push the piece that was lodged inside back out of the opening.
Reassembly was the opposite of this and was quick.
Hope that helps.
- Dave

Nov 19, 2008 | 2007 Honda CR-V

Not finding what you are looking for?
2000 Ford Expedition Logo

443 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...