Question about 2004 Dodge Grand Caravan

1 Answer

Front blower motor doesn't work. Fuses are good, relays are good. Motor? I only checked the fuse box under the hood, cause that's the only one I can find. . Any other suggestions or things I can try to narrow it down or is this it?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 736 Answers

You could have a bad motor (you can connect it directly to the battery to find out) or more likely you have a bad resister block .. not sure on your car but older caravans have that block available by removing the glove compartment .. at any rate its probably under the dash near to and connected to the fan speed selector switch .. different wire wound resisters are selected by the switch to determine fan speed .. if just one resistor is bad then all speeds below that speed will not work .. if the main connections have aged and opened then no speed will work .. the block is sometimes repairable but a new one is not expensive .. ..

Posted on Sep 17, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Front blower motor quit working replaced ignition switch,control module,resister,and blower motor but still doesnt work fuses are all good where do i look next


normally it is the resistor,( relay) then resistor module then motor.
did you test the relay(I believe located under hood, relay/fuse center), If OK check plugs and wires for melting, damage and good connection, grounds should also be checked. Use a volt ohm meter to see if you are getting any power ti motor,etc.
the first link below gives good how to diagnose blower,press the helpful button
GM Blower Motor Resistor Diagnostics by Wells

DIagnose and Replace GM blower Control Module

http://www.gmcproblems.com/tsbs/Envoy/2003

Jan 30, 2016 | 2003 GMC Envoy Xl

1 Answer

Rear A/C does not work. it will not come on, front works fine but rear does not do anything, front driver control turned to rear pass operation NADA,front control turned for driver control NADA, cannot...


since you know where the blower motor relay is for the rear, have someone turn on the switch while you touch the relay. if you feel a click then the relay is good an trying to turn the rear blower on. that would mean you have a bad blower motor or bad blwer motor resistor for the rear unit.

Aug 07, 2011 | 2008 Chrysler Town & Country

1 Answer

My Heater is not working in my 2003 Honda Element


First check and confirm the fuses related to heater in your car.Fuse #12 (40A) in the under-hood box powers the blower motor. Fuse #14 (10A) in the under-dash box powers the blower motor relay as well as the A/C compressor clutch relay, A/C condenser fan relay, power mirrors, radiator fan relay, recirc. control motor, and rear defogger relay.If the fuses are blown then replace the fuse and check.But if the problem is still there then Its a heater relay problem,.The blower motor relay is in the under-hood fuse box. It's larger than the rest, on the back side, labeled RY6.Remove the relay. With the ignition off, use a 12V tester to locate the constant-power socket, which powers the motor via the relay. Then with the ignition on, locate the switched-power socket, which powers the relay. Verify that neither of the remaining two sockets is powered, then with the ignition off use a continuity light to determine which is ground. The last socket goes to the motor. (If the continuity tester lights on both, it's probably because the motor has fairly high resistance, and you'll need an ohmmeter to determine which socket is ground and which goes to the motor.)With a fused 12V power source, power the relay's coil contacts and check the other two contacts for continuity. If the relay doesn't work, replace. But if the relay is also checked ok.then in that case the blower motor is faulty causing this problem.Make sure it has power at the connector and that the connector is properly seated. If the power and ground connections are fine, then the motor is bad. ----------- This troubleshooting procedure will help you to confirm the possible problem.Thanks.Helpmech.

Nov 12, 2010 | 2003 Honda Element

10 Answers

1997 Isuzu Rodeo V6 4X4. I have only owned this vehicle for 3wks and the fan/ac wont blow at all out the vents. The blue light comes on when i push the ac button but that is all it does. I don't know which...


C-19 Blower motor fuse 25A located in cabin fuse box. Left hand footwell on LHD vehicles, right hand dashboard on RHD vehicles.
Start by checking blower relay B-36 in the engine compartment fuse and relay box. Remove the relay. Jumper directly from battery to pins 85 and 86. (also see here: http://www.fixya.com/cars/r5544622-wire_relay if you dont know about relays) The relay should click Now measure across pins 30 and 87. Measurement should be 0 ohm.
Remove the blower motor(3 screws on the bottom of the unit under the passenger side dash) and connect jumper leads from the battery directly to the blower motor to see that it operates.
The blower motor resister is mounted on the ducting between the motor housing and the heating unit. Remove to test
Measure :
  • pin 1-2 : 2.4 ohm
  • pin 2-4 : 0.9 ohm
  • pin 2-6 : 0.28 ohm
  • pin 2-3 : 0 ohm

Aug 21, 2010 | 1997 Isuzu Rodeo

1 Answer

My rear AC blower dosent work. I dont seem to


Hi,

Thanks for using Fixya!

check the wire terminals from the fan motor, its possible that they are loose. Also check the relays if they are good. Just swap out the other relays to test if it will work. These relays can be found in the fuse box under the dash or under the hood.

Have a great day.
- HotRatchet

Jul 26, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

Turn singals & blower motor stop working at same time


look in your high current fuse box (distribution box) under the hood, inside the box are 4 relays and two rows of fuses, the center row of fuses the second fuse (next to starter/alt fuse if marked) is a 50 amp fuse for turn signals and blower motor, see if it is good, let me know what you find

Apr 13, 2009 | 1995 Mercury Grand Marquis

1 Answer

A/C for 2004 chevy suburban issue


Automatic climate control or manual ? blower motor control processor , probably . or the blower motor , or the HVAC control module etc.... All these are just guesses , without testing the electrical circuits . Did you check the BLOWER fuse 40amp located in the under hood fuse / relay box And the HVAC /ECAS fuse 10amp in the under hood fuse box ? Plus HVAC I fuse 10amp located in the I/P fuse box .

May 07, 2017 | 2004 Chevrolet Suburban

2 Answers

Heater quit blower not turning on


Check the fuse box in the car first then if that dont work check the fuse block under the hood also check for a bad relay. And if that dont fix it you may need a blower motor

Feb 26, 2009 | 1996 Ford Contour

1 Answer

95 lumina fan doesn't work


start by checking fuses....if good check check blower motor ..you can check by removing power wire from motor then with a wire hook up one end to battery ...+...postive....the other to blower motor ...if it comes on then your problem will be the blower motor relay or the switch in the dash.... ....the blower motor relay is located in fuse box under hood....hope this helps...

Dec 11, 2008 | 1995 Chevrolet Lumina

Not finding what you are looking for?
Cars & Trucks Logo

177 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...