Question about Ford F-150

1 Answer

Hi, i have a 1993 ford f-150 4.9 the truck starts if runs very rich i have checked fuel pressure checked ok ive check spark getting a strong spark ive check for injector pulse and no problems the truck runs awful if you wot if just bogs and shuts down ive replaced cap+rotor+plugs+wires+fuel pump the only thing that seemed odd was that the i pulled the new plugs out to check them and some of them were coverd in fuel i was hopeing you could help me diagnos this problem i was think map sensor or fuel pressure regulator thanks a bunch Justin

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 103 Answers

Hi,
I think you are on the right track. With the engine off remove the vacuum hose from the fuel pressure regulator and see if there is fuel in the vacuum hose or fuel is leaking from the fuel pressure regulator vacuum nipple,if so replace the regulator,check to make sure that the engine oil is not contaminated by fuel if so,change the oil and filter. Good Luck!

Posted on Sep 17, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 03 ford f150 4.2...It has started spark knocking when under a pull,and gas mileage has gone down


Sounds like you have a timing issue with the truck. Could be your ecu or the sensor(s) that feed data to your ECU.

May 02, 2017 | 1993 Ford F150 SuperCab

1 Answer

Runs rich and is hard to start has 4.3


Check the fuel pump relay located inside the glove box .If its bad the fuel pump will still get power through the oil pressure sending unit its a safety back up system but will make a long cranking condution. Also check your fuel filter located under the drivers door on the frame rail inline . And i dough its running rich .Pull your spark plugs you have to go in from under the wheel wells for most .If they look white then its running lean .I would check the fuel filter before it cooks the fuel pump first. Spark plugs tell a story if you can read them . And how is your exhust system thats a nother big factor on how the engine performs extremaly imporant on the 4.3 vortec

Sep 22, 2011 | 1993 Chevrolet S-10 Blazer

2 Answers

My jimmy wont start have 58 psi of fuel pressure good spark but the spider injection wont open to spary the fuel brand new 280 bucks for it have checked grounds two broken one fixed those still no start...


check your ecm-ign fuse.if it is ok check to see if you have power to your spider injector.if you have power, you either have a bad computer or a bad connection between the computer and the inj.do you have spark??.if you have no spark check your ign module or bad connection at the ign module.i have seen that before.

Feb 01, 2011 | 1993 GMC Jimmy

1 Answer

93 gmc sierra running rich no computer codes


Oxygen sensor[s],map sensor and fuel pressure regulator.Although you should have a check engine light "on" with any sensor malfunction.I would look at fuel lines for a leak under vehicle.

Apr 17, 2010 | 1993 GMC Sierra

1 Answer

I have the same problem as stated here and don't


there are two common problem with that 4.0! throttle position sensor aka tps causes hi/lo idle and iac motor aka idle air control valve motor!

Mar 18, 2010 | 1993 Ford Ranger SuperCab

1 Answer

1993 Subaru legacy running horrible. Ultra rich fuel mixture. When I give the vehicle gas it bogs down like it is getting too much gas and not enough spark or something. Not sure where to start looking....


remove cam covers and try to line up timing marks also check fuel pressure also check timing with timing light thats were i would start.when you pull the throttel you should see the marks move towards advance. hope this helps Thunderboltz

Jan 13, 2010 | 1993 Subaru Legacy

2 Answers

F150 won't start


So you turned the key just to "Run" and hear the fuel pump running (guessing elec pump)? Did you pull off a spark plug wire to check for spark? If no spark, pull the Distributor cap and check inside of cap, and rotor for damage, if ok, then the coil is bad, replace it. If you have spark at the plugs, have you tried Starting Fluid? (old school, go to AutoZone for this)

Aug 18, 2009 | 1990 Ford F150

1 Answer

4.9 liter will idle but wont accelerate have to start with ether


yes checked fuel pressure and replaced the fuel filter, checked the mapp sensor,tested throttle position sensor, has strong spark, 50psi fuel pressure, fresh tune up, runs real rich and rough idle but wont rev up like fuel injectors arent speeding up, also checked exhaust. thanks julius

Oct 09, 2008 | 1990 Ford F150

1 Answer

Fuel Problems


check for air inlet at carburettor leaks.

Jul 13, 2008 | 1989 Ford F 150

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

282 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...