Question about 1999 Oldsmobile Alero

1 Answer

Cooliant light stays on and it is full and not running hot

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 14,036 Answers

LOW COOLANT SENSOR IN THE OVER FLOW JUG FAULTY OR HAS A LOOSE CONNECTION.

Posted on Sep 17, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a2005 ford taurus. My car trying to run hot cooliant is in the reserve tank. What is the problem?


Check thermostatic valve is opening to allow coolant to flow through radiator..

Jul 13, 2016 | Ford Cars & Trucks

1 Answer

Look have a 98 contuer running all water out no leaks all hoses working fine .Not running hot but when i go frim a to b all water and cooliant are gone.what is the problem.


If there are no leaks, the engine is probably burning the coolant out the exhaust pipe. Most times its a leaking head gasket.

Jul 16, 2014 | Cars & Trucks

1 Answer

Cooling fans stay running even if engine cold


cooliant sensor is bad ,you have two,one for cooliant temp and one for cooling fan both are in therostate housing or in some of the cooliant ports,

Jun 15, 2009 | 2002 Land Rover Freelander

1 Answer

My car goes through so much cooliant


How many times has it got hot? You better do a cooling system pressure test. Sounds to me you got more problems than a cloged radiator. Do you see a puddle under the car? Its got to be going someware. Do the test.

Apr 01, 2009 | 1989 Ford Mustang

3 Answers

1998 olds acheive low cooliant light on


Did you add coolant ? you are supposed to bleed the system after adding coolant. it also could be a bad Coolant temperature sensor which turns on the radiator fans. or a leak in the intake manifold gasket.Or even a bad thermostat. Does the heater work ? All of this can cause that problem.

Feb 16, 2009 | 1998 Oldsmobile Achieva

1 Answer

1995 Chevy Cavalier


should check ur thrmostat to make sure its working and make sure ur cooliant level is good and ur over heating the starter and then when cools off it works

Jun 14, 2008 | 2001 Chevrolet Cavalier

1 Answer

Coolant system


cooliant level sensor at the bottom of ur cooliant tank

Jun 06, 2008 | 2001 Cadillac DeVille

1 Answer

Runs hot


check cooliant level , thermostat might sticking closed

May 19, 2008 | 1998 Buick Century

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

130 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...