Question about 1994 Chevrolet S-10

1 Answer

94 s10 pu 4.3l cpi engine drives fine till it warms up then idle goes crazy. new map,iac,cap,rotor,plugs,wires,fuel filter,etc. i believe I'm down to the computer and the 02 sensors. my question is, since the engine light isn't on do/will i need to replace all the 02 sensors? if so is there 3 or 4? i found 3 but haven't gone under close to engine so not sure.

Posted by on

  • only1jer Oct 03, 2010

    replaced the computer and coil also cleaned the EGR valve...still clueless to what is going on here

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 835 Answers

Just 3 sensors . u need to check throttle body bolt make sure tight/no vacuum leaks/plugged pvc/or camshaft lobes worn/leakin head gasket do compression test

Posted on Oct 20, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

92 s10 blazer,popping through intake when warm and accelerating,runs better when manually shifting.


It could be a few different thing's , testing to find out the problem , rather then just replacing parts is the proper way to fix vehicles . Checking engine sensor data with the proper factory or equivalent scan tool . Could be a vacuum , leaking fuel pressure regulator, map sensor . CPI injection system under the intake manifold . Chev GMC Misfire poppet injector diagnosis troubleshooting and replacement

Jan 09, 2017 | Cars & Trucks

2 Answers

1989 chevy s10 4.3L 4x4 (automatic)Truck idles and runs great when cold. As soon as it reaches operating temperature It acts like it's not getting enough fuel. It will have an erratic idle and when I...


Chances are you have an oxygen sensor problem. When the engine warms up, the engine computer moves from open loop operation to closed loop, and it then uses the O2 sensor readings to adjust the fuel. If the sensor(s) is contaminated, it will send a false reading to the computer causing this problem.

Mar 11, 2017 | 1989 Chevrolet S-10 Blazer

1 Answer

Problems with my 94 k1500 / changed idle control valv / map sensor / throttle control sensor /plugs,wires,cap,rotor ,and fuel filter / these are all the things i have bought but nothing i have done will...


it might be the ECU, when cold the computer raises the iddle to warm it up, when reaches temp., it dropes it down to normal iddle, but it might not know where the correct iddle is, it might be another sensor like a cam, map, throttle position senssor.

Dec 05, 2010 | 1994 GMC Sierra

1 Answer

94 s10 with 4.3 w, misfires during driving.


Check fuel pressure,fuel pump maybe on the way out.

Apr 19, 2010 | 1994 Chevrolet S-10

1 Answer

1994 s10 blazer 4.3 cpi,starts and drives but has miss/stumble right before it shifts,if it gets warm it starts running rough and dies has new fuel pump,fuel filter, cap,rotor,ign moduletranny filter,plugs...


check these two things, the electronic egr valve, located at the front of the engine on top near the front of the intake, they are know for getting something in them and not working properly. also check the cold water temp sensor, located on the driver side of the head.the egr valvce can be taken apart nad cleaned, you might have to get a new gasket for it.

Sep 17, 2009 | Chevrolet S 10 Cars & Trucks

1 Answer

Rpm bounces from 1500 to 500 and back again


I have the same problem with my 94 s10 4.3 cpi.... I have been told after replacing fuel filter; 3 sensors; cap, rotor, plugs & wires; spider injection assembly; and a coil (and i could have even left something out the list is so long), that it is probably the 02 sensor by the cat converter. If not that then my injectors are already bad...oh yeah plus I cleaned the EGR valve. Does this only happen to you after you vehicle warms up? cuz thats when it goes crazy for me.

Feb 26, 2009 | 1994 Chevrolet S-10

Not finding what you are looking for?
1994 Chevrolet S-10 Logo

438 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...