Question about 2002 Mercedes-Benz M-Class

Open Question

ML270 Speedometer display reads start error and engine wont crank

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Loss speedometer and tackmoter in my 2005 jeep grand Cherokee what could it be odemeter still works


the cluster in the the car, is standalone,
its just a display and has self test you can do.
http://www.fixkick.com/Jeeps/jeeps.html#cluster

Check both cluster fuses in the fuse box yet?
one is power other is memory.

if that test passes, and you
THEN PCM, did you scan it yet? (any modern $10 scan tool works here) can-bus rated, scan tools are Ubiquious now.
not scanning the car, and missing can-bus errors is bad idea.
or missing PCM can't talk to the display(cluster) misses the boat.
or VSS errors, or any TCM errors, or other errors, DO SAY THEM.


the PCM sees RPM or the engine can't run , with dead cam or crank sensors. so right off the bat I know PCM is sending RPM .(tacho)

the speed can be checked with any scan tool made (rpm /speed)
plug in scan tool and drive, and have helper read the PID called, SPEED . (vss speed) cheap tools can do live data stream.
on ANY PID. (pids are live parameters by number)

do not guess. here, scan it first.
or go broke.

Feb 27, 2015 | 2005 Jeep Grand Cherokee

1 Answer

Car wont start


but cranks ok, right>??????????????????????
green key, in display,
my guess, you never read the manual> ever>?
if answer this,
here it , is
ahh no 04 here.
so read 01, or 08 ,id bet the green lamp means same thing...
(server is slow,) and folks are off work today. soooooo
http://justgivemethedamnmanual.com/honda/

IIRC:
the green key means IMMO very unhappy
so did you try (only no rings or other keys) the IMMO master key
the car comes with 2 keys,. never lose both.
IMMO= immobilizer, engine cranks but fuel is cut , IMMO doing its job.

Dec 30, 2013 | 2004 Honda Odyssey

1 Answer

I replaced injector copper seal in Mercedes ml270 cdi now wont start I have traced wires back to ecu and wires are beeping through any ideas as wats going on


You have a bio degradable wire loom and it's degrading and sheading it's insulation.. Need an engine wire loom from Mercedes.

Oct 07, 2013 | Mercedes-Benz M-Class Cars & Trucks

1 Answer

Volvo 2005 EC210 BLC Engine Crank but no start .display shows code 140SID and 250 9


It can be faulty fuel pump or clogged fuel filter or its issue with starter or battery or may be problem with sensors.There are few possibilities that can cause these problem,there are few help links provided related to these issue. Click the link below and refer the troubleshooting procedure to solve the problem:-----
Engine cranks but will not start? http://technoanswers.blogspot.in/2012/02/engine-cranks-but-will-not-start.html
-------- Landcruiser prado won't start http://technoanswers.blogspot.com/2012/10/landcruiser-prado-wont-start.html ------- 2007 ford expedition engine cranks but wont start http://technoanswers.blogspot.com/2012/10/2007-ford-expedition-engine-cranks-but.html

--------
: Engine Cranking Fast but not Firing up? http://whatisbyme.blogspot.in/2012/05/1999-lexus-gs300-engine-cranking-fast.html

----------
1997 Oldsmobile Cutlass Ciera: The Engine cranks but not start? http://schematicsdiagram.blogspot.in/2012/04/1997-oldsmobile-cutlass-ciera-engine.html

-----
Mazda MPV cranks but will not start? http://technoanswers.blogspot.com/2012/01/mazda-mpv-cranks-but-will-not-start.html
-------- MAZDA MPV WILL CRANK BUT NOT TURN OVER TO START? http://technoanswers.blogspot.com/2012/01/mazda-mpv-will-crank-but-not-turn-over.html
--------- Vehicle Cranks Fast but Won't Start http://whoisbyme.blogspot.in/2012/07/vehicle-cranks-fast-but-wont-start.html

------
How to test Crankshaft Position Sensor? http://fordrepairhelp.blogspot.in/2012/03/how-to-test-ford-focus-crankshaft.html

---------
These details will help,keep updated for more help.

Oct 16, 2012 | Cars & Trucks

1 Answer

Speedometer error?


Many cars have an error on the speed indicated. 10% sounds quite high, next time you buy tyres go for one size bigger or the next profile up, eg, if you are using 70 series go to 75 or 80. That will sort your problem out and you will get better fuel consumption. You can have the speedo calibrated but I would thing that the cost or effort wonuldn't justify the result.

Feb 27, 2010 | 2002 Toyota Camry

1 Answer

03 Altima 2.5, Wont turn over on cold start


First, change the fuel filter, and make sure the lines are good. Check the intake manifold bolts for tighness, check all vacuum lines. Best to have it running, wiggle them around and listen for a hiss. Lastly, change idle control sensor, if the other suggestions don't make a difference.

Jun 30, 2009 | 2003 Nissan Altima

1 Answer

I have a 98 grand prix 3.8L and sometimes it's hard to start. then sometimes going down the road the tach goes to zero and the speedometer starts swinging while the car is trying to stall.


If the vehicle cranks normally when not starting check the tach see if it is reading any engine speed. Sounds like the crank sensor is going bad very common fault on the 3800 series 1 & 2 engines. You must remove the harmonic balancer to replace the sensor.

Apr 09, 2009 | 1998 Pontiac Grand Prix

3 Answers

Honda Civic fuel system


sounds like maybe low battery voltage? or check the distribvuter wires for breaks please rate -jeff

Aug 30, 2008 | 1995 Honda Civic

Not finding what you are looking for?
2002 Mercedes-Benz M-Class Logo

Related Topics:

312 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76051 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...