Question about 1996 Chevrolet Suburban

1 Answer

I have a 96 suburban and it want start just turns over, so I replaced the fuel pump and still nuthing, someone said cam sensor, but what about a crank sensor? How can I tell with no engine light on for a code?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

Check for spark at the plugs..if you have spark..get some auto mobile starter fluid ..spray some in engine intake.. if engine starts ..you have a fuel deltvery problem..that should narrow your your problem down..your fuel pump might be good..there are other parts in your system that will cause pump not to work.. such as plug fuel filter/pump relay..ecm..fuel pump fuse etc..take it one step at a time..guessing is costly

Posted on Sep 21, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 kia sportage wont fire backfired once very loadly no power to tps cam or crank sensor fuel pump will turn over but wont crank


Being it is a 96. It could be many different things, electrical. Really should have the codes read. Check fuses first. No power to the cam and crank is a no start situation.

Aug 11, 2015 | Kia Cars & Trucks

1 Answer

Have a 2000 Chevy suburban it turns over but won't start good battery any ideals What can b wrong


Fuel pump and or filter,Ignition module, PCM, Crank or cam sensor.Is the check engine light on, If so have it scanned.

Mar 10, 2015 | 2000 Chevrolet Suburban

1 Answer

I have a 96 Suburban 7.4. I was driving a month ago and stopped at the light. When I pushed the gas it lunged and quit. I have changed the timing chain and gears, Plugs, Wires, Cap, Rotor, Cam Sensor,...


Have you tried boosting fuel supply by spraying carb cleaner into the intake ?
Is it possible the cam is not in time with the crank ? Or the distributor is off a few teeth ? Does it make any difference if you turn the distributor ?

Aug 29, 2013 | Chevrolet Suburban Cars & Trucks

1 Answer

So... I'm starting to get just a bit frustrated... after installing the new PCM, my dodge avenger, 96 2.0L ran for 5 days then went out again, fuel pump works and I've got spark but no start..


after all that work its terrible that something else goes bad however since you do get spark and fuel i would say crank or cam sensor but then if one of those goes bad it wont allow engine to turn over and would shut fuel pump off. so there is only one thing left to cause it you have a short in the harness somewhere maybe just a lose connection on the cam or crank sensor put dieelectric grease in all your connectors

Apr 03, 2013 | Cars & Trucks

1 Answer

1999 chevy suburban fuel pump or what????


could possibly be either cam position sensor or the crank position sensor if the fuel pump doesnt read the signal from them it will not start

Aug 17, 2009 | 1999 Chevrolet Suburban

2 Answers

1999 chevy tahoe starting problem


i have a 99 5.7 chevy suburban and have to use starting fluid for it to turn on , ive replaced the fuel reg. and fuel pump is 4years old fuel filter 6months old new cam and crank sensor new distrbutor rotor and cap

Jul 30, 2009 | 1998 Chevrolet Tahoe

1 Answer

I have a 96 suburban 5.7....cuts off when on unlevel ground...fuel pump and regulator has been checked ..no problem..could there be a possible cam shaft sensor problem?


Check the wire connections, they might be loose. Otherwise it your fuel tank or the fuel sump - the dirt inside gets sloshed around and temporarily clogs the fuel admission.

Jun 28, 2009 | 1996 Chevrolet Suburban

2 Answers

Will not start


It might not be the pump. I have an 96 Blazer that had the same problem. I ended up replaceing the ingition switch.

Jan 13, 2009 | 1997 GMC Jimmy

1 Answer

1996 GMC Suburban will not start.


check your cam or crank sensor,i think your sensor not getting signal

Jun 25, 2008 | 1996 GMC Suburban

Not finding what you are looking for?
1996 Chevrolet Suburban Logo

240 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...