Question about 2001 Pontiac Grand Am SE

1 Answer

My coolant light won't turn off even when I added coolant

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 385 Answers

Look for a plug in sensor on the resovior. unplug the harness and short the pigtail together. light goes off when unplugged or shorted? replace sensor...

Posted on Sep 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Low coolant light stays on until system heats


Your overflow tank(aka coolant recovery reservoir) is low on coolant. The coolant expands when warm and raises the level in the tank, which turns off your light. Top off the reservoir (when cool) to the "Full Cold" line. If you have to keep adding on a regular basis, then you have a leak somewhere in your cooling system, could even be the reservoir itself.

Oct 18, 2015 | 2000 Buick Century

1 Answer

How can I reset the coolant temperature light on my 1998 Boxster


un do the hot side of battery for 5 to 10 min that will reseat the caputer

Jul 03, 2012 | 1999 Porsche Boxster

1 Answer

2000 vw beetle 2.0 L, low level coolant light...engine mil code 1256


not the pump but air in the system or a broken wire to the coolant level sensor
that sensor at the top of the radiator tank has to be completely immersed in coolant or the circuit is broken and the light comes on
same effect id the wire to that sensor is broken in the insulation

Jun 16, 2017 | Cars & Trucks

1 Answer

Low coolant light comes on even after adding coolant. What does this indicate? A leak? What type of coolant does it take?


the float that is in the coolant bottle probably gets stuck, you might have to take the bottle out and clean it out good, or just replace it. the coolant that goes in that car is dex-cool

Mar 03, 2011 | 2003 Pontiac Grand Am

1 Answer

Changed coolant mixing valve added coolant engine shut down on coolant level .started cotinued adding coolant to proper level. defroster working again turned off engine left hood ajar. next morning car...


S type jaag ?? yes immobilisor ,disconnect battery join leads together ,leave for ten mins while you have a cuppa then reconnect battery and it will start .leads must be joined though not just disconnected

Sep 04, 2017 | Jaguar S-Type Cars & Trucks

3 Answers

1998 olds acheive low cooliant light on


Did you add coolant ? you are supposed to bleed the system after adding coolant. it also could be a bad Coolant temperature sensor which turns on the radiator fans. or a leak in the intake manifold gasket.Or even a bad thermostat. Does the heater work ? All of this can cause that problem.

Feb 16, 2009 | 1998 Oldsmobile Achieva

1 Answer

01 mercury sable traction control & low coolant lights stay on.


check for something stuck in the wheels and as for the coolant light get the car running and up to warm temp and start adding coolant to the reserviour bottle until it is up to hot level because there maybe a bubble in the line but also if might be a bad switch in the reservior bottle itself

Jan 11, 2009 | 2001 Mercury Sable

2 Answers

Coolant light stays on after coolant was added


you have a bad sensor in the reservior.

Oct 03, 2008 | 1999 Chevrolet Lumina

Not finding what you are looking for?
2001 Pontiac Grand Am SE Logo

Related Topics:

97 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8560 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...