Question about 2003 Oldsmobile Silhouette

2 Answers

Speedometer isn't working and engine running at high revolutions while driving.

Posted by on

  • fieldtrooper Sep 13, 2010

    If the gear is broken, could the material from the broken gear cause the transimission not to shift properly? As mentioned, the engine is running at a high RPM both issues should be related because they started happening at the same time.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,489 Answers

If it seems like the transmission is not shifting properly and the speedometer is not operating at all, the speed sensor(VSS) is either failed or the wires to it have been damaged. The VSS is located in the transmission, nearest the axles so it can read the out put speed. Let me know if you need anything else. I will be happy to help.

Posted on Sep 13, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 17,970 Answers

The speedometer problem may be caused by the speedometer cable binding or the speedometer head itself. If it is the cable, other than the uneven speed reading, it should cause no problems. If it is the head, it may break the new cable.

Remove the part of the transmission housing that the sensor plugs in to. You probably have a broken gear or it has slipped on the shaft.

I took at a look at the speedo problem and what it seems to be is a failed IPC {instrument panel cluster}, the cluster {speedo} is also a microprocessor getting the speed inputs from the PCM (powertrain Computer) the PCM gets inputs from the VSS (vehicle speed sensor). Usually if you have a failed VSS or PCM your cruise control would stop working, the cruise module gets inputs from both the PCM and the VSS, in your case the cruise works so that means all is well with the PCM and the VSS, looks like the IPC just had a failure; replace the IPC or send it out for repair, the local dealership can send those out for repair.

Hope helps.

Posted on Sep 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my 2002 Mazda Tribute making a loud knocking noise when I start it


loud knock and for how long

is it a diesel or petrol

broken engine mount

loud tapping is tappets ..should go away once oil reaches top of motor
water pump or bearing something running off drive belts

if high milage engine
a loud knock at engine revolution or half revolution
big end bearings or
piston slap or gudgeon wear

26303613-eolcmrc2k3afiywjhmzpes2a-3-0.gif

26303613-eolcmrc2k3afiywjhmzpes2a-3-1.jpg

Oct 07, 2016 | Mazda Cars & Trucks

1 Answer

RPM's go high when driving but then go back to normal


What you are describing sounds normal. RPM's stand for revolutions per minute. Each minute your engine is running, the pistons are going up and down. When you are not going anywhere, your engine is idling and so the RPM's should NOT be very high. However, when you race up a hill, your RPM's SHOULD be high because your engine has to work hard to climb the hill or to go fast.
Idle speed= 650 Revolutions Per Minute. That means your engine cylinders each work 650 times in One minute.
At freeway speeds, your engine will revolve somewhere between 1600 and 2100 times per minute. I hope that helps.

Apr 20, 2015 | Cars & Trucks

1 Answer

Speedometer on my 95 gmc sierra 4.3l v6 is registering right at 4 mph higher that what I'm actually going help please.


If you have recently changed from stock wheels and tires to aftermarket, the problem could be as simple as your wheels turning more revolutions per mile due to a tire height change. That would cause the speedometer to register high.

Nov 18, 2014 | 1995 GMC Sierra

1 Answer

I have a 1996 Honda Accord with 268k miles that sputters at the same timethe speedometer needle fluctuates wildly. But I do have a new Vehicle Speed Sensor. This typically only happens when the engin


I am no Honda expert, but a similar problem happened to my ex sister in-laws Ford Taurus. The speed odometer would jump around and it had trouble shifting (automatic transmission). After driving it I changed out the speed odometer sensor on the transmission and it's been fine ever since. I changed out the sensor because if the cars computer cannot tell how fast the car is traveling then fail safes in place go into effect and the computer will do it's best to keep the cars rpm's down based on the speed indicator and not let it shift or shift properly either. If it's getting false speeds then it will shut down the motor when the speed gets to high and allow it to run as the speeds fall (jumping speed odometer needle). It effects the transmission shift points also. It will either shift erratically or not shift out of say 2nd gear, so that the cars engine can't get damaged based on what signal the speed sensor is sending the computer.

Jan 23, 2014 | 1996 Honda Accord

1 Answer

My speedometer isn't working and I think it's the


most cases it is the speed sensor and not the speedometer, it usually turns on the check engine light when it fails.

Oct 14, 2012 | Cars & Trucks

1 Answer

Speedometer isn't working on 1993 corolla


It is not a belt it is like a wier that need a new one

Aug 17, 2012 | 1993 Toyota Corolla

2 Answers

The speedometer gauge and RPM gauge is not working. The speedometer gauge goes to the max while I am driving. The car itself seems to be running ok. Help! It is a Yukon Denali 2005.


I suspect that your sender is malfunctioning. Todays speedometers and RPM is sent from a sensor/sender near the drive shaft. A magnet on the drive shaft is sensed and the revolutions are converted to RPM and speed.

For information see:

http://wiki.answers.com/Q/Speedometer_on_2003_Yukon_XL_doesn%27t_work_most_of_the_time_is_this_a_common_problem_how_much_to_fix_it

Jan 09, 2011 | 2003 GMC Yukon Denali

1 Answer

93 subaru legacy gt cuts out at around 100kph check engine light comes on, restart car and it is fine. car is a auto and doesnt seem to do it as much if car is in 3rd instead of drive


Check The Vehicle Speed Sensors.

The Legacy has 2 Vehicle Speed Sensors (VSS): VSS1 is located inside of the transaxle; VSS2 is located in the combination meter assembly.

VSS1
  1. Disconnect the electrical harness from the transaxle.
  2. Connect an ohmmeter across the transaxle's electrical harness terminals 9 and 16.
  3. The resistance should be 450-650 ohms.
  4. After testing, reconnect the electrical harness.
VSS2
  1. Remove the instrument cluster from the instrument panel.
  2. Disconnect the electrical connectors and the speedometer cable from the instrument cluster.
  3. Connect an ohmmeter or continuity tester across the combination meter terminals 7 and 11.
  4. Insert a small screwdriver in the speedometer cable drive socket.
  5. Rotate the speedometer drive and note the continuity across the VSS terminal. Continuity should turn ON/OFF 4 times per speedometer drive revolution.

Nov 25, 2008 | Subaru Legacy Cars & Trucks

1 Answer

Speedometer does not work


Hi, The speed sensor on your car is going bad,
THe speed sensor work in A magnetic pulse generating a a/c voltage, but when the magnetic force come poor need nore revolutions for generate the signal to the computer.
And you can have erratic speed ,
I recomend replace the sensor.

Thank for use fixya, I hope this work for you.

Jul 08, 2008 | 2001 Ford Taurus

Not finding what you are looking for?
2003 Oldsmobile Silhouette Logo

Related Topics:

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...