Question about 1997 Jeep Grand Cherokee

1 Answer

Morning or when engine cools down I have to run it for about 15min then it stop dead. wait for 5-10 mins, turn it on and runs again for 2-5 mins than stop again. wait for few more mins and on again, It wont drop dead again for the rest of the day. Changed crank sensor, coil, ignition control module, computer but to no avail. I dont think its a throttle fault because I cant get a spark when tried to turn on again during intervals. These beauties are really pain in the neck

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 273 Answers

Dear sir
this can be problem cause of o2 sensor(lamda sensor) . in cold condition if we start the car some quantity of water can also came out through silencer and can stay at point of 02 sensor it is paced at silencer, ECU(Engine Control Unit) receive data from 02 sensor for Engine Firing . so replace it and let me know. thanks.

Posted on Sep 13, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Jeep grand Cherokee 2000 v8 runs 15min cuts off cools down 15 min run short time ( no errors)


probable a bad engine control computer if there is no code. could also be bad crankshaft positioning sensor, or camshaft positioning sensor.

Aug 21, 2014 | 2000 Jeep Grand Cherokee

1 Answer

2000 BMW 528i running hot


is the cooling fan cutting in ? run the engine whilst stationary with the hood up , give it a little gas 2000revs and wait for the temp gauge to rise ,the cooling fan should be heard cutting in , and off again once cooled the engine temp down ,this may take 10-15 mins but you have to be sure the fan is cutting in or you may cook the engine

Jun 03, 2014 | 2000 BMW 528i

3 Answers

2000 Mercedes CLK..I think it is a vapor lock problem..car starts as usual but 5-7 minutes later it just shuts down..happened in traffic..so I dont dare to drive it..Afterwards it doesnt start unril...


Sounds like the crankshaft position sensor needs to be replaced. They are a common problem with the Mercedes. That sensor is the one that the engine control module looks at to see if the engine is running. When they get hot and stop producing a signal the engine control module thinks the engine is not running and shuts of the fuel. After waiting awhile they cool down and the vehicle will start up again. I've changed many of them when I worked at the dealer. Tricky part is when there working and the car is running there will be no check engine light on or code stored. Usually will only have the code when the car won't start. Let me know what you end up finding out on it but that would be the first place to look and probably the cheapest.

Apr 20, 2011 | 2000 Mercedes-Benz CLK

1 Answer

Every morning i stard my car it stard to smoke i drive for about 10 min and the smoke stop complectly...what could it .Is there that i can i put in my engine to make it stop smoke


most likely the valve guide seals when motor warms up the every thing will expand and seal alitle better when it cools oil will run down valve stem and sit in head until you start it again

Mar 02, 2011 | Mitsubishi Galant Cars & Trucks

1 Answer

Runs and stalls, wait for a min and runs again whats the problem?


well i would say if the rpm gauge stay's up and the other's all go down that would be a blown motor.

May 09, 2010 | 1999 Dodge Durango

1 Answer

When the engine is started in the morning it doesn't run right


It starts and will run perfect or will not start at all

Oct 25, 2009 | 2001 Dodge Ram 2500 Truck

1 Answer

2002 blazer..would drive at 60mph for 10-15min


there is a screen in the fuel tank to prescreen the fuel. If this is clogged it will give a problem like this.
check it and replace if necessary.

Jan 23, 2009 | 2002 Chevrolet Blazer

Not finding what you are looking for?
1997 Jeep Grand Cherokee Logo

135 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...