Question about Chevrolet Camaro

1 Answer

I have put a water pump, a new thermostat and a did a flush and its still running hot.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 235 Answers

Sounds as if you cateletic converter is cloged.

Posted on Sep 13, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Recently had a new water pump fitted to my jeep Cherokee but it's still overheating and the heater in the car doesn't work. Any idea what might be causing this


if no leaks in hoses, then flush out the radiator etc, there maybe a plug up in system. also change thermostat. God-Bless! and hope this helps you.

Apr 24, 2016 | Jeep Cars & Trucks

1 Answer

I put a new thermostat in my 07 still running hot


water pump faulty, low on coolent, could be temp sensor faulty too if it reads hot all the time, even when you know its cold (like first thing in the morning) loose belt on waterpump, clogged coolent system, maybe it needs flushed.

Dec 09, 2013 | Dodge Magnum Cars & Trucks

1 Answer

2002 jeep cherokee put new water pump and thermast in still getting hot like water is not flowing cheack top radiator hoses and its hot bottem hose is cold is it a bad radiator what can i do???


Hi David, How long did you run the engine before checking the temperature? The thermostat will only begin to open when the engine has warmed and the gauge begins to move. If after giving it a correct warming period it has still remained cold, I suggest the following. As you have already replaced the water pump, thermostat and radiator cap, the radiator may be blocked. Carry out a back flush, meaning, use a good quality radiator flushing chemical and follow the instructions carefully. Run the engine in accordance with the instructions. Let the engine cool and then draining, flushing the system by connecting a hose pipe with a fairly good head of pressure against the usual direction of flow. If that fails you may need to replace the radiator. Let me know how you get on, Happy new year Regards John

Jan 01, 2013 | 2000 Jeep Grand Cherokee

1 Answer

I have 85 toyota have changed water pump reader cap thermostat and still gets hot boils out water but when you put cold water it's ok for the rest of day sets over night start next day gets hot ag


did you let excess air out of radiator? after filling let it run for a few minutes with out radiator cap and make sure the water does not go down and serculates after thermostat opens, refill if needed
do you notice moister under vehicle in the morning ? possibly a gasket could be leaking.

Mar 30, 2012 | Cars & Trucks

1 Answer

Have a 2000 chevy cavalier. new water pump, new t-stat, new head gasket , new coolant, still running hot


Two ideas.

1. Try a new radiator reservoir cap (trust me, it is very important in holding pressure which keeps the coolant from boiling out).

2. This one you will need an entire weekend to spend on this. You need to remove the thermostat and replace the thermostat housing. pull one of the radiator hoses and attach a garden hose with good pressure. It needs to flush for at least 20 minutes. Then switch directions and flush water where was coming out. Then put it back together and drive until it gets hot. Allow it to cool for 45mins (to prevent engine from cracking due to rapid cooling) and repeat until no crud comes out when flushing.

May 30, 2011 | 2000 Chevrolet Cavalier

1 Answer

95 ford conversion van with a 351 engine. replaced the radiator, water pump and thermostat last year. The water pump leaked when cold and finally replaced water pump and thermostat again. Got the leak...


If you didn't do a thorough cooling system flush with the radiator replacement last year, then i would say you may have excessive build up of rust, scale and other debris. This will certainly clog up a new radiator quickly. You may still have a restriction. I would do a good flushing, including REVERSE flushing until water runs clear. This should help... Good luck, my friend.

Feb 02, 2011 | 1995 Ford Econoline

1 Answer

My car overheated and leaked coolant everywhere once i shut it off.. i just got my water pump replaced back in april i believe so i'm pretty sure it's not that should i just flush the old coolant out and...


Did you have the thermostat replaced when they did the water pump, as this might be stuck closed and preventing circulation of the water and overheating.....

To check, top the system back up with just water, and run until hot. Switch engine off and feel both radiator hoses, they should be the same temperature, if one is hot and the other cold/lukewarm, the thermostat is stuck closed or partially open.

Oct 01, 2010 | 1999 Jeep Grand Cherokee

1 Answer

I have a 2000 nissan maxima and just recently i noticed it was running hot. so i took it to my mechanic and he advised i needed a new water pump. so he replaced the water pump and he is saying it is still...


hot engine usually due to clogged radiator or bad thermostat. Take out the thermostat and make sure it is opening fully in boiling water.
Look inside your radiator for signs of clogging. If yes, professionally flush or replace radiator.

Aug 22, 2010 | 2000 Nissan Maxima

1 Answer

Car is running hot occasionally and the serpentine


Well there's only part that has to do with the cooling system and serp belt - the water pump!! Maybe it's starting to seize or has too much play. Either way, when you change the water pump, replace the thermostat and flush the system very thoroughly, those 98-99's are notorious for rust build up. Make sure to pull the heater hoses off and flush the heater core too. After all said is done, purge the coolant and make sure there is heat from the blower. If not you're going to have to replace the heater core because that gets clogged sometimes when flushing.

Aug 07, 2009 | 1999 Mercury Sable

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...