Question about 2003 Chevrolet S-10

1 Answer

My 2003 s-10 is starting rough only some of the time, and runs fine after an initial hiccup. After several hours of operation starting becomes increasingly difficult and it started to get above normal operating temp., yet ran for hours at the correct temp. the next day. I just replaced the radiator and change from water only and bars leak sludge to a dexcool, water and minor sludge in there now. I got oil change used seafoam treatment, cleaned k+n air filter

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,272 Answers

Get the coolant level checked.If the coolant level is low then it can have temp over rise problem. Also check the coolant temperature sensor.And for rough starting.It can be fuel pump pressure problem.Get the fuel pump pressure checked at any local car garage.Get the fuel filter clogged.If fuel pressure is low then fuel pump haws to be replaced.Also check the radiator cooling fan.In case if its not running then the radiator fan motor needs to be checked. Thanks. Keep updated for any more query. You can rate this solution and show your appreciation

Posted on Sep 12, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hours of reading blogs; none show my symptoms: SAAB 95, 2005 Arc. Hiccup/hesitation/stumble when's engine warm to hot, any speed.


Are you talking about a go-cart, or a motorcycle, or a tractor-trailer 18 wheeler? Then OF COURSE, you must IDENTIFY the MAKE, the MODEL, and the YEAR of whatever vehicle you are asking about, if you want any REAL help!

May 16, 2017 | Cars & Trucks

1 Answer

99 ford ranger, most of the time it will start and run just fine, but sometimes it won't start after several attempts for hours, then it will start again eventually


Does this problem become more common during cold weather days ? Or when it has rained ? Humidity and moisture can affect a few components which make it hard to start.

Might want to double check your vacuum lines also.

Nov 25, 2016 | Ford Ranger Cars & Trucks

1 Answer

Starter


Well the starter won't cause the rough running or stalling problems.
You would need to know if the starter has full battery power when it will not crank without being jumped off another battery.
It could be that the battery voltage drops low enough to affect the computer memory, and after the engine starts the computer has to re-learn the settings.

Apr 26, 2013 | 2003 Honda Element

2 Answers

Car runs rough during initial startup!


Check the fuel filter,or just change it,it is more likely it is stopped up.

Jun 07, 2010 | 2004 BMW 3 Series

1 Answer

Car starts and runs fine then after 30 min or so runs rough


Check the primary and secondary resistance on your coil and resistance and gap on your spark plugs. Sounds like you have a high temp foul out.

Jul 31, 2009 | 1983 Ford Crown Victoria

1 Answer

Stalls, runs rough


your choke is sticking

May 10, 2009 | 1984 Dodge Rampage

1 Answer

Engine Stalling '65 Mustang


replace the accalerator pump in the carbrator this is located at the bottom of carb. or front above fuel filter! this should cure the hiccups and problem.

Apr 02, 2009 | 1965 Ford Mustang

3 Answers

Truck has trouble starting- runs fine after start


I found the fuel pressure regulator on the fuel rail was leaking fuel into the intake manifold via the vacuum hose.Was hard to start and rough idle. Pull vacuum line and see if fuel is coming out-if so like me-replace it. About 50.00 at Murrays. Also the two inner cylinders on the passenger side-opposite of the vacuum line will be very rich fouled-replace them all

Dec 24, 2008 | 1999 Chevrolet Silverado 1500

1 Answer

Why is my 1994 Chevy S10 Blazer lugging? motor shakes and lugs.


Could be vacuum leak or bad ignition wire(s).

I had a similar problem on my "93 Ford probe. The engine idled pretty rough with shakes, Turned out to be a head gasket leaking engine coolant into the cylinder during low rpm's. At fast rpm's it was fine becuase the internal cylinder pressure was greater than the hot coolant pressure & would prevent the coolant from leaking in.

A friend has the same problem with his "94 Blazer 4.3 L, throttle body injection, manual tranny. He hasn't fixed it yet, It started a few weeks ago & is getting worse. His gets a fast idle with hiccups which causes the engine shake. He already checked the EGR valve. He also has a severe exhaust problem, Not oilly but very gray & terrible smelly, but only when the fast idle problem happens. THis fast idle hiccup problem starts when the engine is warmed up.

Nov 19, 2008 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
2003 Chevrolet S-10 Logo

Related Topics:

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...