Question about Dodge Grand Caravan

1 Answer

I just unhook my radios harness to put in a new deck and now my clusters is acting up by staying on after i turn off the van and my locks do not work now plus lights stay on after i turn them off. couls this be my body control module couls i reset it or i just got to get a new one

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Contributor
  • 613 Answers

Sounds more like you have a ground wire touching a power wire and sending false signal

Posted on Sep 12, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1997 jeep laredo everything was ok but when i replaced my radio with a aftermarket radio my cluster works just no gauges


You might have loosend up one of the connection on the back panel of the instrumentos cluster
Verify to make sure all conectores all fit in place

Oct 02, 2016 | 1997 Jeep Grand Cherokee

1 Answer

Dash cluster started acting up,also the radio just flickers. change cluster still doing same thing ? un hooked battery for 30 minutes. checked fuses.


Bad ground connection possibly . G - 203 ! Both radio an instrument cluster share ground 203 .
G203 In the I/P harness below the left side of the I/P near the A-pillar . Check to see if clean an tight connection .

May 30, 2016 | 2005 Chevrolet Avalanche

1 Answer

Installing aftermarket stereo, but van does not have acc position on ignition switch. Factory radio has power button, but also turns off after van has been turned off and driver's side door is opened. The...


Take a multi meter and find an open slot in the fuse panel use a bus connector and a piece of yellow 14 gauge wire and feed it up to the deck area .

Aug 17, 2013 | Cars & Trucks

1 Answer

Comfort access failure.


Sounds like they might have missed plugging the door harness in to the body, or maybe left a ground unhooked.

Apr 24, 2013 | 2002 Ford Excursion

1 Answer

Speedometer, tachometer, whole cluster not working on 99 olds 88


You shorted out the wireing harness, going to the guages, Possiblly evan a fusible link was mess up.

Nov 06, 2012 | 1999 Oldsmobile 88

2 Answers

I have a 1993 dodge caravan v6 3.0 the other day i was driving it and wen i braked at a light the van jerked back and cut off. when ever you put it in drive it jerks back and cuts off. does anyone know...


it sounds like the lock uo solenoid to the torque convertor is hung on. Find some one who knows about transmissions to unhook the plug to the lock up solenoid and ur problem will be temporarily fixed or you can put a new lock up solenoid in it to fix it. But it will not hurt it un pluged it will even save on gas.

Jan 04, 2011 | 1993 Dodge Caravan

1 Answer

Remove the starter motor on a 2001 ford windstar


FIRST TURN OFF RADIO SO YOU WONT LOCK IT OUT.THEN REMOVE NEGATIVE BATTERY CABLE.RAISE AND SUPPORT VAN SAFELY.REMOVE THE HARD SHELL CONNECTOR AT TERMINAL S GRASP THE PLASTIC SHELL.DO NOT PULL ON THE WIRE.DISCONNECT STARTER ELECTRICAL HARNESS.REMOVE THE UPPER STARTER BOLT.SUPPORT THE STARTER AND REMOVE THE LOWER BOLT.REMOVE THE STARTER FROM VAN.THEN WHEN YOU PUT ON NEW STARTER TORQUE BOLTS TO 20 FT LBS.

Feb 21, 2010 | 2001 Ford Windstar

1 Answer

Gauges act up and engine shuts off


What year and model is the van? If it's a 97-2001 caravan, then there were issues with the clusters cloking up, usually from an electrostatic discharge. Generally they would still run, just could'nt use the gauges. There is a printed circuit board on the back of the cluster that is succeptable to electric spikes. The most common cause is a spike induced from the secondary ignition cables into the main engine wiring harness. Look at the ignition wires on the rear of the engine, they may be routed too close to the harness under the upper intake plenum. The data bus wires run between all of the modules on the van and any electrical spike can cause this. There was also issues with spikes from the door lock actuators/latches. If they're buzzing when you hit the power locks this may be your problem.

Jul 26, 2009 | 1998 Plymouth Grand Voyager

2 Answers

Wiring harness problem


the issue is the trailer, negative or power feed back,check grounds

Jul 24, 2008 | 2002 Ford Windstar Cargo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...