Question about 1991 Toyota 4Runner

1 Answer

1990 V6 petrol auto Hulux with 3VZE engine - changed head gaskets, reconnected everything and will start but only rev to 300 -350 rpm. When pumping accelerator no change. Will run like this for 5 minutes then stop. Checked computer and no error code indicated. Checked fuel and pressure at all connections.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 642 Answers

Double check the timing belt installation. You got the cam timing wrong. These engines are pretty much a pain to set up with regards to cam timing.

  • Disconnect battery negative
  • Remove bottom engine cover
  • Drain coolant.
  • Remove radiator. - Remove hoses. Remove oil cooler pipes. Remove fan shrouds
  • Remove power steering and A/C belts
  • Remove coolking fan
  • Remove alternator belt
  • Remove the water outlet and studs and unclip HT cord clamps
  • Remove the timing belt cover.
  • Line up the crank pulley groove to the 0 degree mark
  • Check that the cam pulley marks line up with the corresponding marks on the rear timing cover(Dont bother with the marks on the belt). If the marks on the pulley are at the bottom rotate the crank once(360 degrees) and check again that they line up with the cover.

Posted on Sep 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

3vze timing belt kit


the vin number has specific build identifiers that may help. run the vin on google or call your dealer. also the part your looking for i just purchased on ebay for half of what my parts guy wanted. let me know if this helps..

Jan 26, 2012 | 1990 Toyota Xtracab

1 Answer

Toyota 4runner v6 engine 3vze 1991 year-problem engine light on and less power-i change oxygen sensor and coil ingnition cap-i find into engine control some burned componets, i change it and for some month...


A common problem in the Toyota V-6 engine was head gasket failure. This doesn't sound like the symptoms that we had with our 4-Runner, but is worth checking. Does the vehicle use fluids, such as coolant. Or does the oil tend to discolor milky or brown?

Sep 10, 2017 | Toyota 4Runner Cars & Trucks

2 Answers

1995 mazda mx6 2.5 v6 kl engine. Replaced head gasket cam timing and enerything fine but when u start it the engine revs to 3000 rpm for about 5 seconds then comes down. then starts reving itself to about...


Hi,
Looks like vacuum leaks and some sensors are not connected.
Re check everything again and tell us what happen, so that we could guide you better.
Thanks for using Fixya!

Dec 08, 2010 | 1995 Mazda MX-6

1 Answer

Engine is dying on idle


quick test , replace a piece of the fuel line with a clear plastic one, chaeck for air bubbles especially with less than half tank

Jul 28, 2010 | 1990 Isuzu Trooper

1 Answer

3vze v6 engine no power to fuel pump can only


remove the passenger side of your dash "the glove box" there is a circuit opening relay tucked up behind the speaker it's small box. it reseavs signal from efi and maf then sends power to your pump. good luck...peace and love for all...

Jan 22, 2010 | 1994 Toyota 4Runner

2 Answers

I have a 1990 pontiac grand prix LE 3.1 v6 and it starts but when the engine gets warm it starts to spudder and when you hit the gas it will shut off i replaced the fuel pump and the fuel filter and ideas


Possible blown head gasket. Check the oil to see if there is water in it. When it starts, does water or steam come out of the exhaust pipe? Those are 2 signs of a blown head gasket.

Jun 12, 2009 | 1990 Pontiac Grand Prix

1 Answer

Engine high rev at stop and slowly goes to idle speed.


I've got Hyundai Lantra 1.6 year 2000. It's take time to start when it's hot. When I start my car it revs at about 2k-3k rpm. It also does it when I come to a stop. When I come to a stop it will stay at a higher rpm than that of idle speed. It drives ok when on freeway but uses more petrol. I have changed the water & petrol pump but no luck

Oct 26, 2008 | 2000 Hyundai Elantra

Not finding what you are looking for?
1991 Toyota 4Runner Logo

Related Topics:

88 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

78267 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8836 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...