Question about Chevrolet S 10

2 Answers

I have chev s-10 4.3 v-6 started while driving the engine would shut off, pull to the side of road restart an drive off some times it would do the same 15 minutes later, pull off road restart an drive again, i noticed that when it shut off all dash idiot lights were not on, only when idiot lights came on would the truck start, now it will not start an there are no idiot lights, the radio will work, please help, thanks

Posted by on

  • alamericantr Sep 08, 2010

    engine turns over it just wont run, batt is fine an alt is fine

  • alamericantr Sep 08, 2010

    engine will turn over, it just wont start, the batt. is fine ,alt. is fine.

×

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Expert
  • 4,070 Answers

Hi! Pretty much a PCM (powertrain control module) problem. The PCM has connectivity on all electric current that runs inside the car. If the PCM is faulty there surely be failure on the electrical somewhere. You will need to have the PCM resetted to resolve this but as a first course of action please try this. Open the hood and remove the positive battery connector and let it sit for atleast 5mins. to reset the system. After reconnection, see how it goes. Hope this helps and thank you for using FixYa!

Posted on Sep 08, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 6,927 Answers

I do not know what year it is,but it sounds like a bad connection at the battery,have the alternator checked also.But be sure to clean the battery terminals and the battery connections on the battery,until they shine.

Posted on Sep 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Engine dies


if it shuts off while driving down the road. and restarts after 10 minutes, its usually a bad crank sensor that does this. it messes up timing and shuts off fuel supply.

Apr 05, 2014 | 1994 Chevrolet Suburban

1 Answer

No start or quits going down road then re starts after 10 mins no spark


a bad crank sensor will cause car to shut down, and restart in about 10 minutes.while driving down the road.

Mar 13, 2014 | 2004 Chevrolet Impala

2 Answers

I was driving home on the freeway and everything in the car shut off. I pulled to the side of the freeway, restarted my car, drove little more and then everything shut off. I restarted it, continued and...


Lose connection , broken wire inside the insulation . Where on the vehicle is the wire , how many wire's ? is it a whole wiring harness ? What color wire ? Open up the wiring harness an check the wire's one at a time . Pull on the wire's an see if one comes apart . If the wire is broke inside it's insulation you won't need to pull real hard for it to come a part .

Mar 17, 2017 | 1993 Buick LeSabre

1 Answer

Was driving down the road and it just went dead. It's getting gas and fire but will not crank.


I encountered a similar problem on a chev 4cyl with a coil pack ignition ( no distributor). It would run for a while and suddenly die out and wouldn't restart until a 10 to 20 min. cooling period. It turned out to be a crankshaft position sensor going bad. On this engine it was located in the engine block under the ignition module on the firewall side.

Aug 13, 2011 | 1998 Chevrolet Cavalier

2 Answers

Volvo 740 engine shutting off intermittently


sounds like a broken wire, but i cant say where, on ignition, fuel pump, under dash, quik scan could save alot of time an money

Jan 04, 2010 | 1990 Volvo 740

1 Answer

When I drive the lumina about 20 miles and brake to stop engine dies. Will restart in park but as soon as put in drive or reverse it instently dies after it cools about 10-15 minets can restart and drive


a bad crank sensor causes a car to shut down while driving down road. and will not start back up for about 10 minutes. have car scanned to read the problem codes. any auto parts stores will scan for free.

Dec 01, 2009 | 1995 Chevrolet Lumina Apv

2 Answers

Engine wont idle unless you keep your foot on the gas pedal


First, try a new accelerator pump. They're less than $10 and easy to install. On the side of the carburator, near the linkage. It's simple a small rubber diaphragm.

Mar 15, 2009 | 2001 Toyota Tacoma

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

245 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...