Question about 1996 Chevrolet S-10 Pickup

1 Answer

My Chevrolet S10 1996 currently problem is when I ride up in elevation the truck stalls. Also, coming down in elevation it drives fine but when I come to a stop it stalls. Could this be a Coil wire?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 39 Answers

Sounds more like a fuel / air problem. What is the condition of your O2 sensors? They could be reading incorrectly and causing a lean or rich condition.

Posted on Jan 14, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 disco 1 sd starts when cold but when hot wont start, if you floor the gas it starts but stalls, wont start again until at least the engine cools then the idle runs high & then comes down afte


I had this same problem my 1996 discovery . oddly enough lights came on bright etc i thought ok all electrical is good .. Nope , i jumped a pair of battery cables from the negative battery post to the bracket where alternator bolts on to a ground pretty much .. This problem went away completely.. So it was just a current issue wasnt getting enough to light those spark plugs my guess or the computer was doing something else whne it diditn see all the current it needed .. i have no idea but it fixed it

Dec 05, 2013 | 1996 Land Rover Discovery

2 Answers

Idle


MAYBE CHECK (MAF) MASS AIR FLOW SENSOR

Jun 29, 2013 | 2000 Chevrolet Tracker

1 Answer

2002 Malibu stalls while driving, doesn't over heat. But can start smelling gas fumes before it stalls. usually wait about 5 mins then restarts. in higher elevation runs fine but in lower elevatio


It sounds like the catalytic converter could possibly be almost completely plugged up not allowing the exhaust to leave the engine like it should. It just builds up in the cylinder head and when it gets too much in it built up and there's no where to go, it'll stall the engine. By letting it sit for a few minutes, it gives the exhaust time to find a way out and the car will restart.

Mar 27, 2013 | Chevrolet Malibu Cars & Trucks

1 Answer

Chevrolet spark. The engine stalls as car slows down . after driving continuously the problem disappears


so it stalls when you stop. that can be a bad throttle position sensor or a idle air control valve. is there any codes

Dec 13, 2012 | Cars & Trucks

1 Answer

I have a 99 K1500 suburban. It starts fine and runs fine. I just had a new GM crate motor installed. When you start it, sometimes it will stall, or get a rought idle and stall. Everything works fine when...


new engines always receive a tune up with new parts. The brochure that comes with these engines highly recommends that for the warranty to be intact. Do that first if not done yet

Mar 26, 2011 | 1999 Chevrolet K1500

2 Answers

Car runs fine when cold, when warm it stalls


My first guess is a vacuum leak or maybe a defective IAC. Tests need to be run to narrow the search down.

Apr 17, 2010 | 1990 Chevrolet Lumina

1 Answer

Suburban stalls while driving after running for 15-30 minutes. After letting it sit for 5-10 min it runs fine for another 5-10 minutes, then starts doing it all over again.


a bad crank sensor can cause this. shuts off while going down road, and will start about 10 min, later with no problems runs fine until it quits again. hope this helps,

Oct 07, 2009 | Chevrolet Suburban 1500 Cars & Trucks

2 Answers

Stalls when under load "driving"


Check the ignition module. My car would run fine until it came up to full temp and then run bad. I continued driving the car while trying to diagnose the problem. It got worse and then one day the car stalled as if it ran out of gas (still had plenty in the tank). I was able to coast it into a parking spot and called for a ride. Upon returning, I tried to start it, started right up and ran fine. On the way home it started acting up again (once it was up to temp). It turned out to be the ignition module.

Jun 29, 2009 | 1995 Chevrolet Lumina Apv

1 Answer

Car stalls when stopping sometimes - starts ok then stalls


torque convertor not unlocking u can unplug the wiring 4 the torque convertor on the transmission u can drive it fine after u unplug it or spend $1000 to have it replaced ur call

Apr 05, 2009 | 1990 Oldsmobile Cutlass Calais

Not finding what you are looking for?
1996 Chevrolet S-10 Pickup Logo

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...