Question about 2000 Alfa Romeo 166

5 Answers

Alfa Romeo 166 ICS Radio AUDIO mode is inoperative. As I switch the radio button to the "ON" position by pressing the switch, I get all the tuninig of CD/Casette/FM/AM radio frequencies, but non fo them can be heard. My Alfa Romeo 166, has an ICS serial no. BE 2569 X 5044595. Would appreciate details of how to reactivate the AUDIO of my ICS radio system. Thank you.

Posted by on

  • 5 more comments 
  • gabrielb744 Sep 08, 2010

    I followed your directions to the letter, FUSE 4 (ICS Stereo),was found faulty (15 amps), it should have been 10 Amps as per Car Manual. I replaced the broken FUSE for another 15A, and after completing the steps you mentioned the FUSE I replaced broke one more time. Decided to put a 25 Amps FUSE, this one stayed o.k, radio features such as CD/Cassette/FM/AM all tuning ICS screen showing frequencies, but Car radio "Audio" not sounding. Comments?

  • gabrielb744 Sep 09, 2010

    Amplifier checked and inspected, nothing wrong with radio or amplifier. I do remember in last ocassions I was able to operate radio that the engine acceleration interference could be heard on the speakers on the background of the music.



    Radio code works as per card specs, auto tuning on FM/AM feature works perfect, CD player finds CD track, cassette winds alright, ICS screen showing nothing muted, but NO AUDIO on any feature selected???

  • gabrielb744 Sep 09, 2010

    Alfa Romeo 166 year 1999, ICS Radio, worked perfectly for 10 years, most recently lost audio on all features, named FM/AM/CD/Cassette, inspected wiring, fuses, amplifier, etc no change.

  • gabrielb744 Sep 10, 2010

    I have my ICS radio code, the radio activates but the problem is "VOLUME", no AUDIO, no chance to hear anything from the ICS screen selection, either FM/AM or CD/Cassette.
    Checked all fuses and connections are O.K, any idea how and why the radio speakers do not emitt any sound whatsoever??

  • gabrielb744 Sep 11, 2010

    Interesting thought, my CD player contains 6 CD's, sometimes because of the bumpy roads in Istanbul, the CD player stumbles but comes back. Now about the output of transistors, would it be possible to drain or change them for more capacity before I consider changing the ICS radio system? It would be a pity that I cannot keep this vehicle with original parts.

  • gabrielb744 Sep 13, 2010

    As I was about to take your suggestion to a nearby car radio specialist, my wife decided to turn on the radio this morning and the ICS radio system worked perfectly with AUDIO on all modes, named Cassette, FM/AM, CD player, it was like a sudden awakening. There was however in the background the sound of an interference increasing when you accelerate, decreasing when you decelerate, do not know what is the relationship between the engine RPM's and the car radio audio system.

    AS we parked and had to go again, the ICS system tried to hold on again, but it went to sudden death again. Do you still believe the AUDIO board of the amplifier needs to be isnpected/changed?

  • erjonmustafa
    erjonmustafa Jul 16, 2013

    i have a alfa romeo 166 becker model:be2580 serial no:15086003.. i need code for cd player.. can u help me?

×

Ad

5 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,319 Answers

The audio board is at fault. Take the unit in for repairs at any car dealership. They can send it out for repairs to any center that repairs radios for cars

Posted on Sep 11, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Alfa Romeo Master
  • 22,219 Answers

If you are not showing any mute or audio off on the screen then ask in dealer as they should know if their is a audio off or mute mode and if their isnt then put a new radio in ,one with usb and SD card support so you dont need to use CDs ,Its possible that the audio output transistors have packed up

Posted on Sep 10, 2010

Ad

Try these codes "3178" "4444" "3179" "6066" or "6607"

If this don't work, try this website:

http://www.radio-code.co.uk/

http://boardreader.com/thread/ICS_Code_for_Alfa_Romeo_166_Becker_radio_87ioX1863.html

Posted on Sep 09, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Alfa Romeo Master
  • 17,970 Answers

This isn't one activated audio system request, or unlock code for the radio, sound like a problem wuith the amplifier.

Posted on Sep 08, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Alfa Romeo Master
  • 19,396 Answers

Hi.

Check fuses that control the ICS system:
Fuse 7 ICS
Fuse 4 Stereo
Fuse 18 ICS battery

If fuses are Ok, perform following reset:

Disconnect battery ground cable.
Disconnect and connect back in the ICS connectors.
Disconnect and connect back the stereo cable.
With ground disconnected, touch negative cable to positive terminal for a couple of seconds and then reconnect the ground cable to the battery. This will discharge the system

Note: after disconnecting battery you will be asked for stereo and ICS codes. Ensure that you have the codes, or better performing the operation at the dealer.

Posted on Sep 07, 2010

  • Ginko
    Ginko Sep 10, 2010

    Hi.

    Regarding your comment: "I followed your directions to the letter, FUSE 4 (ICS Stereo),was found faulty (15 amps), it should have been 10 Amps as per Car
    Manual. I replaced the broken FUSE for another 15A, and after
    completing the steps you mentioned the FUSE I replaced broke one more
    time. Decided to put a 25 Amps FUSE, this one stayed o.k,"

    The POWER DRAW MUST BE WITHIN 10 AMPS. Do not replace fuses with bigger Amps ones, that is not a solution. fuses are made to blow at specs amps. If they need more amps, then there is an abnormal power draw due either to a fault , or to a contact in wiring. If you increase the Amps fuse won't do its job.

    You need to remove the unit from the dash, check wiring, and if that does not fix the problem check internal components.

    Sorry to see that you left negative feedback. On your request the question will be passed to a different expert.

  • Ginko
    Ginko Sep 11, 2010

    Stating to your description the radio was drawing far more current that it should.

    I have already answered twice and I received a bad feedback.

    You keep asking same question:

    Either there is a wiring problem (a fibre from speakers copper wire touching ground can do this), or the radio is defective. The fact that the radio worked for ten years does mean nothing. A light bulb can work for ten years and then blow, a rope can be tied tosomething for ten years before the fibre breaking.

    The only way to find the problem is removing radio for the dash and then testing it and testing its wiring.

    Note: Since the radio was drawing too much power and you replaced the fuse with a bigger amp one, this may have damaged the radio, allowing a bigger draw and blowing the ICs/Transistor in the final amp section of the stereo. The fuse was a ten amp one to prevent this possibility.

    Here my previous comment:

    Hi.

    Regarding your comment: "I followed your directions to the
    letter, FUSE 4 (ICS Stereo),was found faulty (15 amps), it should have
    been 10 Amps as per Car
    Manual. I replaced the broken FUSE for another 15A, and after
    completing the steps you mentioned the FUSE I replaced broke one more
    time. Decided to put a 25 Amps FUSE, this one stayed o.k,"

    The
    POWER DRAW MUST BE WITHIN 10 AMPS. Do not replace fuses with bigger Amps
    ones, that is not a solution. fuses are made to blow at specs amps. If
    they need more amps, then there is an abnormal power draw due either to a
    fault , or to a contact in wiring. If you increase the Amps fuse won't
    do its job.

    You need to remove the unit from the dash, check wiring, and if that does not fix the problem check internal components.

    Sorry to see that you left negative feedback. On your request the question will be passed to a different expert.

    Goodbye.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Code for alfa romeo car radio clarion PU9156A


Take proof of ownership into Alpha dealership or contact Clarion direct.

http://www.clarion.com/gb/en/support/faq/security_codes/index.html

May 01, 2016 | Alfa Romeo Spider Cars & Trucks

2 Answers

How do i enter code on alfa romeo 156 jtd radio where can i find the code ? blaukpunt werke gmbh BP700532314916


You need another number to find your code. Go to this site to get it. https://www.radio-code.co.uk/blaupunkt-radio-codes.html

Oct 31, 2015 | Alfa Romeo Cars & Trucks

1 Answer

How


You MUST contact the dealer.

May 20, 2014 | Alfa Romeo 166 Cars & Trucks

1 Answer

NEED A RADIO CODE FOR ALFA ROMEO BP 037834830471


When you disconnect your battery and then reconnect it again, it disables the radio. This is an anti-theft protection for your car radio.
The enable your radio the activation code is in your vehicle owner's manual. If you do not have this code you need to go to your Alfa Romeo service centre and get them to enter this code for you.

Dec 02, 2012 | Cars & Trucks

2 Answers

I need the code for ics radio for 166 alfa romeo please


Not possible to answer this directly since each radio can be different. If you can manage to remove the radio you will find the serial number and the manufacturer on the back plate. Take a note of these then on your computer search engine type - Car Radio Codes, there are several web sites which will send you your code on line once you give them the radio details you have just written down. Cost is normally £10 or about $16

Jun 30, 2011 | 2000 Alfa Romeo 166

1 Answer

How do you set the clock in Alfa Romeo Model 166 year 2000


Go to settings on display - press trip button to get settings, then press right hand knob, turn same knob for set date/time, then I choose rda setting, this allows car to pick up correct time always from the radio hope this helps - I have problem with my driver's seat adjustment, will go back and forwards but not up and down!!

Apr 03, 2011 | 2000 Alfa Romeo 166

1 Answer

How to reset the radio on a spider---1989


Hi,

Some recomendations to try ..

1.) To reset the radio we press & hold the "BND" button till the incorrect numbers disappear.

2.) In case we do not have the correct codes we would need to get it from your dealer or try alfa parts.

Let me know if that worked...

Thanks,
Fame.

Oct 23, 2009 | 1989 Alfa Romeo Milano

1 Answer

I want unlook radio for alfa romeo 166


Do web search on "auto radio codes". There is a UK web site that will give you the code if you provide the serial no of the radio- costs around £12. I did mine and the service is good

Jun 15, 2009 | 2000 Alfa Romeo 166

2 Answers

Button trouble


Haven't had that problem but I have lost access to the Traffic reports from my radio on a couple of occasions. In both cases, disconnecting the battery and re-initialising the system cured the problem - perhaps it resets the software.If the aircon switches have failed, you will probably need a new unit but it may be a software error!?! As an aside, does anyone know if Alfa have updated the software at any time and whether the existing system can be updated?

May 14, 2008 | 2000 Alfa Romeo 166

Not finding what you are looking for?
Cars & Trucks Logo

2,397 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

905 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...