Question about 2002 Chevrolet Tahoe

2 Answers

HELLO, JUST CHANGED PLUGS, NOW IT RUNS RUFF......WHAT DID I DO WRONG?

Posted by on

  • Jeff Turcotte
    Jeff Turcotte Sep 06, 2010

    might you have got 2 of the wires on the wrong plugs?

  • djcbusby Sep 06, 2010

    WELL, ON MY TRUCK, THE PLUG IS RIGHT UNDER WHERE IT PLUGS IN TO.

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 50 Answers

On a 02 hoe the plugs should be an iridium. Not a platinum or ngk v power. Only iridium plugs are the right heat range for chevy motors and there not cheap last time I did then I believe they were $15 a peice my cost at the part store. I would also do wires. Always do wires and plugs together. Its just better over all. And use a dielectric grease on the ends of the wires before u plug them in and a anti sieze on the plugs themselves before installing them in the motor.

Posted on Mar 24, 2011

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Did you change the plugs with the correct OEM plugs? Also, you may a bad spark plug wire. Check that plugs are set at the correct gap.

Posted on Sep 06, 2010

  • djcbusby Sep 06, 2010

    WHERE DO I FIND THE CORRECT GAP?

  • Jeff Turcotte
    Jeff Turcotte Sep 06, 2010

    sometimes they sell you a bag plug too...

    Gap should be 0.040

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 Dodge Ram 2500 5.9 runs ruff a low rpm has a p300 p302 p306, p307 adn after about 1200 rpm the misfire goes away and runs smooth psi on # 2,6 is 147 and #7= 30 psi, I changed the ecm, new plugs an


Something like that is sure wrong in #7. If you do a leak-down test, it should tell you if it is an intake or exhaust valve losing compression, or exactly what it is. A bent push rod would be a blessing. Then maybe you wouldn't have to take the head off for repairs. Roll a push rod over a glass surface to check for straightness.

Dec 14, 2013 | Dodge Cars & Trucks

1 Answer

I changed the spark plugs in a 2005 buick rainier and now the car runs ruff and the check engine light is on


when you changed the plugs, did you make sure to gap them correctly? also, this could be faulty wires. Why did you replace them to begin with?

Mar 19, 2010 | 2005 Buick Rainier

2 Answers

Runs ruff changed mass air flow plug wires plugs


check for vacuum leaks, check distributor cap and rotor button, clean or replace as necessary. Use quality injector cleaner.

Feb 18, 2010 | 1993 Lincoln Mark VIII

2 Answers

Ruff idle on my 2001 for taurus. At higher rpms it runs fine.


It is most likely you wheel alignment (costs about 20 bucks to have your wheels aligned) or try checking the tire Pressure to make sure they're all even maybe hope this helps

Dec 29, 2009 | 2001 Ford Taurus

1 Answer

96 ford taurus ran fine yesterday go on 25 mile trip half way through trip engine runs ruff. Like miss firing just changed plugs about two weeks ago it idles ruff but runs doesnt stall at all. baffeled


sounds like spark plugs or spark plug cables are bad and it is in fact misfiring this happened to me in my car and my spark plug cables were bad

Aug 29, 2009 | 1996 Ford Taurus

1 Answer

I have 97 explorer 4.0 running problem


you could have a vacume leak or could be catalatic convertor or could be an injector problem possibbly need a little more info but i hope this helps a little

Aug 18, 2009 | 1997 Ford Explorer AWD

2 Answers

Engine runs ruff


you may have a valve or valves leaking which will cause it to run rough, have a leak down test done or a compression test

Jun 22, 2009 | 1994 Volvo 940

1 Answer

Starts ruff and smokes


check coolant temp sensor

Apr 18, 2009 | 1999 Saturn SL

1 Answer

Truck has no power up hills runs ruff


check or change thr fuel filter and if that dont fixit then i would look into getting a new fuel pump

Apr 02, 2009 | 1984 Nissan Pickup

Not finding what you are looking for?
2002 Chevrolet Tahoe Logo

97 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...