Question about 1984 Nissan Pickup

1 Answer

Well i just put a new pistin in my 1984 nissan 4x4 720 i put it all back togeather it started just fine but after bout 15 mins of running it starts to knock could my timeing be out or do i need to replace the other 3 pistins

Posted by on

  • dale blankenship Sep 05, 2010

    Could be your timing. Have you checked the timing per the specifications? If it is too far advanced, that will cause knock as the engine heats up. Did it knock like this before you replaced the piston?

    Are you sure that the engine is not overheating? (That can cause knock as well).

    Why did you replace one piston?

  • austinwood64 Sep 07, 2010

    well i got the truck for free alreadly tore apart with the new pision and gasgets and eerything els inside it just ha to put it togeather s i do not no what it sounded like befor

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Nissan Master
  • 4,336 Answers

Knocking is because something is loose, The only way to find it is to disassemble and measure all clearances.

Posted on Sep 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont stay running


ignition switch assembly. that what it sounds like.start there.

Jun 26, 2013 | 1984 Nissan 300ZX

1 Answer

My 1984 300zx starts fine and runs for about two minutes the dies. I can then then restart it and it does the same thing. I replaced the fuel filter and it didn't solve the problem. The car has be


Check fuel pressure with a gauge or at least
listen for the pump to come on when key is turned on

Cut that fuel filter open, so you understand what it does

They used to get clogged when fuel tanks were metal,
but you never get a not start,only lack of power at around
25 mph

Are you sure you just don't have a no idle condition

It runs 2 mins so what are you loosing,battery voltage,
fuel,spark ?

Nov 15, 2012 | 1984 Nissan 300ZX

1 Answer

1984 Nissan 720 4x4 starts fine but runs rich, misses, sputters. New distributor, plugs, wires, cleaned fuel tank.


check pvc and check for air leaks around intake and carb gasket use a little carb cleaner if engine sputters while spraying u have a leak

Aug 09, 2010 | 1984 Nissan Pickup

1 Answer

I have a 1984 nissan 200sx turbo, was running one day and stalled on me. After 15 minutes I got it to start and got it home. The next morning I tried to start it and nothing. It turns over but no spark,...


BACK IN 1984 NISSAN HAD THE ELECTRONIC IGNITION WITH AIR GAP ADJUSTMENT.YOU ADJUST AIR GAP IN THE DISTRIBUTOR BY LOOSENING THE STATOR MOUNTING SCREWS .MOVE THE STATOR UNTIL PROPER GAP IS ACHIEVED.THIS COULD BE NO SPARK CONDITIONS.

Sep 22, 2009 | 1984 Nissan 200SX

1 Answer

'84 Ford Ranger cuts off after about 30 mins of driving.


sounds like the auto choke isnt turning itself off properly but to be totally honest i would need this to happen when i test drive it to diagnose it correctly .

Sep 01, 2009 | 1984 Ford Ranger

1 Answer

93 altima starts fine drives fine once it has been driven long enough for the engine to heat up maybe a 15 to 30 min trip it doesn't want to start back if shut off. sometimes it cranks and cranks other...


You most likely have a bad fuel pump. Very common symptoms your describing, If your handy try squirting some brake cleaner into the throttle body when this happens. If it starts you now know what to do. Also be sure the battery terminals are clean. Voltage drops can cause a fuel pump not to run or run ineffeciently.

Jul 14, 2009 | 1993 Nissan Altima

1 Answer

1984 bronco 2-runs 15 min shuts down wont start again for 20 runs


If the fuel filter is dirty it will settle when you turn the truck off. When it runs for a few minutes the debris in the filter will get sucked into the screen and stop the fuel from getting through. If it was a starter or coil, it would not start at all.

Dec 05, 2008 | 1984 Ford Bronco II

1 Answer

Is it my battery?


well this is what you should try ,,jump the car get it running
then when its warmed up take the positive lead of the battery
if the car stops the alternator is gone (thats what charges the battery) if the car runs its fine

and if u have put another new battery in it and the alternator is fine look for any broken wires earths or positives that could be making it drain so quick
and make sure your battery levels are full
hope this helps

Jul 02, 2008 | 2001 Mercury Cougar

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14251 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...