Question about 1995 Dodge Neon

2 Answers

My engine idles and revs fine from startup until the engine reaches std. operating temp. Then it starts missing, surging, and losing power until it stalls out. I have checked all the sensors that have a heat-related function (O2, IMT,) and they check out. What else can I do? What else can be causing this problem?

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 222 Answers

Those sensors won't cause that but a heated IAC will or you might have a severe vacuum leak. Start with IAC but get some starter fluid and (carefully) spray on different areas of the vacuum hoses. If sudden increase in RPM's that's different from what it's already doing then you found the leak.

Posted on Sep 05, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 373 Answers

Coil pack

Posted on Sep 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 pathfinder start up runs fine until it reaches normal temp after that it starts to bog down like its losing power whats wrong?


Check engine light on? Could be catalytic converters. No engine light. Have history codes read.

Feb 27, 2016 | 2003 Nissan Pathfinder

1 Answer

Engine backfiring and loss of power with throttle pushed in slightly


Need to put the cat back & the Oxygen Sensors

The O2 Sensors are for adjusting fuel trim

Can't use the vehicle the way you have it & it is
against Federal Laws to remove Emissions Equip.

Sep 19, 2012 | Cars & Trucks

1 Answer

1994 nissan pickup idles funny and looses power when @ opperating temp


these kind of behavior generally happens,when the tappets clearance is less than the specified .that means when the engine heats up valves elongates,and the gap reduces,resulting valve leakage,improper combustion,power drop, emission, missing etc....set the tappets

Mar 03, 2012 | 1994 Nissan Pickup

1 Answer

My 2001 Jeep Cherokee rough idle on hot start up


SOUND LIKE INTAKE MANIFOLD VACUUM LEAK OR VACUUM HOSES VACUUM LEAK.ALSO DIRTY FUEL INJECTORS WILL CAUSE THAT PROBLEM YOU DESCRIBE.

Apr 02, 2010 | 2001 Jeep Cherokee

1 Answer

My 98 jetta 2.0 will not hold idle by itself until reaching operating temp. then a good long idle. in drive it completly shuts down after about 10-15 sec driving. will start up run for a few sec and shut...


Try replacing your Engine Coolant Temp Sensor, it's cheap and easy to replace. Just remember do it when the coolant is cool to work with before you start cracking a pressurized system.

Mar 02, 2010 | 1998 Volkswagen Jetta

2 Answers

Bmw 316i had a service a week ago but car losing power when first started up.. Once it heats up the car seems fine. Any ideas


is it just idling roughly or hesitate when accelerating? You may have a clogged cold start injector in which you could have poor performance before the vehicle heats up to its operating temp but once it reaches its peak temp will run fine. Did your servicing include a tune up and/or fuel system cleaning if not I would recommend one.

Aug 05, 2009 | BMW 3 Series Cars & Trucks

2 Answers

1995 Lexus SC300 looses power as temp increases.


could be clogged cats or may even be bad crank sensor.

Jul 06, 2009 | 1992 Lexus Sc 300

1 Answer

When warmed up, the engine (2.7) may miss erratically


1391 is lose off cranksensor or cam sensor like code 340 i would by a cam sensor for that code.356 sounds like a bad coil on #6 which there are one per cylinder .dont worry about code 432 for now.

Mar 15, 2009 | 1999 Dodge Intrepid

1 Answer

Saab 2.2tid car loses all power when warm, rev counter goes to zero


Check fuel feed is ok and fuel pump pressure also check cold start injector could be running on this til warm.

Sep 16, 2008 | 1999 Saab 9-5

Not finding what you are looking for?
1995 Dodge Neon Logo

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

77202 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...