Question about 1999 Mitsubishi Eclipse

1 Answer

Low temp fan won't come on. Has new temp sensor, new thermostat, radiator is clean, can unplug sensor and override and make both fans come on but won't come on independantly.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,297 Answers

Supply power and ground direct to the fan
if still inop you need a new fan

Posted on Sep 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Overheating


That is normal cooling fan operation. the fans are computer controlled and not turned on until the engine reaches the pre programmed temperature, that is about 185-195F

Jan 03, 2014 | 1998 Chevrolet Lumina

1 Answer

1992 Ford Tempo Coolant Fan


the "sensor " near the thermostat should have 2 ,3 or 4 wires to it
if it only has one wire , that is the temp gauge sender unit and not the coolant sensor the coolant temp sensor reports to the ecm and that unit then switches on the fan relay that spins the fan
if you unplug the coolant sensor and the fan starts to run you have a serious coolant temp sensor circuit problem
take it to an accredited service center and have it sorted

May 01, 2017 | Ford Cars & Trucks

2 Answers

Cooling fans not working at all i have replaced the relays and thermostat. what else could be wrong


Most likely a bad coolent temp sensor. To check unplug coolent temp sensor while vehicle is running and see if fans come on. If fan comes on replace coolent temp sensor.

Feb 21, 2011 | Chevrolet Impala Cars & Trucks

1 Answer

My 1996 grand prix started to register cooling temp of over 210 degrees. the motor doesn't seem to be overheating. I've replaced the water pump, thermostat, temp sensor, both fan relays, low coolant...


I would first check the cooling fans. To do this unplug the fans and use two jumper wires to hook them direct to the battery and test. If the fans are working I would have the radiator cleaned or purchase a new one. To clean the radiator take it to a professional and tell them you would like it rodded out. You can purchase a new one for about twice the price. I wouldn't worry about the low coolent sensor. By it being on it will not send a message that your vehicle is overheating. If you have changed everything that you say you have and the fans work and radiator is cleaned you may have a blown head gasket. If you have a blown head gasket you would see steam comming out of the tail pipes or water in the oil on dip-stick. Good luck.

Feb 20, 2011 | 1996 Pontiac Grand Prix

1 Answer

Replaced the radiator, and the fan relay sensor, fuse is fine and fans work but the fans will not turn on when the car starts


Radiator fan will not come on right away, only with a/c on, fan should come on when temp. is about 1/2 way up, or 220 deg., if fan is not coming on at all with a/c off, check your coolant temp. sensor, sits close to your thermostat, if you unplug it and fan comes on, replace sensor.

Jul 07, 2010 | 2002 Chrysler Town & Country

2 Answers

Engine coolent temp circuit high input. what is


More than likely the fan switch in the radiator has failed or the fan itself has failed / is not running, so the water returning from the radiator to the engine is HOT therefore you are seeing the high coolant temp input indication. Check out the operation of your radiator fan.

If the fan circuit is OK then the water temp thermostat may very well be be stuck closed.

Thanks for using FixYa.

Kelly

Mar 20, 2010 | 2002 Kia Sedona

1 Answer

Radiator Electric Fan Motor on a 2003 Buick Century won't come on when temp gets high


I have a 1997 Buick Century with the same problem. Both my fans work if the A/C is
on as they should. If your turn off the A/C the passanger side fan will not come on
and at an idle the coolant in the radiator will boil, you can hear it in the overflow tank.
If you are driving there is enough air flow thru the radiator that the coolant doesn't
boil and the car doesn't overheat. I have replace the water pump, the thermostat.
and the ETS or engine temperature sensor mounted just above the thermostat in
the thernostat housing, to no avail, I still have the same problem. The only other
thing is the coolant level sensor in the radiator, which I haven't replace yet due
to the fact you have to pull the radiator in order to replace it, which is a major
undertaking. I have a low coolant indicator on all the time on the dash so I have
a pretty good idea the coolanat level sensor is bad. The coolant level is not low
so that sensor is not working as it should. I hope this may help with your problem.
To test you fan raise the hood when it is cold and top off the radiator and fill the
overflow tank to the cold mark. Start the car and let it idle with the A/C off and
see if the drivers side fans comes on. It will have to get to operating temp
before the fan will come on. If it doesn't come on replace the radiator low coolant
sensor on the passanger side of the radiator. If that doesn't fix the problem
replace the thermostat and the Engine Temperature Sensor at the thermostat
housing with an A/C Delco Engine Temperature Sensor. Good Luck..

Sep 26, 2008 | 2001 Buick Century

Not finding what you are looking for?
1999 Mitsubishi Eclipse Logo

Related Topics:

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...