Question about 2006 Mercury Milan

4 Answers

I have a 06 Mercury Milan with 120k miles. Yesterday morning I noticed a strange smell when I got in my car; hard to describe but almost tangy? I thought maybe my daughter dropped some food between the seats or something. Then when I got in my car this morning, I noticed the same smell but a lot stronger. My car started fine but after starting, battery light came on & dash said "check charging system" then I went to back out I noticed my power steering wasn't working...so needless to say I didn't drive today! Anyone know what the problem might be & how/where do I check to see if that's what it is? I'd like to figure out what's wrong so before I decide where I'm going to take it. Will I have to have it towed or is it drivable? Thanks;) Oh, had new battery put in a couple months ago. Also had oil change 2 weeks ago & all fluid levels were fine at that time.

Posted by on

  • krissiann Sep 05, 2010

    Ok. 1: Ps is below min so I got ps fluid. Does it really have to b brand manual says? 2: belt is either loose or broken. As soon as I opened hood I could tell it wasn't tight. I went 2 pull on it

  • krissiann Sep 09, 2010

    All clear! Filled fluid back up

×

Ad

4 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same thing just happened to mine, the belt popped off I haven't had it fixed yet though

Posted on May 03, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 869 Answers

Check if the battery is discharged. did u leave the car idle for a longtime and the battery might have got discharged in meanwhile ?

Posted on Dec 28, 2010

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 118 Answers

Sounds like the heater core is leaking and you may have lost you drive belt for your PS and Alt

Posted on Sep 05, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 333 Answers

Sounds like your belt broke or came off. If the power steering quit working too. The belt runs power steering, alternator, A/C unless it is different belt. Have you looked under the hood at all? If it turns out that it isn't that. Then check all of the connections on the battery and alternator. Check fuses for charging system.

I hope this helps.

Posted on Sep 05, 2010

  • 5 more comments 
  • krissiann Sep 05, 2010

    Ok. 1: Ps is below min so I got ps fluid. Does it really have to b brand manual says? 2: belt is either loose or broken. As soon as I opened hood I could tell it wasn't tight. I went 2 pull on it

  • krissiann Sep 05, 2010

    Ok. 1: Ps is below min so I got ps fluid. Does it really have to b brand manual says? 2: belt is either loose or broken. As soon as I opened hood I could tell it wasn't tight. I went 2 pull on it

  • krissiann Sep 05, 2010

    Ok. 1: Ps is below min so I got ps fluid. Does it really have to b brand manual says? 2: belt is either loose or broken. As soon as I opened hood I could tell it wasn't tight. I went 2 pull on it

  • Biggdex35
    Biggdex35 Sep 08, 2010

    Hey, sorry bout that. I just now seen that I had a comment. No you can use any powersteering fluid. If it was low then I would get some with stop leak in it. And as for the belt, if it is loose then look for a pulley that isn't hooked up to anything. Its called an idler pulley. It is more than likely stuck. It has a spring on it and that is what holds the belt tight. Or it could just be the belt jumped off of one of the pulleys. Let me know what you got. I hope this helps.

  • Biggdex35
    Biggdex35 Sep 09, 2010

    Hey I was trying to find a belt diagram for your car. And I found the problem. Here is a link.

    Good Luck.
    http://www.ricksfreeautorepairadvice.com...—belt-squeal-fix

  • Biggdex35
    Biggdex35 Sep 09, 2010

    Hey Krissiann,

    I was looking for you a belt diagram and found your problem.
    Ford has issued a technical service bulletin to fix a problem with certain 2006 Ford Fusion and Mercury Milan vehicles. Ford reports that some of these vehicles with the 2.3L engine built before aa/1/2005 may have a belt squeal from the FEAD. Ford defines the FEAD as Front End Accessory Drive. Ford has issued a newly designed shield, belt, and tensioner to correct the squealing problem. Alignment instructions for the new tensioner are included in the TSB.


    I would go to the dealer and check into buying one. Looks like it should be a recall to me.

  • agwbk Jan 23, 2011

    i agree with Biggdex35 the smell would have been the belt slipping and no charge and no p/s inspect and simply adjust or replace the belt. regards agwbk

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wheres the fuel filter for a 2010 Mercury Milan


Should be part of fuel pump assembly. I looked at an online partsbook for your vehicle--2.5L engine--didn't show fuel filter. That usually means, the filter is part of fuel pump assemble.
Have you checked for applicable trouble codes? Your saying it stalls every couple of miles?

Sep 25, 2016 | 2010 Mercury Milan

1 Answer

Why do I hear a strange vibrating noise in the trunk when I try to open it, it happen's either with inside button or remote


Your trunk release uses a solenoid to power the release switch...a noise is common when engaging this...is this a new noise, or just noticed?

Mar 28, 2015 | 2006 Mercury Milan

1 Answer

2010 Mercury Milan has rotten egg smell when the AC is on, now it's stalling out when driving? Can anybody help with diagnosis?


This car has a problem with the emission control system, it is under warranty and should be returned to the dealer for repair.

Jul 17, 2012 | 2010 Mercury Milan

1 Answer

I went to start my 2006 Mercury Milan this morning & it jus clicked. Got a jump from someone but i am not sure if it's the battery or starter, what should i do?


you need 2 get your battery tested any auto sparky will do it they can also check your starter only takes bout 5 mins

Sep 08, 2011 | 2006 Mercury Milan

1 Answer

Is ir normal to replace rear brakes on a 2010 mercury milan with only 22,300 miles? 15-16,000 of the miles are highway miles


The rear brakes should last 70,000 miles, if
you disassemble,clean & lube once a year,
on the rear of most all cars

My question is --- have you not had years or decades
of experience with other vehicles?
If so, why would you ask that question?

Aug 25, 2011 | 2010 Mercury Milan

1 Answer

My battery went dead after only 16,000 miles- I have the car for 2 years, 6 months. Is there a recall notice out on the charging system or battery used in the Milans. It's a 2007 Milan 6 cyl AWD model


no there is not a recall on your milan, only on the monterey for after market fuel filters. The fact of the matter is they just don't build them like they used to. So Its probably your alternator thats the number one probable cause.. hope this helps and god bless.

Feb 13, 2010 | 2007 Mercury Milan V6 AWD Sedan

1 Answer

1997 nissan Pathfinder once warm rpms drop when


The sweet smell is your engine coolant,check for a leak under the hood,look for green fluid,Have your catalyst checked,for the other problems,and your fuel presure checked,or change the fuel filter.Either of these should help a little.

Jul 22, 2009 | 1997 Nissan Pathfinder

Not finding what you are looking for?
2006 Mercury Milan Logo

741 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

fordexpert

Level 3 Expert

5546 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...