Question about 1997 Pontiac Grand Am

1 Answer

My speed op, water, gas gauge does not work - 1997 Pontiac Grand Am

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

Sorry for your troubles. Need to check your fuse box and the fuses for the problem areas. If it is not the fuses then most likely it is in the wiring. Again sorry.

Posted on Sep 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1997 ford expedition eddie bouer addition at the same time my oil,battery,and temp gauge started reading high why the speed and gas gauge is bottomed out but the tech gauge works fine


a guess
thats a lot of sensors to fail all at once
may need an auto electrician
.any fuses blown
if happened all at once
voltage overload/spike from alternator regulator
or huge short / wire loom melt ....

May 30, 2016 | 1997 Ford Expedition

1 Answer

Mariva 1.4. Why does temperature gauge reading fluctuate?


check grill and radiator fins are not plugged and fan is not damaged and is working.
sounds like a thermostat or water pump issue.

Jan 09, 2016 | Vauxhall Cars & Trucks

1 Answer

Over heating not shifting right


Gas gauge is most likely the sending unit in the gas tank. 99.99% of the time. Shifting and speedo could be from a bad speed sensor. Speed sensor is at the tail end of the transmission. The over heating could be from a stuck thermostat or low coolant(cheapest fix) to a blown head gasket.(not so cheap fix)

Apr 05, 2014 | 1994 Chevrolet Camaro

1 Answer

1993 chevy 9c1 caprice with L05


I would say that the gauge is ok but the problem is a blocked radiator cores that are not allowing the volume of water to pass to cool quickly. The high speed RPM makes the water pump work hard and if the water cannot circulate readily then the water will heat up in the block and head. When you back off the water circulation is just enough to cool the water . Have a flow test done on the radiator and if sufficient the a new radiator is the answer as flushing only cleans out the cores already flowing. Check the thermostat is opening all the way and replace it if it is faulty.;. If you do not have a thermostat then put one in as the flow rate is too fast to allow the water to cool.

Jan 09, 2014 | Chevrolet Caprice Classic Cars & Trucks

1 Answer

Both speedometer and gas gauge not working properly. Gas gauge giving readings all over the dial and speedometer starts to give proper speed then it reduces speed on meter until reading zero even though...


Hello: To correct this condition you will have to replace the cluster. After replacement the mileage and engine hours will have to be reset then the cluster will have to be programmed to your truck.

Jan 23, 2011 | 2003 Chevrolet Tahoe

1 Answer

Speedometer on my 2004 Tiburon works thens cuts down to zero. Gas gauge is doing the same thing. Just put gas in drop down to empty yet still has gas in it.


Clean the connectors on the back of the BCM and on the back of the gauge cluster.

If that doesn't work, then it could be:
- Fuel Sender & Vehicle Speed Sensor (should cause your "Check Engine" light to come on)
- Gauge Cluster
- BCM

You'll have to diagnose each of these possibilities.

Jan 16, 2010 | 2004 Hyundai Tiburon

1 Answer

All of a sudden my speedometer and my gas gauge quit working


If it would of been only your speedometer I would of tell you to replace your speed sensor. But in this case you gas gauge stopped working as well so I would recommend taking your whole cluster to a mechanic he will try to fix those two items, otherwise you will need to replace the whole cluster, same thing happened to me. Good luck

Dec 31, 2009 | 1998 Nissan Frontier

3 Answers

Speedometer, gas gauge, odometer, rpm gauge not working


My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Jul 29, 2009 | 1998 Nissan Frontier

1 Answer

1992 plymouth voyager and my gas gauge doesn't work


I have a problem with my gas, speed, temperature gauges,,,,,,,don`t work,,,,,,,what I can do

Aug 17, 2008 | 1992 Plymouth Voyager

Not finding what you are looking for?
1997 Pontiac Grand Am Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...