Question about 1990 Toyota Camry

1 Answer

It suddenly started putting down the road very bad and the air filter looks clean...when I push the gas the acceleration would stall...so I changed the spark plugs and it drove better...sometimes at take off it messes up and sometimes at take off it does not mess up. Then I changed the spark plug wires, rotor, and distributor cap and now it will not start at all...first it clicked a little when trying to start it and now it makes no sound but the battery charge seems to go up and down when trying to start...nothing should be wrong with the battery.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 222 Answers

Sounds like multiple things going on. The 1st is maybe something sticking with the throttle and why intermittent. Clean carb/throttle body. Make sure you installed everything correctly, sometimes the problem can be compounded with fixing attempts. If it was clicking and not cranking and now not clicking possibly the neutral safety switch is bad but it should still click which is the starter relay. Maybe wore it out trying to start it. It's not uncommon for other things to fail as a result of a failure. If it kept clicking I'd say definitely the NSS. Check your battery connection and get a terminal brush cleaning tool. I assume you mean by battery charge seems to go up and down you are using a multimeter. If it has a dead cell you would have this problem but maybe the connection to it is bad.

Posted on Sep 03, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What causes engine to accelerate without gas?


Possibilities:
  1. Leak in intake manifold or deteriorated throttle body gasket;
  2. Loose or missing throttle body spring;
  3. Defective idle air bypass valve;
  4. Bad throttle position sensor;
  5. Bad EGR valve or EGR position sensor;
  6. Evil aliens.
If there is, or has recently been, a CHECK ENGINE light showing, have the stored codes read out. They may reveal the culprit or, at least, indicate where to begin looking.

Aug 09, 2014 | 1992 Buick Park Avenue

1 Answer

1992 olds cutlass supreme wont accelerate when pushing the gas pedal


Check oil first, Low oil sensor will shut down if more than a quart low. Change fuel filter, could be fuel starvation, change the air filter. stopped up air filter will put MAF sensor out of range. PERFORM OBDII SCAN SOON.

May 19, 2017 | 1992 Oldsmobile Cutlass Supreme

1 Answer

I have a 1999 ford taurus, I am getting ready to hand this down to my youngest daughter but want to make sure its in working order, just recently I can start it up and it wants to stall immediately, if I...


You need to have the Idle air controller cleaned or replaced, and the throttle position sensor checked or replaced-and while you are at it, have the throttle body cleaned. Since she is going to be driving it, you should consider doing a tuneup (plugs, air filter, fuel filter, plug wires or have COP's checked for oil in the bottom of the plug holes)-an oil change, and checking the brake linings, antifreeze and cooling system maintenance.

Jul 05, 2011 | 1999 Ford Taurus

2 Answers

My 1994 buick w/3800 engine suddenly started "stumbling" and not running above an idle. when it does run for a little while, when you try to accelerate it "bogs" and if you try to push the accelerator it...


I would put a new fuel filter on and try that. If that didn't work, sparkplugs and wires, and a distributor cap and rotor. Also make sure your air filter is clean.

May 08, 2010 | 1994 Buick LeSabre

3 Answers

My car doesnt accelerate like its supposed to do.It seems to me like it boags down when i push the gas but when i let off the gas a little it will accelerate slowly.It has no power, once you get to going...


try to have your intake manifold and air filter cleaned. Also, try to replace the fuel filter. these are usually the culprits for the problem that you are experiencing.

May 14, 2009 | 1995 Honda Accord

1 Answer

1992 jimmy blazer


You could have gotten bad gas in your tank. Did you try dry gas at all? Also, bad gas can leave alot of sediment at the bottom of your tank, waiting for the right movement to get moving into your system. A new filter would only get quickly clogged again. I had this happen- got gas from a station after a flood- fuel tank had to be dropped and cleaned out.

Feb 26, 2009 | 1995 Jeep Cherokee 2 Door

2 Answers

85 740 GLE Non-turbo stalls when put in gear or push on accelerator


Its really sounds like the throttle switch, chack him.

Jun 17, 2008 | 1985 Volvo 740

Not finding what you are looking for?
1990 Toyota Camry Logo

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...