Question about Chevrolet Blazer

1 Answer

Passenger headlight went out,bulb was blown. I replaced it,lows and highs would not work. Checked fuses, they were good. Changed headlight relay. Still no high or low beams. All other lights work. What could it be?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 11,800 Answers

Bad wiring. First check that the power reaches the headlight  - use a voltmeter connected directly to the hot wires from the bulbs plugs and to the body of the car. If it doesn't then the wire is broken somewhere between the bulb and the relay - you will have to check it completely. If the power comes the check the continuity of the ground wires with an ohmmeter connected to the ground wires from the plugs and the body of the car.

Posted on Sep 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

HEADLIGHTS DO NOT WORK, BUT HIGH BEAMS DO AND SO DO TURN SIGNALS AND SIDE MARKERS


The HID requires a ballast, did you do any rewiring? Did you check the fuses? Unplug the relay either hi or low, use jumper wire between terminals 30 and 87, the lamps should work, I'm talking about your regular lamps. If they work with the jumper, then check control side of relay.

malibu headlamps-n3gdy1s0yelmttnhr2yepr4t-2-0.jpg

Mar 06, 2017 | 2009 Chevrolet Malibu

1 Answer

Right front headlight not working on low beam


Have you checked the relays and fuses,high and low beam run on different relays and fuses.

May 07, 2012 | 1995 Ford Explorer

1 Answer

How to change the low beam bulb on driver and passenger sides


the low beam bulb is one with the high beam ,so you need to replace the headlight bulbs, its hard to believe they both went at the same time,i would buy one and replace it if lights still don't work than you might have other issues like maybe a blown fuse.

Jan 27, 2010 | 2005 Nissan Altima

4 Answers

My headlights on my 2000 monte carlo does not work


Day time running lights run low voltage to the high beam bulbs so it sounds to me like you need two new bulbs or you need to check the fuses and see if any need replaceing.

Dec 07, 2009 | 2005 Chevrolet Monte Carlo

1 Answer

Both low beam lights went out. high beams work. changed bulbs,checked fuses and relays


if all these other components checked out ok you need to replace the combonation switch/headlight switch

Oct 22, 2009 | 2003 Honda Pilot

1 Answer

2006 Honda CRV Passenger both Low & High beams out (bulbs good)


Well I suspect that you may have developed a problem in what's called the Multiplex unit. It's an integral part of the fuse box in Honda CR-V's. It's possible that the cargo trailer caused the problem by causing too much current to be drawn thru the system, I have a similar problem with my 2002 Honda CR-V and have been told I need to replace the multiplex unit and they are quite expensive. You may have to bite the bullet and have it checked by your nearest Honda Dealer.

Aug 16, 2009 | 2006 Honda CR-V

2 Answers

1994 Mercedes c280 high beams not working...


At first 1994 C280 high beams began to not connect regularly when stick pushed forward, then not at all. Drove high beams by pulling and holding stick back towards steering wheel until that stopped working, too. Shop said the turn signal switch was at fault-- had seen it many times before with W202; about $160 to replace. Haven't done it yet, but should be an easy fix?

May 27, 2009 | 1994 Mercedes-Benz C-Class

1 Answer

1994 Mercedes c280 high beams not working...


headlight relay is under the screwed down portion of the fusebox.

Oct 13, 2008 | 1994 Mercedes-Benz C-Class

1 Answer

High beams not working...


More likely to be the high beam relay if it is affecting both headlights.

Oct 13, 2008 | 1994 Mercedes-Benz C-Class

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...