Question about Kia Sorento

1 Answer

My car was operating as normal when I went to work that day. When I got off work, 4 hours later and crunk the car to back up, the car would not move. Tried to go forward, the car would not move. I finally pushed and pushed on the gas and the car backed up slowly and then moved forward slowly. After 40 mph, the car ran fine but at each stop light, I struggled to get the car to move. I had a sensor replaced in it last week and it ran fine for a few days then I went to drive it one morning and it went in reverse but would not go forward. Now it goes in reverse but will not go forward. When you put it in neutral, it won't move, even when someone is pushing it. This is a 2008 Kia Sorento with 60,000 miles on it

Posted by on

  • Barbara Daniels
    Barbara Daniels Sep 03, 2010

    So, why did the car start working when they changed the sensor? TCM? What is that?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kia Master
  • 11,800 Answers

The clutches that control the gears are no longer correctly commanded by the TCM so either it is defective or you have wire harness problems (and the sensor was just another problem caused by it - changed for nothing). You will have to take the car and this time make sure the guys don't just read the codes and replace the indicated faulty part, they actually search why that part failed.

Posted on Sep 03, 2010

  • Azrael SRL Sep 03, 2010

    Because the moved the wiring around and the broken wires (or contacts) made again contact. Now the wires have shifted again and the contact was lost on even more wires. Make sure they do a thorough checkup on it and all its connectors.



    TCM = Transmission Control Module = the brain of the transmission, the one that controls what gears should be engaged, and how. If the TCM is faulty then nothing will work as it should.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I'm having same problem on my 2000 model rodeo 4wd 3.2L V6. Other day check engine light came on. I checked engine bay nothing abnormal, or power loss. Next day light was gone. 2 days later drivin


Where I live there is a Schuck's auto parts...and they have a hand held diagnostic tester that plugs right in to your harness. This will tell you whats is wrong.It only takes about 2 min and they don't charge you.On my car it was the mass air flow censor.If you can't find a Auto parts store that does this...take it to a shop soon. Good Luck

Mar 27, 2013 | 2000 Isuzu Rodeo

1 Answer

Car wont crank!


How old is the battery?

Jun 30, 2017 | 1998 Kia Sephia

1 Answer

Truck has been sitting up for a long time .Brought back to my home seviced crunk up ran good.Then a few days later would not crank. Fires ,has fuel pressure,timing good,verified fuel pressure at cold start...


Sounds like the injectors arn't putting fuel into the combustion chamber. The only thing could be is the ecu (car's computer) your going to have to try and pick up another computer for it.

Sorry for you luck, but good luck in the find

Aug 11, 2009 | 1986 Toyota Pickup 4WD

1 Answer

My Lights keep flickering when I don't run it for a few days.


could be a bad ground cable,or a bad connection wher the ground cable goes to the car not the battery. hope this helps.

Feb 22, 2009 | 1998 Chevrolet S-10 Pickup

2 Answers

Holden Rodeo 2001, check engine light keeps coming on!?


I'm having same problem on my 2000 model rodeo 4wd 3.2L V6. Other day check engine light came on. I checked engine bay nothing abnormal, or power loss. Next day light was gone. 2 days later driving, a sudden loss of power and light came up. After idling for a couple of minutes, drove off with light still on but all power back. 1 hour later of faultless driving loss of power for a minute or so. Engine temp normal. Had break for 1/2 hour and set off for last hour of journey without fault except check engine light still on. Following dayon startup light went out???
Seeking help from experts.

Feb 09, 2009 | 2000 Isuzu Rodeo

1 Answer

1995 Chrysler Concorde


the alarm is activating when he locks it and for some reason the key or fob isnt deactivating it..check the disarm switches in the door

Aug 11, 2008 | 1995 Chrysler Concorde

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...