Question about 2005 Ford Mustang

1 Answer

I left my 2005 mustang perfectly fine on the parking lot at my work, it was only with low fuel, whe I come back and start my car, something weard happen, ligthts on gauges turn on, the light of parking breakes, engine, also the computer mark low on oil, break fluid, I went to the next gas station put gas on it, and tha gaudget is not working,the oil gauget is not working neither. Im freak out.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 22,095 Answers

Dealer only computer glitch ,2005?? chances are its using encrypted software

Posted on Sep 03, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Heater is working perfectly when ticking over and when u put a rev on engin it stops working Isuzu trooper 2005


Starts and idles ok, and reaches , normal engine temp.
ok, but stalls in both Reverse and Drive.
and restarts easy, after the stall. right?
no engine size stated.
ok, this can be lots of things but now my useless guess.
low fuel pressure,
is gas fresh?
was car parked for year, then started, or longer.?
when was the last time car was a good daily driver?
can you prevent the stall, with a fast right foot action.????????
the last question is very revealing....
last question, when was the last full tuneup done, 10 years ago?

Nov 30, 2016 | Isuzu Trooper Cars & Trucks

1 Answer

I have a 2005 Sorento 3.5 changed out valve cover gaskets and tuned up since I've done this all it does is crank over tries to start but will not start I tore back down to make sure I did not have the plug...


recheck the timing marks if the belt has been changed, the fuel gauge is connected in to the fuel line with a T piece connector, check the pressure and flow, if the flow is low replace the fuel filter , if the pressure is low check the relief value, if ok replace the pump.

Feb 25, 2015 | 2005 Kia Sorento

1 Answer

Mustang water leaking on passenger side floor.


I have 2005 mustang and had the same problem 4 yrs after I bought my .Mustang when it was still under the warranty I took it to the dealer where I purchased vehicle.They charged me $150.00 to change the cabin air filter they said the old one was blocked with leaves and suggested not to park vehicle under trees which is kind of hard to do when I live on a street with a lot of trees. Everything was fine until 2 years later it started leaking in passenger side again.Pulled cabin air filter saw no leaves.Of course now warranty ran out .I went on a mustang web forum to find there were other people with same problem and not just a mustang problem there were other makes and models having same problems .One person fixed the problem. Here is the fix. Pop your hood look under where the cowl grill sits on the right and left side there is a rubber drain on each side( hard to see)so feel with your fingers check to see if they are blocked with dirt or leaves if so clean them so water can flow through them when it rains .That is what was causing water to come in on my passenger side right underneath the glove box in my mustang now every few months I check to see if they are blocked I have not had anymore problems with water coming in on passenger side . Sad thing is when i purchased my mustang i wish the dealer would have told me not to park my car under trees so i wouldn\'t have a water I would have thought twice about buying a car that you can\'t park under trees because I live in an area where there is a whole lot of trees.Thanks a lot Ford for designing such a crappy car !!!! Good luck I hope this fixes your water problem.

Mar 04, 2014 | 2007 Ford Mustang Coupe

1 Answer

Battery on a 2005 Mustang went dead. Had a Jump to get the car started. Drove & speedometer & odometer worked fine. However, I had Triple AAA install a new battery & now they don't work. ...


Did AAA clean the battery cable connections when they installed your battery? Did you check the fuse for the insrument panel?

It could be just bad timing or a coincidense but I am more likely to think things are connected. If your gauges worked after jump starting your car, but not after AAA changed the battery, something changed or was left disconnected.

Jul 03, 2011 | 2005 Ford Mustang

1 Answer

2006 ford mustang wont start after driving the car for a few hours cut car off and parked for about a hour or so when returned to get back in car to leave the car would not start the lights inside the car...


Sounds like an electrical mess up. Im not too familiar with ford and newer vehicles. It could be the starter getting jambed. The make a grinding/clicking noise..Something like a selenoid? Just ideas..

Oct 05, 2009 | 2006 Ford Mustang

1 Answer

Replaced #2 injector, truck ran fine. Parked and


Had Mustang that lost power and had black smoke coming out of the tailpipes. The O2 sensor had an intermittnet fault which caused a lot of problems as nobody could find it. Purchased a cheap code reader and just happened to check it when the O2 sensor was causing a code. Not sure if you're having the same problem but, something to think about. Good luck.

May 03, 2009 | 2005 Ford F 350 Super Duty

1 Answer

2005 Mustang Speedometer Issue


This is pretty common on the 2005 Mustangs, it's caused by failing stepper motors in the instrument cluster, they control the movement of the gauges. There's a guide on how to fix them here - 2005 Mustang speedometer problem

Jan 17, 2009 | 2005 Ford Mustang

Not finding what you are looking for?
2005 Ford Mustang Logo

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...