Question about 2008 Chevrolet Impala

1 Answer

The last couple of week the gages somtime will not work somtime its all of them sometimes its only the speedometor. Now it will not start is a 2008 chevy impala ss

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 222 Answers

Sounds like a power loss issue than a gauge problem if all are cutting out and especially if you can't start. This could be numerous things but off the top of my head I'd say you either have a short to the computer, computer dying or bad ASD relay but might be called something else on that car, like MFI relay that shuts everything down. Only other things I would relate to this and usually causes stalling is the crank and cam shaft sensors. They don't give a signal car dies and/or car wont start. Does your check engine light come on when you turn the key to ON (not starting)? If it doesn't come on for the 3 seconds then you computer has no power, shorted out or dead.

Posted on Sep 02, 2010

  • ryaanmichael Feb 20, 2011

    Sounds like a bad BCM (body control module). This is a common problem and needs to be replaced.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Speedometor quits working


Sounds like your VSS. Vehicle speed sensor. I don't have that year vehicle, but my older Prelude did the same thing.

Mar 31, 2014 | 1996 Honda Accord

1 Answer

Ignigtion sometimes wont start


sounds like a problem with the ignition control switch. get it check out by a mechanic .

Nov 11, 2013 | 2003 Ford Taurus

1 Answer

I have a 2008 Malibu LS, 4 cylinder.My engine light has been on and at the same time my temperature gage does not work and the fan keeps running, then the engine light went out for a couple of days, the...


Your best bet would be to have the vehicle checked for DTC'S - diagnostic trouble codes ! May not be a sensor problem , could be a wiring issue . Most auto part stores will do this for free , and if it is a sensor they can show you where it lives an how to change it !

May 16, 2017 | 2008 Chevrolet Malibu

1 Answer

The turn signals speedometor and rpm gage stoped working i have replaced the cluster and the turn signal switch and still not working


What you need to replace is the speed sensor. That has gone bad.
Please don't forget to rate me.. this will help me

Mar 03, 2011 | 2001 Oldsmobile Aurora

1 Answer

Went to try and install a stereo, now all the gages on my dash won't work, such as speedometor, fuel, temperture and tac gages. What possibly can be wrong?


Have you checked all the fuses??
or it could be that you have pulled on the wiring loom a little to much and unplugged something double check all plugs and fuses see if that helps
Steve

Mar 02, 2011 | Oldsmobile Intrigue Cars & Trucks

2 Answers

My 1998 plymouth neon expresso - dash board cluster gauges: the speedometor, gas gauge, and rpm gauge sometimes work and other times do not. If you turn the ignition on to accessories but not on to...


i dont have a solution for this problem. my car does the same thing. infact the only reason i bought this pos was the low mileage. little did i know it was bs. let me know if you find a solution to this.

Sep 05, 2010 | 1998 Plymouth Neon

1 Answer

94 ford probe,speedometor,oil gage,odometer not working


You need to pull the dash and check the guages look for any burning or melting. You may just need to replace the pannel in your dash, pretty easy work. If not start checking the wires and cables that come out of your faulty guages.

tepfy

Feb 22, 2009 | 1994 Ford Probe

Not finding what you are looking for?
2008 Chevrolet Impala Logo

283 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...