Question about Chevrolet Tahoe

2 Answers

The oil pressure guage drops to near zero when ideling and when running at high speed does not go above 22 lbs. The motor does not knock when the guage drops and the warning light comes on. I have had issues where the low coolant light comes on although the fluid level is normal. Is this a faulty oil sending unit, an electronic glitch in the system or bad oil pump.

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 2,050 Answers

You should hook up an external gauge, to see what the oil pressure actually is. Otherwise you are assuming the gauge, and sending unit are correct. And then go from there.

Posted on Sep 02, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 222 Answers

Take it to Advance or Autozone and have them scan the ECM if 95 or newer.

Posted on Sep 02, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

High oil pressure in a toyota 100 series 1999 model 1HZ engine


Have you recently purchased the vehicle. A rebuilt agent with, racing seals & a racing oil pump, will run around 75 - 85 lbs pressure. If it just started happening on a vehicle you have had for a while, a defective guage. Or look for a plugged oil chamber, (near impossible without dis-assembly). Bad oil sending unit (part that sends the signal to the guage.

Sep 13, 2011 | Toyota Land Cruiser Cars & Trucks

1 Answer

High oil pressure on guage. It goes to zero with engine off. Where is the sensor?


High oil pressure is ok, lack of pressure if the engine is running, is very bad. Pressure is supposed to drop to zero as soon as you turn off the engine, nothing abnormal about that.

Jun 21, 2010 | 2000 Jeep Grand Cherokee

2 Answers

Should the oil pressure gauge fluctuate with speed


The oil pressure guage will fluctuate with engine RPM. At idle it should be approximately 20 lbs./sq.in, at high revs about 50-60 lbs./sq.in. Hope this helps any concerns you may have. Good luck!

Jun 05, 2010 | 2004 Chevrolet Express

1 Answer

Oil guage drops then goes to high range


sounds like your sending unit needs to be replaced cheap fix and if your oil pump losses all its pressure you will begin to hear knocking coming from your motor from the top under the heads.

May 27, 2010 | 1991 Buick Park Avenue

1 Answer

Difference between oil sending unit and the oil pressure switch


Same part...make sure you get one for gauge, not idiot light though. If the engine has any knocking or ticking when pressure drops do not drive it and have a mechanical gauge installed to check actual pressure. Parts often have different names for same item...your driveshaft is actually called a propeller shaft!!!

Sep 18, 2009 | 2004 Jeep Grand Cherokee

1 Answer

Oil pressure drops to zero after warmed up or below 2700 RPM


Check the oil pressure with a test guage, if the finding are the same, the look at your oil filter, pump, pickup, or pressure relief valve.....

Jul 18, 2009 | 2002 Isuzu Rodeo

4 Answers

Has no oil pressure when ideling, has 20 lbs at highway speed.


you have either a weak oil pump or a faulty sensor check the leads on the oil sending unit and make sure they are not frayed. if they are not take it off and have it bench tested if it passes replace oil pump...please rate this

Sep 03, 2008 | 1988 Ford Bronco II

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

233 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...