Question about 1990 Chevrolet Cavalier

Open Question

Can i drive my car without the MAP sensor plugged in?it cuts out with it plugged in and runs fine with it unplugged?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

keemo68
  • 1263 Answers

SOURCE: map sensor

that is not a map sensor(mass air flow) it is a barometric switch also know as a mps(manifold pressure sensor) if your vehicle idles fine but when you try to accelarate. i have a question? is it a throttle body or a carburator type fuel system?

Posted on Sep 01, 2008

  • 398 Answers

SOURCE: Changed Mass Air Flow sensor, CEL still displays problem

it almost sounds like a fouled fuel injector. this is a tricky problem because it involve so many different operations. the maf is used to deliver fuel and the o2 sensor tells how much. there are 2 o2 sensors one before cat 1 after. mabey check these out visually. the computer should pick these sensors up if there bad. is this a supercharged engine? ill try to come up with some other ideas for you soon.

Posted on Mar 12, 2009

  • 202 Answers

SOURCE: 1991 firebird will not idle cold and bogs down while driving

This sounds like a fuel issue to me. If I am not mistaken, this engine has two injectors running on a separate fuses. Remove the air cleaner assembly, and make sure both are firing while engine is running. If so, then check the fuel pressure. If you have a fuel pressure gauge, connect it to the fuel rail, and start it up. Remove the vacuum line from the fuel pressure regulator to see where it is set. You should have at least 36lbs of fuel pressure. If the pressure is too low, check the fuel filter. It may be clogged, or you might have a weak fuel pump.

Also you changed the throttle position sensor, you will need to make sure it is set properly.

hope this helps,
Chris

Posted on Mar 24, 2009

  • 206 Answers

SOURCE: VW Polo Map sensor fault code idling pooly

Check for air leaks in the admission system...

Posted on Apr 02, 2009

  • 2 Answers

SOURCE: 96 cavalier 2.2 in drive the car pokes along it

Check the catalitic converter for being plugged up.

Posted on Apr 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Fuel mixture is wrong..not running correctly. however if i unplug the MAP sensor it runs perfectly fine. I know for a fact that any of 3 things could be wrong how do i determine which sensor is bad?


I fit runs good, gets decent gas mileage, and you don't have inspections. Unplug the MAP. It could be just the MAP sensor, could be the ECU. You might get a MAP sensor, good luck on getting an ECU.

Jun 28, 2016 | 1993 Toyota Tercel

1 Answer

2001 Chevy blazer 2 wheel drive 4.3 V6 transmission shifts fine then it stops won't come out of first . I unplug battery for a bit then plug it back in and it runs fine for a bit ?


The first step would be to attach a dealer scan tool, and see what is being sent/commanded. If there is a full command set from the outside, a pressure test would be the next, to see if pressure is rising in the proper areas. No computer command from the outside, would mean checking the related input sensors, such as the lever position switch, throttle position sensor, MAP sensor, air flow meter and the power control module. This requires a digital lab scope and a data recorder.

Apr 19, 2016 | Cars & Trucks

2 Answers

Hard starting, misfire & cut out when revved with MAP sensor connected


Hi Bernie, Im AL the owner of Big As Auto Repair

Bernie, this is hard to say without diagnosis, but I can tell you that 99% of the time when you unplug the MAP Sensor and it runs better, then its usually the MAP Sensor. If it should turn out that a new MAP doesn't fix it, then check for broken or frayed wires and check the connector for damage. Hope this helps and please visit my auto-repair website and check out my satisfied customer testimonials.

Jul 03, 2015 | Cars & Trucks

1 Answer

Holden/Chev Cruze 2003 clonking out


run fault codes to check that you got the right sensor replaced

Nov 06, 2013 | Cars & Trucks

1 Answer

My 91 Chevy s-10 2 wheel drive p/u w/2.5 four cylinder wont idle and runs rough when i rev the motor which the only way i can keep it running is to feather the throttle. If i unplug the vacuum to the


the problem if from the map sensor.. when you change it it will run rough and keep cutting off,, keep stating it back and reeving over and over as soon as it cuts off again keep repeating until the CPU gets calibrated with the new sensor and it starts idling smoothly..

Dec 30, 2012 | 1991 Chevrolet S-10

1 Answer

Idle and run problem with 1995 Chevy C2500 2 Wheel Drive, 350 Truck


check fuel pressure and injectr/s condition
indicates that you have faulty / leaking injectors /seal

May 13, 2017 | 1995 Chevrolet C2500

1 Answer

I have a 94 Geo Prizm LSI 1.8L. I have a real odd hesitation, sputter. Before the car shut down, it drove fine, except that it you maintained a steady speed the car would sputter - but not when...


Try exchanging the MAP sensor from the other "good running" car. What I think you are experiencing is a flat MAP which fails to read more than the minimum. A MAP sensor out on these cars will make it run absolutely terrible and die as you have indicated.

By unplugging the TPS sensor you are effectively putting the car in "limp" mode. In this mode it ignores a potentially bad TPS, O2, and MAP sensors and or circuits.

Jan 19, 2010 | 1994 Geo Prizm

1 Answer

Truck just cuts off while driving


It could very well be the MAP sensor. I believe it is on the fire wall of the '99s . unplug it and see if thet doesn't help. If it does, then replace the sensor. (MAP sensor will have a vacuume hose and a small plug in attached).

The mass airflow meter could be the culprit as well.

Are you getting any codes?

Nov 16, 2008 | 1999 Jeep Grand Cherokee

1 Answer

Map sensor


that is not a map sensor(mass air flow) it is a barometric switch also know as a mps(manifold pressure sensor) if your vehicle idles fine but when you try to accelarate. i have a question? is it a throttle body or a carburator type fuel system?

Aug 24, 2008 | 1990 Ford F150

Not finding what you are looking for?
1990 Chevrolet Cavalier Logo

Related Topics:

210 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...