Question about 1995 Buick Riviera

1 Answer

Electric fans arent working - 1995 Buick Riviera

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Contributor
  • 157 Answers

Check #1 Fuses, #2 for Electric fan relay and #3 temp. sending unit

Posted on Sep 02, 2010

Testimonial: "thank you so much, im currently going through divorce, she took the new car,and all i have is my beloved 95 riviera, i need to fix her befor winter."

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Car gets hot pretty quick and will overheat, noticed fans arent coming on when car is hot or if I turn a/c on. Have caught them running recently but didnt catch it again.


it could be the cooling fan relays or possibly the cooling fans. to check the fans disconnect the plug at the fans and run jumper wires to them both power and ground. if they don`t work then the fans are bad. check voltage and grounds at the plugs when they should be running, if they are good then the wiring is good. it could also be the coolant sensor for the fans that send the signal from the sensor to the computer so it knows when to turn on the fans. the fan that runs with the A/C when turned on could be the A/C relay.

Sep 10, 2015 | 2003 Dodge Intrepid

1 Answer

My 1999 Chevy Malibu is losing the coolant though the overflow hose by the resevior I've had my head gaskets replaced there is no overheating no water oil mix, but my radiator fans arent working I


Sounds like you need to disconnect the Radiators' electric fans and have them tested. You absolutely must have them working, or your car will overheat. Check to see if the Temperature guage is working.

You need to go to a good autoparts store and have them test the fans and charge and test your battery. You may need some sensors to activate the Radiator fans, but you could be running the battery down with shorted cooling fans.

There are also Relays which work with the Radiator fans. The overflow will stabilize once the water gets into where it belongs. Make sure your Thermostat is not clogged with the sealer.

Jan 15, 2012 | 1998 Chevrolet Malibu

1 Answer

My electric cooling fans arent working, or appear not to be working. my radiator was boiling a few days ago, does this sound like a problem?


yes it does, check the relays to the fans, and also the fuses, they should be in the under the hood fuse box, once you determine that the fans work ( turn on the ac and see if it starts it should ) you can move that relay to the normal fan relay spot, ( if you have 2 fans ) if your car still over heats after knowing the fans are working,, check the thermostat

Aug 26, 2011 | 1997 Chevrolet Malibu

1 Answer

I have 2000 monte carlo ss v6 , it has multiple problems, all electrical :the turn signals buzz and wont flash as does the emergency flashers. the a c works periodically , the gas guage goes up and down...


Good grief! Short of replacing the wiring harness one thing comes to mind. Make sure the ground wire from the battery to the body is clean and well connected. What you claim really sounds like a major grounding problem.

Mar 16, 2011 | Chevrolet Monte Carlo Cars & Trucks

1 Answer

2005 neon electric fans not working. 30 amp fuse looks good. it has 2 relays. i switched them but nothing happened.


sounds like the coolant temperature sensor if it is bad it will not tell the fan to come on. that also provided the fans themselves arent bad, which can be tested by connecting a hot power source to one of the fan terminals and grounding the opposite

Aug 03, 2010 | 2005 Dodge Neon

1 Answer

Need electrical schematics for cooling system for 88 firebird 5.0 tpi


The only electric on cooling system is the fans.if those arent working then check fuse panel under the hood

Apr 28, 2010 | 1988 Pontiac Firebird

1 Answer

1988 oldmobile cutlass cierra, Does not get spark. Ignition module is good, and coil pacs are good. At first the injectors were not pulsing, now they are working and the plugs arent firing. The electric...


the main fuse bao under the hood on the drivers inner finder well is crossed check for corrosion and make sure all terminals are free of each other

Oct 22, 2009 | 1988 Oldsmobile Delta 88

2 Answers

Z28 95 running hot


Is the fan running or do you have an electric fan? If fan isnt running or never comes on no matter what you do it will never run much cooler. If fan is good then you could flush the radiator a couple of times and that will help but if fan isnt working it wont last long

Aug 25, 2009 | 1995 Chevrolet Camaro

2 Answers

Fans arent working on. checked fuse


Check cooling fan relay beside master cylinder on firewall.

Jun 11, 2009 | 1994 Pontiac Firebird

Not finding what you are looking for?
1995 Buick Riviera Logo

Related Topics:

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...