Question about 1999 Nissan Altima

1 Answer

My belt is sqealing and running hot with anti freeze in it

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Replace the belt or re-tension it.
if it just started the water pump may be seized.

Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question.

Posted on Sep 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Keep running hot


Need more information as in how long after starting the engine does it indicating hot, can you see steam venting from the radiator or hear water boiling, are all visible v-belts in place, is the engine running smoothly or not, when was it last serviced - timing can be out, is there anti freeze in the radiator water and if so in the correct ratio. More info please.

Aug 05, 2015 | 2000 Ford Crown Victoria

1 Answer

Can smell my radiator but not running hot also checked has plenty of fluid. engine light is on .


WATER PUMP HAS A BUILT IN "WEEP HOLE" AT BOTTOM OF PUMP. YOU NORMALLY SEE SMALL SPOTS OF ANTI-FREEZE, BUT IF IT IS DRIVEN OFF THE TIMING BELT IT IS BEHIND PLASTIC COVERS. LOOK AT LEFT(DRIVERS) SIDE...WHICH IS FRONT OF ENGINE FOR DRIPPING FROM LOWER TIMING BELT COVER.

Jul 21, 2013 | 1999 Honda CR-V

1 Answer

My caddie keeps running hot and I want to know is it because I am using the wrong anti-freeze. Should I be using the orange anti-freeze instead of the green anti-freeze?


Never heard of the wrong anti-freeze. You're best bet is to check the temp sensor and replace it. It is what tells the system fans to "cool down"

Aug 28, 2012 | Cars & Trucks

1 Answer

My Century is running hot. The serpentine belt is working fine and there is anti-freeze in the reservoir. What else should I check?


Are your electric cooling fans cycling on and off? You could have a stuck thermostat, plugged up radiator.

May 28, 2010 | 1999 Buick Century

2 Answers

My 1997 geo metro sqeals when started


this could be the serpentine belt at the front of the engine it could be warn and needs replacing, but this could also be the signe of a warn bearing ie idler bearing, waterpump bearing, alternator bearing, power stearing pump bearing, best to get it checked, as a belt is only a few bucks, where as the others could be allot more, should i say will be...hope this helps

Feb 12, 2010 | 1997 Geo Metro

1 Answer

Have a belt sqealing and antifreeze in the engine


Hi:
There is a good chance your waterpump bearings failed, and your belt was getting dragged over the drive pulley. Since your engine got hot, the impeller that moves coolant could have broken, so you should investigate that. The coolant could have leaked out the weap hole on the front of the water pump.

Nov 18, 2009 | 1997 Mercedes-Benz C-Class

1 Answer

Loud sqealing tried changing the belt but it still


above your water pump there is a small hose that runs into it there check it make sure it is not leaking that will make it squeal and its cheap doesnt take much water for the belt to slip so?

Sep 27, 2009 | 1997 Ford F150 Regular Cab

2 Answers

My 1995 ford taurus is running hot


It sounds like the cooling fan is not working. Turn on the a/c and see if it comes on. Dont forget to rate.

Mar 08, 2009 | 1995 Ford Taurus

1 Answer

Antifreeze leaking and noisy belt


when you replace anti freeze you should check and tighten all clips etc as the anti freeze is thinner

Nov 23, 2008 | 1992 Oldsmobile Ninety Eight Regency

Not finding what you are looking for?
1999 Nissan Altima Logo

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

723 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...