Question about Chrysler Town & Country

1 Answer

2003 Chrysler Town and Country. Rear window washer is not pumping fluid out. Is there a fuse for this or is the pump bad. Front washer pump works fine. Front and back share same resevoir.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 864 Answers

In my experience i would say its the pump. But if you look in your owners manual there will be a fuse diagram. From there you can check the fuse. Also if you know where the fuse boxes are located you can look on the backside of the lid that closes the fuse box there is a diagram. That will help you locate the fuse. If you need further assistance please let me know. Thanks, Midwest-tek

Posted on Aug 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 town & country rear washer does not work


replace the washer pump theres one for front and one for rear

Feb 18, 2014 | 2002 Chrysler Town & Country

1 Answer

Chrysler 2001 town and country power steering problem


The power steering pump is bad! God-Bless! or the rack and pinion leaks, check the pump first. the pump whines if low on fluid or bad.

Nov 04, 2017 | 2001 Chrysler Town & Country

1 Answer

Front windshield washer pump not working, replaced pump but still does not work, when button is pushed in the wipers come on but pump does not hmmm. like usual


get a test light and disconnect the washer pump motor and connect your test light to the motor harness and have someone push the spray button. If the light comes on, then you bought a faulty motor. if it does not come on then there is a blown fuse or a break in the circuit .

Jun 28, 2011 | 2003 Chrysler Town & Country

1 Answer

Both front & real window washers aren't working...fluid doesn't pump but the fluid well is full


What fluid do you have in the tanks? Is it the summer formula which may freeze below 32 deg. F? Or, I would check fuses for the windshield wiper fluid pumps.

Also, check with a test light to see if the test light goes on when the backprobed connection to the windshield wiper fluid pump should be energized with the button or switch inside the vehicle.

If the electric pumps which should wrrrr when working are bad, replace at or near the tanks.

Jan 14, 2011 | 2003 Chrysler Town & Country

1 Answer

Front windshield washer motor is not working, but the rear one is. what could be the problem? have checked the fuse and that is ok. what can i do to fix the problem?


use a cheap probe type 12V tester and check the output at the plug on the washer pump motor when the wash button is pushed. If you have power to the plug then the washer pump motor is bad or poor electrical connection. If no power to the plug then the multifunction switch may be bad. either way about $50 in parts from rockauto.com

Sep 02, 2010 | 2001 Chrysler Town & Country

3 Answers

Where do you add fluid for rear window washer


I believe that if you add it in the front, it makes it to the back. I have never had to add any to anywhere else and I use it all the time.

Jun 20, 2010 | 2005 Chrysler Town & Country

1 Answer

Back window washer stopped working but the front still does. Do not see any leakage under the car indicating hose is disconnected or broken (used to happen on my Chevy Venture quite often). What could be...


Likely, the pump/motor for the rear window (which is located under the front washer bottle is not being turned on, or is stuck for whatever reason. Remove the exit hose from the pump and blow through it with LOW pressure air to see if fluid and air exit from the rear washer fitting. Both motors are controlled directly by the Body Control Module (another computer besides the PCM) and are not fused individually. Each motor receives 12 volt power to it when commanded to run. Hope this helps!

May 21, 2010 | 2005 Chrysler Town & Country

1 Answer

Front wiper fluid won't dispense back works fine


My Town & Country had the same problem. It was clogged. I had it cleaned by a mechanic and it works fine now.

Dec 15, 2008 | 2001 Chrysler Town & Country

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

737 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

79847 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

chargerhp
chargerhp

Level 3 Expert

814 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...