Question about 1992 Cadillac DeVille

1 Answer

Motor missing, replaced plugs&wires,cuts out after some distance, possibly after reaching normal operating temp! Jim's in Ranson replaced EGR valve,said this was problem, did not solve problem! I should have known better than to ask that shop, from now on, they are on Sh...list!!! Also replaced fuel filter, can this be fuel related? Possibly Fuel pump related? HELP!!!

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Remove air intake. Look inside throttle body. Do you see black carbon & tar. If so, clean or have cleaned. DO NOT USE CARBURATOR CLEANER--TOO STRONG REMOVE FILM COATING. Should smooth out.

Posted on Oct 28, 2010

Testimonial: "I am sorry I forgot to thank expert for helpful suggestion, definately solved problem!"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1995 pontiac bonneville 3.8L temp gauge maxed, engine norm temp


Possible bad sending unit or shorted sending unit wiring.

Jun 07, 2013 | 1995 Pontiac Bonneville

1 Answer

2004 mercury grand marque check engine light on code is p0108 says map sensor or vacum leak but does not have leaks.this car does not have map sensor what else needs to be replaced


PO 108 --- Baro/Map Sensor High Voltage Detected

Yes it does

It is integrated into one unit in the ESM EGR assembly
(possibly)

I have no experience with that,so if you find only an egr valve
& no other sensor with vacuum hoses & wires going to it,replace
the egr valve.

Getting the feeling you missed it

Work the web sites. Put in your motor & EMS Module for egr
& see what comes up

Sep 21, 2011 | 2004 Mercury Grand Marquis

1 Answer

Once car warms up it cuts out. fuel pump among other things have been replaced. problem still occurring. wondering if the egr valve or the wiring harness could be the issue.


car shuts off when tempurature gets to normal--- causes are low coolant, failing coolant temp. sensor, failed radiator fan, it takes 10 to15 minutes to reach operating range. hope this is what you need !!

Jul 17, 2011 | Volkswagen Jetta Cars & Trucks

2 Answers

1996 VW cabrio runs strong until the temp gauge reaches about halfway to normal, then misses and run intermittently rough below 2000 rpm. As the temp nears normal the condition worsens and smooth operating...


i wonder if you've got an EGR valve stuck open that is making it vent exhaust gases into the motor at all times rather than only in wider throttle as it should?

Sep 30, 2009 | 1994 Volkswagen Jetta

1 Answer

3.4L engine stall at stops


do u have a check engine light coming on? if not the plugs are not the problem a miss will trigger a check engine/service engine soon light, most likely you have a dirty automatic idle speed control motor.

May 11, 2009 | 1993 Oldsmobile Cutlass Supreme

1 Answer

Very bad idol and run condition.


sounds like a possible water temp issue... check your thermostat and/or water temp sensor. when you first start your engine the computer uses the water temp reading to do a 'cold start' scenario, more fuel. once you reach normal operating temp the fuel should be cut back. if the thermostat is not opening and closing properly this can cause strange readings from the water temp sensor (which is mounted near the thermostat)... unlikely the sensor is bad, but a possibility... more likely the thermostat.

Mar 23, 2009 | 1993 Ford F150 SuperCab

1 Answer

Honda Misses.


Pin point the dead hole and check that injector.

Dec 23, 2008 | 1995 Honda Accord

1 Answer

Buick century misfire


it could be thermosat...i would also check EGR valve the are common to stick out and cause misfires

Dec 17, 2008 | 1997 Buick Century

Not finding what you are looking for?
1992 Cadillac DeVille Logo

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6924 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...