Question about 1999 Plymouth Grand Voyager

1 Answer

Electric windows will not roll up and gauges not working i.e. speedometer, gas gauge, rpm and tempature. Could this be fuses?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 523 Answers

With regard to the windows not operating, yes it may be as easy as a fuse however there has been issues with the solder joints on the PIN connection to the gauge cluster. The issue being that over time thru vibration and such one of these solder joints will fail (happened on or 1999) you can repair this though. You will have to remove all of the trim from around the driver's side dash board, this will include the trim towards the center of the dash. Once these pieces are remove you'll need to remove the gauge panel (I believe (4) allen head screws) carefully bring the panel and release the wire clip from it. Looking at the back of the panel, where the plug was, carefully with plenty of light look for one of the pins to have a failed solder joint. It will be very faint however the failed joint will be a fine dark line around the pin. To correct use a small soldering iron and reheat this solder until it wants to flow, let it cool and reassemble.
I hope this may have helped,
Tom
PS: I have helped several persons with this issue, please review my profile; good luck with it (also often times with this issue the ABS light stays on)

Posted on Aug 30, 2010

Testimonial: "Thanks Tom that was very helpful! Im not sure if I should attempt to pull apart the panel. "

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok i have a 1999 camaro and the gas speedometer and rpm gauge go up and only the gas and speedometer go back down. all my other gauges are fine


Need a new cluster. There may be a recall not sure but you can have cluster fixed by replaceing the step up motor in cluster.

Oct 31, 2012 | 1999 Chevrolet Camaro

2 Answers

One by one my gauges(rpm,gas,speedometer,oil) stopped working. Is there a sensor that needs replaced? a fuse? dash? Help?


please keep me posted as well, ALL my gauges are doing the same. First the gas, filled it one day and it fell all the way and light turned on, then my themostat, freaked me out, thought i was overheating,...NO just the guage, NOW my spedometer is stuck on 120, and my RPM's are acting crazy. i have read tons with this same problem, WHY WONT the manufacturer DO SOMTHING??

Aug 25, 2010 | 2004 Isuzu Ascender

1 Answer

2003 eclipse and gauge fuse keeps blowing


you may have a broken wire in between the doors. there is a rubber boot the harness runs through u will have to take it off to inspect. hope this helps.

Apr 16, 2010 | 2004 Mitsubishi Eclipse

1 Answer

Fule gauge speedometer and rpm gauges stopped


Go to the fuse box and change the fuse for "Gauges". I think this might solve the problem.

Feb 23, 2010 | 2004 Chevrolet Monte Carlo

3 Answers

Speedometer, gas gauge, odometer, rpm gauge not working


My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Jul 29, 2009 | 1998 Nissan Frontier

2 Answers

No gauges on instrument panel


Apparently a (some) loose fuse(s). Unplugged, checked the fuse(s) and replugged. All is working fine.
Thank you -

Mar 06, 2009 | 2003 Mercury Mountaineer

Not finding what you are looking for?
1999 Plymouth Grand Voyager Logo

270 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...