Question about Ford E-350

1 Answer

The check engine light is on. I have a 1995 7.3 l powerstroke. It starts easily and runs, but when it rus it is rough. It happened suddenly. The van was running fine one day and the next day the light came on.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,272 Answers

If its running rough then this can be problem with fuel system.Get the fuel pressure checked.If the fuel pressure is low then the fuel pump and fuel filter needs to be replaced.The other possibilities which can cause this problem are sensors.The IAC valve and the MAF sensor.Also get the EGR valve/sensor checked.If this all valve and sensors checked perfectly ok and still the same problem then, There are some possibilities which you will have to check in this case:--
1) First of all check the power and voltage to the battery. With meter it will show exact 12 volt if the battery is charged. If the voltage is less get the battery charged at local auto repair shop. If the battery is internally drained and not getting charged then its time to replace the battery.
2) When you crank the car do you see spark coming at the spark plug? If no then its time to check the spark plugs and coil pack. If the spark plugs are not worn out and looks new then its time to check coil pack. The spark plug gets power to spark from coil pack.
3) The other thing to check in this case is the starter solenoid of the car. If the battery is charged and you start the car then it gives power to the starter to start the car. But if starter is faulty or not connected properly then car will not start.
4) The other thing to check in this case is fuel in the car. If there is fuel in the car then check the blockages in the fuel pump if the fuel pump looks proper then check the fuel filter above the fuel pump.
5) If all the above possibilities mentioned above checked out OK/perfect then it’s a electrical issue and the wiring's in the car needs to be checked. The car gets power from the battery to get started. so the wires from battery needs to be checked one by one.
Thanks. Keep updated for any more query. You can rate this solution and show your appreciation.


Posted on Aug 30, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1995 Honda Odyssey automatic. randomly it will have a slight jerk, then check engine light comes on and d4 light blinks while driving on freeway. the speedometer works fine when these lights appear...


First thing to do is have the computer checked for trouble codes. The blinking D4 light means overdrive is not going to function, probably because of the rough running engine.

Feb 14, 2014 | Cars & Trucks

1 Answer

My 2002 a-6 3.0 suddenly started running rough-engine light is on and blinks at 45mph. runs doggedly


Check oil and coolant levels (at the radiator cap) first. Run fault codes to find which sensor triggered the engine light . The light is to tell you that the engine is in danger of failure so do not dismiss the light as not important.. Hot smells mean that the engine is very hot and you may not have any coolant in the system to activate the temp light or gauge.

Dec 08, 2013 | Audi A6 Cars & Trucks

1 Answer

1995 ford 7.3 powerstroke automatic shifts rough after transmission installed after replacing rear main seal


-check your transmission fluid level. park the truck on a level surface with the engine running and pull your dipstick and read the level in regards to the engine and trans temp (hot or cold)
-if that checks out i would go under the truck and check all of the electrical connectors that go to the transmission making sure they are secure and making good contact. also check the wiring to the tcm(normally located on the right side frame rail if i remember correctly)and make sure they are all secure and in good condition

Did you do the rear main seal yourself or did you pay a garage to do it? and is there anything else that was done at that time?

Jan 22, 2013 | 1995 Ford F350

1 Answer

I have a 1998 Dodge Caravan. I got a "tune up" approx. 2 weeks ago with new spark plugs, fuel filter & air filter. It did fine driving around town & on a 130 mile trip. I filled up with...


Sounds like you got a tank of bad gas. That would easily cause your issues. Start by draining as much as you can, put a can of Seafoam in there, add a few gallons of fresh gas, drive to the gas station and tank up, and run that tank down until your gas light comes on before adding more. You may end up needing a fuel filter or plugs again, but with minimal run time on the bad gas, you'll probably be fine.

Jul 29, 2011 | Dodge Caravan Cars & Trucks

1 Answer

When putting van in gear the engine runs rough


how about putting the van in drive with one foot down hard on the brake and rev the engine, does it smooth out now? if it smooths out, i would pull the air cleaner tube to the throttle body and spray the throttle body with carb cleaner, be careful if using the red tube, I have had it blow off before into the intake, not good, open the accelerator and spray it out really good, it will to start until all the cleaner clears out.

Jun 29, 2010 | 1995 Pontiac Trans Sport

3 Answers

2002 express 1500 van, will not start


remove dog house locate test port and install guage should be 45-60 psi

Mar 03, 2010 | 2002 Chevrolet Express

2 Answers

1995 GMC Safari Loses Power when accelerating hard, rough idle


Do you have a check engine light on? Is this a 4.3 with central port injection? If it's running real rich it might have a fuel leak inside the intake, either a fuel pressure regulator leaking or a feed line to the injector.

Aug 23, 2009 | 1995 GMC Safari

1 Answer

1995 Villager Engine light is on


you may have a broken crankshaft snout.This was a common problem on 93-95 Villagers if customer replaced a/c belt and overtightened the belt tensioner.

Did you ecently have the belt changed?
Also, remove distributor cap and rotor ( 1 screw) and slotted plate/ Look for brown dust on optical sensors. If yes clean them and see if van starts. If it starts you will need a new distributor (ebay $200) as the bearing is going.

more help from our villager/quest team

http://autos.groups.yahoo.com/group/villagerquest/

May 24, 2009 | 1995 Mercury Villager

1 Answer

Truck losing power and service engine soon light on


Like to other guy said, give it a tuneup. Also try SEAFOAM to clean carb up of slug. Also check to make sure the butter fly for the choke has not come loose, causing it the choke it down. Failed choke pull-off.

Dec 10, 2008 | 1995 GMC Sonoma

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5481 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...