Question about 1996 Dodge Grand Caravan

1 Answer

Dodge 3.3 engine began running rough. Poor idle. Stumble's on accelloration and backfires. New O2 sensor, new coil, plugs and wires recent. Dissimbles upper engine checked injectors, egr and found vaccum leak at intake plenum, also found fouled #5 plug. I put the engine back to together, started engine - no codes, still running as poorly as before. If it was an old distributor engine I was say that the timing was off.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Had a similar hard-running problem with a 96 ES 3.8 V6; pulled the front valve cover and rocker-arm tube over #5 had split and no longer controlled the i/o valves. had to replace and re-machine #5 valves in the head.

Posted on Sep 22, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Cranks up, stalls, rough idle, no throttle responce


possibly the TPS....also check it for vaccum leaks

Mar 28, 2014 | 2005 Ford Five Hundred

1 Answer

Running rough-1987 Ford Ranger 2.3 L 4 cyl. Had been running very smoothly until 2 weeks ago when it began backfiring and running rough, especially at low speeds, without my having made any adjustmen


If your car has a mas air flow sensor (usualy located right aroung air filter or in air passage after the air filter) check and clean the sensor. This looks like a small spring on the end of 2 wires. BE CAREFUL not to damage the sensor. I have seen where the sensor gets dirty over time and this can cause a rough idle.

Jul 11, 2012 | Cars & Trucks

2 Answers

1998 Dodge Intrepid 2.7 -- After running for 30 minutes, the car starts and runs rough. Driving up to temperature it runs fine. After sitting for 15 minutes or so, when starting it runs rough and will...


it sure sounds like you have an EGR problem. This valve controls the flow of unburned exhaust gases and re-routes them too the intake to be re-burned. This valve is usually open at highway or cruise speeds. Not usually open at idle. If this EGR valve is open at idle, you get a rough running for sure just like a mis fire and will smooth out as your speed increases. I would get that checked out and if faulty, replace. Please keep in mind that this part is quite expensive new, but it is electrically controlled. good luck!

Aug 25, 2010 | 1998 Dodge Intrepid

1 Answer

2002 Isuzu Axiom motor backfiring runs rough put new front O2


common causes for back firing, low fuel pressure, or restricted injectors, breakdown of secondary ignition coil, internal ignition coil arching, or a dead spot in throttle position sensor.

Jul 20, 2010 | 2002 Isuzu Axiom

2 Answers

How do i fix my 2001 cadillac catera idle problem. ive tried fuel injector cleaner, changed the spark plugs, and o2 sensors, but it still idles rough and im throwing these codes. bad o2 sensor bank 1...


The problems you are describing indicate to me that you likely need to replace the coil pack that runs from the spark plugs ,and the plug wires end up at it.It also may be the spark plug wires,get a water bottle and spray the wires after dark and if you get a light show from them then replace them,if not,replace the coil pack.

Jul 15, 2010 | 2001 Cadillac Catera

2 Answers

P0136, P1131, and P1151 codes on Ford Expedition 2000 4.6L


Your auto has four O2 sensors. Two upstream and two downstream; With two banks. Bank 1, sensor 1...and bank 2, sensor 1 are the two upstream (exhaust manifold before the catalytic). Bank 1, sensor 2 and bank 2, sensor 2 (other side of catalytic)

Code 1131= upstream; bank 1..sensor 1
Code 1151= upstream; bank 2..sensor 1
Code P0136 (generic code) bank 1..sensor 2 (questionable)

I wouldn't spend the money to purchase 3 sensors. Highly unlikely all three are bad; Cost is about $40/ ea.
Since there isn't a code for the cat's themselves, I would suspect the O2 circuit is malfunctioning. The rough idle is another clue.


Take an ohmmeter set it on X10 scale and measure the resistance from engine to body and body to negative post on battery terminal. You should read zero ohms (full needle deflection). If you do go buy two upstream O2 sensors. If you read
open or a high resistance run two straps from eng. to body...and body to neg.batt. post.

FixYaWIZ................saailer

Dec 10, 2009 | 2000 Ford Expedition

1 Answer

1995 Ford Windstar with a rough idling 3.8 L. engine.


the speedo gear is in the tranny in that model i believe so thats a seperate issue..

to the rough idle, it could be a multitude of things. the MAF could cause it, you can get one online for cheap. cleaning it is sometimes not enough.the o2 sensors do one thing, that is tell the ecm how much fuel is being burnt in the cylinders, if it is too rich it leans out, if it is too lean it gets rich..

put the vehicle into drive with your foot on the brake, slowly give it gas if it revs like normal it is a spark/ignition problem, which can also be low compression. if it doesnt stumble and run bad with a load on it it is most likly a fuel issue. you have to rememeber that if the o2 sensor is bad, it will cause a misfire by pumping too much fuel into it. try a compression test, remove all plugs, screw in tester, crank engine, record psi. if the psi is lower than %15 of the highest rating then the cylinder has low compression. add a teaspoon of fresh oil into the cylinder and repeat test. if the compression goes up the rings are faulty. if not it could be a bent valve or somethign along the lines of a valvetrain problem.. good luck

Jun 21, 2009 | 1995 Ford Windstar

2 Answers

Dodge dakota, rough idle, backfires, dies under throttle


My 93 Dodge Dakota 3.9 4WD just started doing the exact same thing. Any solution yet?

Jun 02, 2009 | 1994 Dodge Dakota Club Cab

2 Answers

97 dodge dakota


try a crank shaft position sensor
it will not set a hard fault code

May 02, 2009 | Cars & Trucks

3 Answers

Engine rough in low idle


I would start by replacing your automatic air intake and throtle body sensor. Check these 2 things out and let me know.

tepfy

Feb 27, 2009 | 1992 Mercedes-Benz Mercedes Benz 300 Class

Not finding what you are looking for?
1996 Dodge Grand Caravan Logo

744 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8265 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...