Question about Chevrolet Camaro

1 Answer

I have a 92 camaro rs tbi and the alternator and the battery went bad and i just replaced them 2 days ago and now the battery is dead again and after i charge the battery it still wont hold a charge the aternator wont charge the battery

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Contributor
  • 274 Answers

Take it back they have to replace it,they either have a 60-90 day warrenty also see if battery cables are tight.if you have a chrger see if battery holds a charge.

Posted on Aug 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 92 Camaro rs's trunk latch got bent the other


yes, by removing the back seat entirely along with the noise barrier, then crawl through and trip the lock with a flat blade screwdriver..it will be dark in there so use a flashlight or light source of some sort..you may have messed up the switch that controls the trunklight and it may be staying on as well..repost findings..

Feb 10, 2013 | Cars & Trucks

1 Answer

I have a 92 Camaro and the problem I'm having is sorta weird.. My car ran fine about 2 months ago, but i haven't driven it for about 2-3 months. When i went to fire it up the battery was dead, so I...


SOUNDS LIKE YOU NEED BOTH THE ALTERNATOR AND THE STARTER TESTED.THE CAR SHOULD STAY RUNNING OFF THE ALTERNATOR ONCE BOOSTED,IT SHOULD START OFF THE BATTERY WHEN FULLY CHARGED.

Oct 18, 2009 | 1992 Chevrolet Camaro

2 Answers

I have a 1.8L 2003 Audi TT Roadster. About 2 months ago after not driving the car for a week, I the battery went dead, but I did not get any warning lights. Replacing the battery seemed to fix the problem....


Hi,

Thanks for using Fixya!

Sounds like you have an alternator problem. The alternator may have gone bad due to non use. Some parts inside may have rusted out and got damaged. Better bring your car to your local mechanic and have the alternator checked.

Have a wonderful day.
- HotRatchet

Jul 26, 2009 | 2003 Audi TT

1 Answer

My 92 camaro rs v8 won't start.Replaced starter and bypassed VATS


if battery and conectors are very clean and tight,check for bad ground to engine from battery,,also fusable links off of starter or positive small post near fuses, important,,,is the alternator charging ? and have u tried a new battery? voltage should read 13.50 to 14.25 while running 12.5 to 12.65 when not running

Jun 29, 2009 | 1992 Chevrolet Camaro

1 Answer

92 RS Camaro, Replaced battery and now car has no power?


are your battery post bolts clean and tight, my 89 rs ran fine untill i decided i wanted shiny new battery bolts, when i put them in and tightened them down my car had no power at all, i checked how tight they were, and they were TIGHT so i wiggled the black cable and re tightened it and bam my lights turned on, tryied starting it, and it started, sometimes you just gotta make sure the connection is really good, not just how tight it is, also check your ground wires, there are a few but the main 2 are located at the front pass side next to the batt, and on the back firewall going from the bottom pass head to the firewall, hope that helps, if not comment back

Mar 17, 2009 | 1992 Chevrolet Camaro

2 Answers

I have a charging problem on my 89 camaro


So found the problem it was the seilnoid on the wasnt working properly store said good put it back hit with small hammer fired up so just replaced whole strarter now fires first time sounds awesome had lot of trouble tracking it down went threw new battery's thinking that was prOblem but was bad starter unit try this maybe will help u to

Jul 01, 2008 | 1989 Chevrolet Camaro

4 Answers

1998 Ford Explorer


I've had similar problems on Fords whit batteries going dead very quickly the fastest one was a relay stuck on specifically the fuel pump relay(1986 tbird) and once it was the EEC power relay (1991 F150) both caused the fuel pump to stay running and in less than an hour my battery was dead. I also had an f150 (92) that had a bad glove box light switch) but it would take a day or so. I'd check to see if you have a bad relay that is causing a motor to run, fuel pump, or electric cooling fan(if equipped) otherwise you have some sort of short in the system draining your battery they are usually not so quick.

Jun 11, 2008 | 1998 Ford Explorer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...