Question about Land Rover Range Rover

1 Answer

Can not get a good spark on 3.9 v8 efi. very very faint spark, renewed coil, 12.71 volts going in but not alot coming back out. can you help??????????

Posted by on

  • 3 more comments 
  • Jeff Turcotte
    Jeff Turcotte Aug 29, 2010

    If you have breaker ignition, check points gap or dwell.

  • mattkyte Aug 29, 2010

    i can not get a spark out of the coil, there is a very faint spark but thats it. theres power going in but the spark is very poor.??????

  • mattkyte Aug 29, 2010

    is any body there???

  • mattkyte Aug 29, 2010

    yep its all fine just not a good spark

  • mattkyte Aug 30, 2010

    can you tell me what wires should be going to the coil and witch way around please???????? 3.9 efi range rover

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Expert
  • 4,070 Answers

Hi! Have you replaced the plug wires? THe plug wires may be worn and may have current leakage. Please try to replace the plug wires and see how it goes. Hope this helps and thank you for using FixYa!

Posted on Aug 29, 2010

  • 5 more comments 
  • dj_relly999
    dj_relly999 Aug 29, 2010

    If that's the case, then the ignition coil is near to it's break point. The poor spark is one good sign that you need to replace the ignition coil. Once replaced you'll be good.

  • dj_relly999
    dj_relly999 Aug 30, 2010

    Hi! Hows it going?

  • mattkyte Aug 30, 2010

    hi! got a spark but the timings out, any info that can help me set it back up??? many thanks

  • dj_relly999
    dj_relly999 Aug 30, 2010

    How bout taking off the belt and set up the timing marks. The timing marks may be off thats why it has a poor spark. Have you tried swapping the distributor?

  • mattkyte Aug 30, 2010

    thank you for the fast reply!!! i have swapped the distributor and now i have a good spark, but it will not start?? not to sure where the timing marks are and how i do it?? i think the timing has gone out though me changing the distributor?? any idear of what to do now?? thank you

  • dj_relly999
    dj_relly999 Aug 30, 2010

    Fuel pump running? If not, it's a possible cause why it's not running.

  • mattkyte Aug 30, 2010

    yep its all fine! any idear of how to set the timing???

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I'm having trouble getting any spark


Check there is 12 volts + terminal of coil , Check the coil HT cable resistance is within specs , remove the center Ht cable from the distributor , hold it a 1/4 inch from the engine block, have a helper engage the starter , a good spark should jump from the cable to the engine block. also check the spark plug Ht cables and renew if not to specs.

Dec 27, 2014 | Cars & Trucks

2 Answers

What could cause a1991 suzuki samurai to have no fire from a new coil?


no spark from coil directly?
is the cam turning, is the dizzy rotor spinning. ????

check all fuses first. Ig-coil, FI and dome.
then using diagnostic jumper wire or fuse, (as approp)
crank engine look for code 41 o 42.!!!

USA cars , answers only
our cars are all EFI that year.
no engine swaps to Suzuki G16A/B sidekick or tracker engines.!
1: engine cranks
2: no spark
3: The ECu makes spark
the CMP sensor in the DIzzy , (never fails if rotor turns, does rotor turn, if not cam belt igored and now snapped.)
the cam turns. the CMP fires. the ECU takes this CMP signal
and fires the ignitor next to coil and the coil charges, and release and BAM spark.

that is it.
the ECU will tell you when the CMP dies or the Ignitor fails
why not ask it.
1: key on
2: diagnostic jumper in place (flashes 12s for ok)
3: crank engine,for 5sec, not 1 ,not 2.
3: release key not off.
4: see code 41, or 42, BINGO !@!!!!

Aug 15, 2014 | 1991 Suzuki Samurai

1 Answer

Lost power in celsior v8


what country
4.0 L 1UZ-FE V8 its a fuel injected V8. used in Lexus LS400s in USA.
i restore old cars and 1990 is old.
lost power can be misfire , does it do that hot /cold or both engine temp? loss power, under what coolant temps.
so if the tranny dont slip or brakes drag. (car rolls easy) then
the engine is sick , this is an EFI engine.
on all old engines. Get a real FSM, for sure.!!!
  1. check compression, first. 150psi or more. good on all 8 (W.O.T)
  2. tune it up, wires plugs, cap ,rotor.. filters. (all)
  3. Ignition timing: 8 -12deg BTDC @ idle (Transmission in neutral position)? 1-8-4-3-6--7-2, firing order sparks wired right?
  4. I then make sure fuel pressure is at spec,
  5. at the same time. the classic injector leak down test.
  6. at the same time, the classic, injector balance test.
  7. With all that good the EFI system has hope.
  8. I then check the ECU for DTC errors, (flash codes )an address all those.
  9. the eng. thermostat get to 180F or more fast and holds !!!
  10. if clean the MAF a dirty MAF, will cause lean and lean causes bogging and huge loss of engine power
  11. does the engine hold closed loop. at idle and at 2500 rpm in neutral (hot engine) id bet not.
  12. no scan tools so all you have is a blinking CEL lamp test so do that check. The check jumper wire.
  13. on these old dogs, i must check every sensor by hand due to no SCAN tools in 1990
  14. thats enough, for now. I see wasted spark coil packs, got misfire?

Feb 18, 2014 | Toyota 105 Cars & Trucks

1 Answer

Je89 ignition


1989 Jeep Cherokee (i had an 88) for 250k miles.
is this the EFI engine , 4.0L I6?, what country?

if yes, it has the old funky Renix Bendix EFI.
never seen an after market scan tool work here.
but try here. for how to get the CEL to flash , error codes
all EFI can report, CMP , or CKP sensors bad. for no spark
EFI fires the coil with an Ignitor.
see if its here.
http://www.scantool.net/software/alldata-diy-1-month-subscription.html

the EFI can report, 3 type ignition failures, so scan it.
see why?

Jan 18, 2014 | 1989 Jeep Cherokee

2 Answers

No spark from ignition coil to start the engine of suzuki vitara16v EFI engine. what is the cause of it


what year? what country? sounds like suzuki G16b engine. is it? or 2.0L?
The reasons are the same basically for G16 or the 2.0L
Both engines have ECU.
Both need good fuses to power ECU and coils.
Both engines need working CMP.
my guess is this is a distributor engien G16b (YOU SAND COIL NOT COILS.)
1: fuses, test the fuses relate to ECM/PCM (3 fuses)
CEL LAMP MUST BE ON KEY ON OR ECU HAS NO POWER.
2: g16B( CRANK FOR 5 seconds), with scan tool connected.
A $50 tool that is indispensable.
P0355 or P340 DTC , bingo, no spark.
or while cranking RPM is dead at 0 RPM.
if all that passes, then check the coil signals. (@ minus term)
The coil has an ignitor in the dizzy and both can go bad.
recap.
power 12v to ECU
CMP working
ECu sees CMP and sends spark to dizzy ignitor.
Ignitor , drives coil, coil makes spark ,engine runs.
nut shell

Mar 09, 2013 | Suzuki Vitara Cars & Trucks

1 Answer

1996 chevy silverado v8 4.3 won't crank. Replaced


Check the voltage coming from the battery and check it again at the coil.I suspect you are not getting the proper voltage going through. Clean all the terminal ends to bare shiny metal and make sure all the connections are tight. If I remember correct your truck still has the HEI setup with the coil in the top of the distributor cap. If all the voltages are good, 12+ volts you should replace the coil. Hope this helps.

Nov 06, 2011 | 1996 Chevrolet K1500

2 Answers

What order do the wires go on the distributor cap


You didn't post your engine size so please use the appropriate diagram:


71f6763.gif

GM (Cadillac) 250 (4.1L) V8 .GM (Cadillac) 273 (4.5L) V8 .GM (Oldsmobile) 307 (5.0L) V8 .GM (Oldsmobile) 350 (5.7L) V8 w/EFI.Engine firing order: 1-8-4-3-6-5-7-2 .Distributor rotation: counterclockwise



cc0b68a.gif

GM (Buick) 252 (4.1L) V6 .Engine firing order: 1-6-5-4-3-2.Distributor rotation: clockwise



23d7821.gif

GM (Cadillac) 368, 425, 472, 500 V8.Engine firing order: 1-5-6-3-4-2-7-8.Distributor rotation: clockwise



c614b2b.gif

GM (Cadillac) 429 V8.Engine firing order: 1-8-7-2-6-5-4-3.Distributor rotation: clockwise

May 12, 2010 | 1976 Cadillac Deville

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...